LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-04-2012, 09:47 PM   #1
marmirelo
LQ Newbie
 
Registered: Apr 2012
Posts: 6

Rep: Reputation: Disabled
debian 6.0.1 (squeeze) is misbehaving - does not give login screen


My system was working fine until I used the synaptic package manager to install some new software. I selected a number of packages and went away. When I came back I had a plain blue screen with just the day and time at the top and white window in the centre of the screen with the host name. When I click on this it switches to display the system name and version. The only active point in the screen is the top right where I can choose to suspend, restart, shutdown. All text on this screen is a basic font.
This blue screen is not the usual gnome gui screen, it is plain blue like the windows crash screens.
It appears that the gnome gui is not being loaded.
Can anyone suggest how I can start to figure out where the startup process is falling over.
Is it possible that I selected packages for kde and that this has stuffed up the startup process.
I can boot in recovery mode and get a command line when I login as root.
Thanks
 
Old 04-04-2012, 10:26 PM   #2
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 636Reputation: 636Reputation: 636Reputation: 636Reputation: 636Reputation: 636
What did you install? You may have installed something that breaks other packages and, because of this, removes them. If you can use the command line type in
Code:
apt-get install gnome-core
and that may bring it all back for you.
 
Old 04-05-2012, 12:51 AM   #3
marmirelo
LQ Newbie
 
Registered: Apr 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
broken packages - empathy won't install - debian 6.0.1 squeeze

Quote:
Originally Posted by k3lt01 View Post
What did you install? You may have installed something that breaks other packages and, because of this, removes them. If you can use the command line type in
Code:
apt-get install gnome-core
and that may bring it all back for you.
thanks the above helped, though not fixed.
on first attempt with the above code, I got a message that there were broken packages and to run manually the command:
dpkg --configure -a
which I did.
After this I ran apt-get install gnome-core and got the message "some packages could not be installed ....
the following packages have unmet dependencies:
gnome-core : depends: empathy (>= 3.0) but it is not going to be installed.
E: Broken packages"
I rebooted and got the gnome login panel but when I logged in I got the message "gnome could not load" and I was logged out.

Any help on how I can repair my self inflicted damage would be much appreciated.
Thanks
 
Old 04-05-2012, 01:02 AM   #4
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 636Reputation: 636Reputation: 636Reputation: 636Reputation: 636Reputation: 636
Do you know what packages you tried to install? We really need to know what packages are causing the breakage. Empathy is part of Gnome so if it is broken something you have installed has broken it.

If you don't it may just be easier to do a clean re-install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeeze keeps logging out to login screen when saving doc's etc. iceniyak Debian 14 11-11-2011 06:23 PM
[SOLVED] Broken login screen debian squeeze MartyJay Linux - Newbie 17 11-07-2011 06:36 PM
LXer: Debian Squeeze updates gdm3 today, and goofy spaceship theme is on the login screen too LXer Syndicated Linux News 0 12-09-2010 07:00 PM
[SOLVED] [squeeze] login screen and network grayed out wch705 Debian 6 10-02-2010 03:23 AM
SUSE 10 on thinkpad doesn't give login screen, it just boots right up LordFett Linux - Laptop and Netbook 4 01-17-2006 12:13 AM


All times are GMT -5. The time now is 10:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration