LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-02-2006, 12:54 PM   #1
DanTaylor
Member
 
Registered: Jan 2006
Distribution: Debian Sarge
Posts: 265

Rep: Reputation: 30
Debian 3.1 kde


I just installed Debian Sarge and I found that I can't make it autoselect kde for startup, but when I boot kde it has most of gnome's(which I hate) visual characteristics and runs like it. What can I do to change these? Also, the screen won't resize past 800x600 which is really bad on a 19 in. monitor. Please Help!
 
Old 02-02-2006, 12:59 PM   #2
DanTaylor
Member
 
Registered: Jan 2006
Distribution: Debian Sarge
Posts: 265

Original Poster
Rep: Reputation: 30
Debian noob needs help

I just installed Debian 3.1 Sarge and I can't get it to autoboot to kde. It lets you boot it once you get to a login screen but it has many of the gnome features that way. What can I do?
Also, I can't resize my screen past 800x600(really bad on a 19in. monitor). Please Help!
 
Old 02-02-2006, 01:13 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 64
Quote:
Originally Posted by DanTaylor
I just installed Debian Sarge and I found that I can't make it autoselect kde for startup, but when I boot kde it has most of gnome's(which I hate) visual characteristics and runs like it. What can I do to change these? Also, the screen won't resize past 800x600 which is really bad on a 19 in. monitor. Please Help!
For the first apt-get install kdm and when the dialog asks choose kdm from the list as the default. For the second get the refresh rates ranges for the vertical and horizontal that are supported by your monitor (if you do not have the manual handy a quick Google search on the make/model number usually comes up with these) then dpkg-reconfigure xserver-xfree86 choose advanced then when you come to those questions put them in making sure that when you get to the resolutions you want to use that you select a higher one than the 800x600 as well. Now logout and use Left Control + Left ALT + Backspace keys at the same time to kill off and respawn the X server. If at the command line when doing then /etc/init.d/kdm start if you still had the gdm running then you would have wanted to have used /etc/init.d/gdm stop before the kdm command.
 
Old 02-02-2006, 01:18 PM   #4
lestoil
Member
 
Registered: Apr 2004
Location: new york
Distribution: win2k,ubuntu,sw13,arch,centos5.3
Posts: 815

Rep: Reputation: 31
Your question is not clear. Assuming this is a new install when tasksel asked did you pick desktop system or installed pkgs individually? Sarge defaults to gdm and gnome but in login screen you can pick different desktop and choose it as default desktop. Man gdm will help.
You need correct horiz. and vert. ranges for your monitor model(from manual or google) or optimal settings for lcd and best video driver for your video card to get desired desktop settings. As root lspci will give useful info. Then dpkg-reconfigure xserver-xfree86 or XF86config or XF86cfg can then be used for better display setting. Review Debian Configuration Post Install at top of this forum. http://www.debianhelp.co.uk/ may be useful too. good luck.
 
Old 02-02-2006, 01:19 PM   #5
Dragineez
Member
 
Registered: Oct 2005
Location: Annapolis
Distribution: Ubuntu
Posts: 275

Rep: Reputation: 32
What video card?
gdm? kdm? Sure you have kde installed?
Can we see your x config file?

We'd love to help, but not much to go on.
 
Old 02-02-2006, 01:21 PM   #6
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Do you mean that it won't let you auto login to KDE? And what do you mean by
Quote:
it has many of the gnome features that way.
As for resizing your screen, try using dpkg-reconfigure xserver-xfree86 as root and have the specs for your monitor handy (refresh rates, maximum resolution, etc).
 
Old 02-02-2006, 03:53 PM   #7
DanTaylor
Member
 
Registered: Jan 2006
Distribution: Debian Sarge
Posts: 265

Original Poster
Rep: Reputation: 30
I'll get those as soon as I can, but I don't have access to my computer right this minute - however, I am sure it is not my video card as I was running knoppix 3.2 and it worked fine with res way past 1280x. My main problem with the boot is that when debian starts up, it pops up a screen that you choose what gui you want to use, and when you choose kde, it keeps all the gnome settings and programs(including config) and drops alot of the kde ones.
 
Old 02-02-2006, 03:58 PM   #8
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
Do you need gnome? If not then you can remove it and that should solve the problem.Try this command:
Code:
update-alternatives --set x-session-manager
/usr/bin/startkde
 
Old 02-02-2006, 03:58 PM   #9
DanTaylor
Member
 
Registered: Jan 2006
Distribution: Debian Sarge
Posts: 265

Original Poster
Rep: Reputation: 30
I don't have an option on my boot screen to chose kde as the default login, and when I run it, it keeps most of the gnome config programs and drops most of the kde ones. As for the res support of my monitor, I ran knoppix with the kde desktop and it ran above 1280x .

During the install I chose to install the kde packeges and that didn't work, so I had it do autoinstall with the same results - however my friend knows a lot more about linux than me and he is helping me now so thanks for the help.
 
Old 02-02-2006, 04:10 PM   #10
DanTaylor
Member
 
Registered: Jan 2006
Distribution: Debian Sarge
Posts: 265

Original Poster
Rep: Reputation: 30
That fixed the problem - still don't know what it was though. Thanks for the help.
 
Old 02-02-2006, 04:12 PM   #11
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
I had the same problem once, so I had to remove gnome ... I find it a waste having two different desktop managers. Get the one you like and stick with it.
 
Old 02-02-2006, 04:15 PM   #12
DanTaylor
Member
 
Registered: Jan 2006
Distribution: Debian Sarge
Posts: 265

Original Poster
Rep: Reputation: 30
gnome is a pain in the butt - almost as bad as the Win. gui.
 
Old 02-02-2006, 04:38 PM   #13
ksgill
Senior Member
 
Registered: Apr 2003
Location: Toronto, Canada
Distribution: Ubuntu Jaunty (9.04)
Posts: 1,044

Rep: Reputation: 45
LOL, there's nothing like Windows GUI
 
Old 02-02-2006, 05:00 PM   #14
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Moved: This thread is more suitable in Linux-Newbie and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 02-02-2006, 05:10 PM   #15
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
The two threads, posted in Newbie and Debian have been merged.
 
  


Reply

Tags
debian, kdm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Review - Debian was made for KDE vxc69 Debian 23 05-28-2007 08:56 AM
LXer: People Behind KDE: Debian Qt/KDE Packagers LXer Syndicated Linux News 0 12-18-2005 06:16 PM
Debian, KDE mazuho Debian 3 08-20-2005 12:42 PM
kde 3.4 in Debian Arnaud_B Debian 2 06-14-2005 03:35 PM
Kde with debian Jar-Jar Bins Linux - Hardware 3 08-15-2003 08:37 PM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration