LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-03-2010, 03:51 PM   #1
Antiz
LQ Newbie
 
Registered: Apr 2010
Posts: 12

Rep: Reputation: 0
Debian 1440x900 resolution problem


Hi, i have just installed debian only to be greeted with a very high resolution... too high for my monitor. After installing the driver for my 9800 GTX the resolution changed to 640x480 and there were no other options to change it. I have read around the forums and changed my xorg.conf file to look like this:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
# Option "ModeDebug" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
SubSection "Display"
Modes "1440x900"
EndSubSection
EndSection

My monitor is a widescreen which is perfect at 1440x900 resolution but there is the problem. This xorg.conf , allthough stated resolution 1440x900 doesnt allow me to pick this setting neither in Nvidia settings or in Debian resolution settings. I can only choose 1280x800 even though there are other modes such as 1024x768. At 1280x800 my screen looks very blurry and lacks sharpness. I dont know what else i could do to fix this. Any help would be appreciated. Thanks in advance
 
Old 04-03-2010, 07:01 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Jessie 8.4
Posts: 5,873

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
At the risk of sounding like a nasty old grouch, I'll point out that the monitor displays the signal it gets from the graphics card. So, what have you done in re installing the nvidia driver (from nvidia, not the generic nv driver)?
 
Old 04-03-2010, 07:15 PM   #3
Antiz
LQ Newbie
 
Registered: Apr 2010
Posts: 12

Original Poster
Rep: Reputation: 0
I installed the driver from nvidia page. I couldnt change the settings in nvidia control panel so i edited the xorg.conf
 
Old 04-03-2010, 07:33 PM   #4
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,275

Rep: Reputation: 126Reputation: 126
Quote:
Originally Posted by Antiz View Post
I installed the driver from nvidia page. I couldnt change the settings in nvidia control panel so i edited the xorg.conf
What, exactly, does this mean? Does it mean that there was no option for 1440x900, or that you couldn't save it to xorg.conf after you had changed it? If the former, you're out of luck. If the latter, then open a terminal and run it this way: "gksu nvidia-settings". The problem is that you need root privileges to change xorg.conf and it generally runs as your userid, when selected from gnome.
 
Old 04-03-2010, 07:52 PM   #5
Antiz
LQ Newbie
 
Registered: Apr 2010
Posts: 12

Original Poster
Rep: Reputation: 0
The problem is that there was no option for 1440x900. I was stuck with 640x480 until i added the line to xorg.conf. Even though it sayd mod 1440x900 there is no option for that mod, only 1280x800 and 1024x768 which doesnt work.
 
Old 04-03-2010, 08:05 PM   #6
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,276

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
That's strange -- I've never had this sort of problem with the Nvidia driver. What kind of monitor do you have (brand and model)? You should also tell us which version of Debian you are using and the exact error from your xorg log file when you try to start X with the xorg.conf you posted (look for lines beginning with (EE) in /var/log/Xorg.0.log). The first thing to do is make sure that the driver is loading correctly; the xorg log file will also tell you this.
 
Old 04-03-2010, 08:15 PM   #7
Antiz
LQ Newbie
 
Registered: Apr 2010
Posts: 12

Original Poster
Rep: Reputation: 0
I am using a HP w1907v widescreen monitor. When i load X with my xorg.conf it loads and i get no error but i dont get the screen is all blurry and not as sharp as it should be. There are several resolution choices but only 1280x800 and 640x480 work.

Here is the log from xorg.conf

II) Setting vga for screen 0.
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Apr 04 01:16:56 NVIDIA(0): Enabling RENDER acceleration
(II) Apr 04 01:16:56 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Apr 04 01:16:56 NVIDIA(0): enabled.
(WW) Apr 04 01:16:57 NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) Apr 04 01:16:57 NVIDIA(0): NVIDIA GPU GeForce 9800 GT (G92) at PCI:2:0:0 (GPU-0)
(--) Apr 04 01:16:57 NVIDIA(0): Memory: 524288 kBytes
(--) Apr 04 01:16:57 NVIDIA(0): VideoBIOS: 62.92.84.00.00
(II) Apr 04 01:16:57 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Apr 04 01:16:57 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Apr 04 01:16:57 NVIDIA(0): Connected display device(s) on GeForce 9800 GT at PCI:2:0:0:
(--) Apr 04 01:16:57 NVIDIA(0): CRT-0
(--) Apr 04 01:16:57 NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) Apr 04 01:16:57 NVIDIA(0): Assigned Display Device: CRT-0
(WW) Apr 04 01:16:57 NVIDIA(0): No valid modes for "1440x900"; removing.
(WW) Apr 04 01:16:57 NVIDIA(0):
(WW) Apr 04 01:16:57 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Apr 04 01:16:57 NVIDIA(0): "nvidia-auto-select".
(WW) Apr 04 01:16:57 NVIDIA(0):
(II) Apr 04 01:16:57 NVIDIA(0): Validated modes:
(II) Apr 04 01:16:57 NVIDIA(0): "nvidia-auto-select"
(II) Apr 04 01:16:57 NVIDIA(0): Virtual screen size determined to be 1024 x 768
(WW) Apr 04 01:16:57 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) Apr 04 01:16:57 NVIDIA(0): from CRT-0's EDID.
(==) Apr 04 01:16:57 NVIDIA(0): DPI set to (75, 75); computed from built-in default
(==) Apr 04 01:16:57 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit

it seems that the mode 1440x900 is not supported. I have tried to mess with xorg.conf and changed 1440x900 to 1280x800 and xorg.log says it is validated, however my screen resolution is still blurry and lacks sharpness. My monitor is optimized for 1440x900.

Last edited by Antiz; 04-03-2010 at 08:26 PM.
 
Old 04-06-2010, 09:20 AM   #8
Antiz
LQ Newbie
 
Registered: Apr 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Anybody any thoughts?
 
Old 04-06-2010, 09:58 AM   #9
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Have you tried 1400x1050 as it is reasonably close to your desired 1440x900 - just a thought!
 
Old 04-06-2010, 10:23 AM   #10
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
This *may* be what you are looking for:

http://wiki.debian.org/XStrikeForce/HowToRandR12

Specifically section 111.5.
Although i've never had to use this myself when i use the Nvidia driver.
Have you checked the driver is working?.

Last edited by the trooper; 04-06-2010 at 10:27 AM.
 
Old 04-06-2010, 12:34 PM   #11
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
xorg is complaining that it cannot read the EDID from your monitor, so it doesn't know its capabilities, so it just guesses 640x480.

How are you connecting the monitor to your NVIDIA card? I suggest you try booting after changing the connection to a different type.

[Edit:] Best to rename xorg.conf to xorg.conf.old before you reboot, or it may still try to use invalid values, instead of probing your monitor's EDID and working out what it is capable of.
[/Edit]

Tell us what happens when you do this.

Last edited by tredegar; 04-06-2010 at 12:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LG L194WT 1440X900 Resolution Problem Daedra Linux - Hardware 5 12-22-2011 06:09 PM
1440x900 Resolution mrsolo Linux - Laptop and Netbook 3 11-15-2010 11:27 PM
1440x900 resolution problem .. help fishstick SUSE / openSUSE 71 10-10-2008 12:50 AM
Intel GMA 900 1440x900 Resolution Problem Omnipresence Linux - Hardware 1 10-06-2008 05:13 PM
I-INC 19" flat screen 1440x900 resolution problem widhari Linux - Hardware 1 08-06-2008 09:14 AM


All times are GMT -5. The time now is 10:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration