LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-30-2007, 12:11 PM   #1
Instantly
Member
 
Registered: Dec 2004
Posts: 78

Rep: Reputation: 15
Deb Files


there is something wrong when installing .deb files
im getting
Code:
user@adminPC:~$ sudo dpkg -i /home/user/Desktop/LimeWireLinux.deb
Selecting previously deselected package limewire-basic.
(Reading database ... 84437 files and directories currently installed.)
Unpacking limewire-basic (from .../user/Desktop/LimeWireLinux.deb) ...
dpkg: dependency problems prevent configuration of limewire-basic:
 limewire-basic depends on sun-java5-jre | sun-java6-jre | sun-java5-jdk | sun-java6-jdk; however:
  Package sun-java5-jre is not installed.
  Package sun-java6-jre is not installed.
  Package sun-java5-jdk is not installed.
  Package sun-java6-jdk is not installed.
 limewire-basic depends on libgnome2-0 (>= 2.14.1); however:
  Package libgnome2-0 is not installed.
 limewire-basic depends on libstdc++5 (>= 1:3.3.4-1); however:
  Package libstdc++5 is not installed.
dpkg: error processing limewire-basic (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 limewire-basic
user@adminPC:~$
what's wrong?
 
Old 06-30-2007, 01:00 PM   #2
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
The error messages are telling you what's wrong;

Quote:
limewire-basic depends on sun-java5-jre | sun-java6-jre | sun-java5-jdk | sun-java6-jdk; however:
Package sun-java5-jre is not installed.
Package sun-java6-jre is not installed.
Package sun-java5-jdk is not installed.
Package sun-java6-jdk is not installed.
limewire-basic depends on libgnome2-0 (>= 2.14.1); however:
Package libgnome2-0 is not installed.
limewire-basic depends on libstdc++5 (>= 1:3.3.4-1); however:
Package libstdc++5 is not installed.
you need to install one of the above java packages, libgnome2 and libstdc++5.
 
Old 06-30-2007, 01:26 PM   #3
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Unlike apt/synaptic, dpkg doesn't handle dependencies automatically. If your .deb package needs some library or something, then you need to install it separately.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DEB files rgreeves Ubuntu 3 12-18-2006 09:09 PM
.deb files isuck@linux Linux - Software 6 08-04-2006 09:22 PM
.deb files on RH MKSN Linux - Newbie 6 07-18-2006 08:47 AM
how to use .deb files???? E.M.P99 Linux - Newbie 4 04-11-2006 03:41 PM
.deb files unkind Debian 2 11-29-2003 09:48 PM


All times are GMT -5. The time now is 07:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration