LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 02-09-2008, 02:02 AM   #16
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15

You can see that the driver r8169 is loaded.
eth0 has no IP. The green indicator back on the PC is not light on - "dead" network adapter.
 
Old 02-09-2008, 07:10 AM   #17
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Maybe you should not use dhcp if you have a router. As I said, I have the same chip and it works fine with almost everything but not FreeBSD, which will only work if I use a fixed address. I guess this has nothing to do with the realtek chip itself but with my router. Since Slackware is more like FreeBSD than Linux in some respects, it may be interesting to see whether you can get it working by setting a fixed address.
 
Old 02-09-2008, 07:20 AM   #18
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jay73 View Post
Maybe you should not use dhcp if you have a router. As I said, I have the same chip and it works fine with almost everything but not FreeBSD, which will only work if I use a fixed address. I guess this has nothing to do with the realtek chip itself but with my router. Since Slackware is more like FreeBSD than Linux in some respects, it may be interesting to see whether you can get it working by setting a fixed address.

I tried with a fixed address, given me from my ISP (Internet Service Provider) to probe, nemask, gateway, nameservers ... but the situation is the same - no connection. When I set fixed IP, the eth0 device accept it. Then when I make a ping, I have ping to myself (127.0.0.1), but no to anything other IPs.
I remind you - the device is freezing or sleeping, its indicator not lights on. In Windows is green and another yellow indicator is blinking when have connection.

Last edited by Fleshless; 02-09-2008 at 07:21 AM.
 
Old 02-09-2008, 07:26 AM   #19
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 222Reputation: 222Reputation: 222
type in a terminal as root ifconfig eth0 up. the the right module is loaded it will be up. in kde go to you little gui interface control pannel and go to net work settings tell it you are using slack 10.2 and then configure it to boot dhcp good luck. if you type ifconfig eth0 up and it says device not found then modprobe the driver type ifconfig eth0 up. good luck. this all is done as root.
 
Old 02-09-2008, 07:38 AM   #20
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Drakeo View Post
type in a terminal as root ifconfig eth0 up. the the right module is loaded it will be up. in kde go to you little gui interface control pannel and go to net work settings tell it you are using slack 10.2 and then configure it to boot dhcp good luck. if you type ifconfig eth0 up and it says device not found then modprobe the driver type ifconfig eth0 up. good luck. this all is done as root.
Thanks Drakeo. To do that I have a question. How can "say" to the PC in the network settings interface window, that I have a Slackware 10.2?
 
Old 02-09-2008, 07:43 AM   #21
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
I forgot to tell something!
When I installed the Slackware 12.0, then he didn't recognize my network device. When I went to the Settings --> Network settings, it appeared a window "Your platform is not compatible! Please choose from the following distro's one, that You are SURE that works:"
And I choosed Ubuntu 7.10, because somewhere in the netforums I had read that this distibution supports this card ... But I think (this is my opinion - but i'm newbie!) that this choice is meaningless. Then this windows not appears any more. How can return it? Maybe exact there I can "lie" the PC that I have Slackware 10.2?

Last edited by Fleshless; 02-09-2008 at 07:47 AM.
 
Old 02-09-2008, 10:45 AM   #22
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
OK, Drakeo,
I reinstalled the Slackware to make it again be able to see this window "uncompatible platform".
I choosed "Slackware 10.2.0"; configured dhcp.
Nothing has changed. No network. No light on network adapter.

But before make the installation this time, I probed with the installation DVD that my network adapter use protocol r8169 successfully. Now I'm sure that the driver r8169 would be able to work.

And now I'm in the begining again ...
How can I make this adapter to "wake up" and start networking?
 
Old 02-09-2008, 12:40 PM   #23
zoranp
Member
 
Registered: Nov 2007
Location: Belgrade, RS
Distribution: Mandriva 2009.0 X86_64
Posts: 44

Rep: Reputation: 15
All you should do to enable your network adapter in GNU/Linux is to boot into Windows and in network card properties (My computer - Manage - Network cards - ...) enable "Wake on LAN".
 
Old 02-09-2008, 04:51 PM   #24
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by zoranp View Post
All you should do to enable your network adapter in GNU/Linux is to boot into Windows and in network card properties (My computer - Manage - Network cards - ...) enable "Wake on LAN".
HA HA HA!!!
You are great!!!
Now works and I have internet!!!

So people! There is the simply solution ---->

If anyone have this problem, do what zoranp said!
Go to windoz --> right click My comuter --> manage --> in the network adapter Properties set "Wake on shutdown" to ENABLE!
Now everything is fine - when boot in Linux the green light of the adapter is ON and the network is there, whitout any settings!!! The dhcp gave all the needed information to the system ))))

Last edited by Fleshless; 02-09-2008 at 05:05 PM.
 
Old 02-09-2008, 04:52 PM   #25
Fleshless
LQ Newbie
 
Registered: Feb 2008
Location: Rousse, Bulgaria
Distribution: Slackware 12.0
Posts: 22

Original Poster
Rep: Reputation: 15
I think this is the happy end of this thread!

I think I will soon start a new one - the bt878 card and the tvtime - I have still problems with it and can't watch tv, but first I'll enjoy surfing in internet ))

Last edited by Fleshless; 02-09-2008 at 05:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with "Asus WL-138g V2 Wireless PCI Adapter" maiden2 Ubuntu 2 02-26-2008 02:49 AM
how to activate my Asus "WL-138g V2" Wi-fi PCI Adapter in fedora 8? maiden2 Fedora 2 12-10-2007 02:45 AM
Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card nsyng Fedora - Installation 1 06-06-2005 07:53 AM
Failed detection of "Realtek Semiconductor Co., Ltd. RTL-8139" network card scuffell Linux - Networking 5 06-15-2004 06:34 AM
Define "dead ethernet card" please. wuck Linux - Networking 10 10-26-2003 10:58 PM


All times are GMT -5. The time now is 10:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration