LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-02-2003, 06:29 AM   #1
grim1234
Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware 10.2, Fluxbox.
Posts: 64

Rep: Reputation: 15
Question dcop / root x config problem - can you help?


hello, could someone help me with this problem?

I am running slack 9 with kde3 as a standard user. I would like to be able to run x applications as root. To this end I added localhost to the xauth file with "xhost + localhost". This allowed me to get xapps as root but now I get the following errors -

-----
root@duckpond:/home/grim# /opt/kde/bin/kwrite
sh: line 1: iceauth: command not found
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
ICE Connection rejected!

DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
DCOPServer self-test failed.
ICE Connection rejected!

sh: line 1: iceauth: command not found
kdeinit: DCOPServer could not be started, aborting.
root@duckpond:/home/grim# man col
root@duckpond:/home/grim# /opt/kde/bin/kwrite |col >/home/grim/dcop
sh: line 1: iceauth: command not found
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
ICE Connection rejected!

DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
DCOPServer self-test failed.
ICE Connection rejected!

sh: line 1: iceauth: command not found
kdeinit: DCOPServer could not be started, aborting.
------

and the xapp actually works (with root's window preferences). Can someone explain how the dcopserver / client system works and what an ICE connection is? Also, any insight as to why I get this error and how to solve the problem would be great.

Thanks,

Graham.
 
Old 09-02-2003, 04:52 PM   #2
grim1234
Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware 10.2, Fluxbox.
Posts: 64

Original Poster
Rep: Reputation: 15
anybody?
 
Old 02-03-2004, 10:42 AM   #3
Bruce Edge
LQ Newbie
 
Registered: Feb 2004
Location: Southern California
Distribution: debian
Posts: 1

Rep: Reputation: 0
Ever figure it out?
I'm having the same issue.

-Bruce
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE (DCOP) problem starting root after forced reboot powadha Linux - Software 2 05-30-2004 05:14 PM
dcop server problem TigerOC Debian 2 01-20-2004 02:30 PM
DCOP problem guygriffiths Linux - Software 0 10-21-2003 10:35 AM
possible samba config problem or network config issue? rruffin Linux - Networking 3 06-03-2003 04:04 PM
dcop and root trpn Linux - General 3 12-22-2002 05:08 PM


All times are GMT -5. The time now is 04:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration