LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   dbconfig-common failures when installing through apt on Ubuntu10.4 (http://www.linuxquestions.org/questions/linux-newbie-8/dbconfig-common-failures-when-installing-through-apt-on-ubuntu10-4-a-942680/)

nonshatter 05-01-2012 03:18 AM

dbconfig-common failures when installing through apt on Ubuntu10.4
 
Hi all,

I have managed to install Cacti on several other debian servers without too many problems. However, there is one server which is not working at all for me.

I am using the Ubuntu sources through apt, which usually works without any issues. It seems to get stuck around the point of creating the cacti database, failing with a couple of mysql-related errors, along with a 'Chown invalid user root:staff'.

This is a production server, so I'd rather not try anything that might risk mashing my system.

Here is most of the output from /var/log/apt/term.log:

Code:

Selecting previously deselected package cacti.
(Reading database ... 152051 files and directories currently installed.)
Unpacking cacti (from .../cacti_0.8.7e-2ubuntu0.2_all.deb) ...
Setting up cacti (0.8.7e-2ubuntu0.2) ...
dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf

Creating config file /etc/dbconfig-common/cacti.conf with new version

Creating config file /etc/cacti/debian.php with new version
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1.
unable to connect to mysql server.
error encountered creating user:
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1
dbconfig-common: cacti configure: trying again.
dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
Replacing config file /etc/cacti/debian.php with new version
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1.
unable to connect to mysql server.
error encountered creating user:
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1
dbconfig-common: cacti configure: trying again.
dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
Replacing config file /etc/cacti/debian.php with new version
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1.
unable to connect to mysql server.
error encountered creating user:
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1
dbconfig-common: cacti configure: aborted.
dbconfig-common: flushing administrative password
dpkg: error processing cacti (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
cacti
Log ended: 2012-04-30  19:25:04

Log started: 2012-04-30  19:26:57
Setting up cacti (0.8.7e-2ubuntu0.2) ...
dbconfig-common: writing config to /etc/dbconfig-common/cacti.conf
Replacing config file /etc/cacti/debian.php with new version
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1.
unable to connect to mysql server.
error encountered creating user:
ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1
dbconfig-common: cacti configure: ignoring errors from here forwards
populating database via sql...  done.
dbconfig-common: flushing administrative password

Creating config file /etc/cacti/apache.conf with new version
chown: invalid group: `root:staff'

Log ended: 2012-04-30  19:27:14

I have tried reinstalling several times using apt-get remove --purge cacti, but still no luck...
My feeling is that if I can solve where this error is coming from, then the other problems might go away:

Code:

ERROR 1064 (42000) at line 1: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/usr/bin/mysql' at line 1

At this point you choose "retry", you will be prompted with all the configuration questions once more and another attempt will be made at performing the operation.
"retry (skip questions)" will immediately attempt the operation again, skipping all questions. If you choose "abort", the operation will fail and you will need to
downgrade, reinstall, reconfigure this package, or otherwise manually intervene to continue using it. If you choose "ignore", the operation will continue, ignoring further errors from dbconfig-common.

Any help appreciated
ns


All times are GMT -5. The time now is 10:44 AM.