LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2010, 04:33 PM   #1
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Rep: Reputation: 0
Question damn small linux error: mounting cd-rom & floppy (probably also usb)


hi: I just installed damn small linux on a Dell 233 Pentium w/ Toshiba CD-ROM XM 6102B, it works fine except for mounting CD's & Floppies (and I assume, although I haven't tried USB-Drives)

when logged in as root, and typing in
mount dev/cdrom
w/ a cd in a the drive
the answer is
no medium found

when using X mount floppy command,
w/ a floppy in the drive, I get:
Error: mount: relocation error: mount: undefined symbol: blkid_known_fstype

also, my cd-rom drive won't stay closed, which is really annoying,

thanks,
 
Old 01-15-2010, 04:43 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,372

Rep: Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198Reputation: 2198
Shouldn't it automount?
 
Old 01-16-2010, 01:16 AM   #3
racepres
Member
 
Registered: Feb 2009
Location: central Michigan
Distribution: Puppy/Debian/Mandriva
Posts: 56

Rep: Reputation: 18
My DSL does not automount, But, I don't mount w/ command line either. Simply selecting mount from "control panel" has done the trick w/ my install. When I have poor floppy's i get "mount failure" and I have had a hardware issue w/ my cdrom drive that caused mount failures also. Try the mount Panel I guess.
RP
 
Old 01-16-2010, 09:31 AM   #4
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Arrow no automount & no hard drive failure

Quote:
Originally Posted by jefro View Post
Shouldn't it automount?
I don't think the cd-rom drive automount (the tray stays open by default), then entering mount etc as a command or using the mount icon will close the tray and cause to read the CD, but result is always "no medium found" whether I put an R or RW CD in the tray,

I also don't think it's a hardware failure because of the above, and also because I installed the OS from the CD drive (initial boot),

I was told this may be had to do with the etc/fstab file, which for me, reads:

/dev/hda1 /ext2 defaults,errors=remount-ro 0 1
proc /proc proc defaults 0 0
/dev/fd0 /mnt/auto/floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /mnt/auto/cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/hda2/mnt/hda2 auto noauto,users,exec 0 0

?

thanks,
 
Old 01-16-2010, 09:33 AM   #5
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 337Reputation: 337Reputation: 337Reputation: 337
is that a dsl hd install or frugal install?

what boot parameters are you using?
 
Old 01-16-2010, 09:43 AM   #6
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 337Reputation: 337Reputation: 337Reputation: 337
also

did you try

mount /dev/cdrom /mnt/auto/cdrom
 
Old 01-16-2010, 09:57 AM   #7
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Arrow hd install

Quote:
Originally Posted by linus72 View Post
is that a dsl hd install or frugal install?

what boot parameters are you using?
it's a hd install,
and I think my boot line is:

from /BOOT/GRUB/MENU.LST

kernel /boot/linux24 root=/dev/hda2 quiet vga=normal noacpi noapm nodma noscsi frugal initrd /boot/minit24.gz
 
Old 01-16-2010, 09:59 AM   #8
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 337Reputation: 337Reputation: 337Reputation: 337
hmmm

did you try the mount /dev/cdrom /mnt/auto/cdrom?
whats on hda1?
 
Old 01-16-2010, 09:59 AM   #9
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Arrow error message

Quote:
Originally Posted by linus72 View Post
also

did you try

mount /dev/cdrom /mnt/auto/cdrom
when I tried this command, logged in as root, in bash, I get:

mount: relocation error: mount: undefined symbol: blkid_known_fstype

?
 
Old 01-16-2010, 10:04 AM   #10
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Arrow / mounted on hda1

Quote:
Originally Posted by linus72 View Post
hmmm

did you try the mount /dev/cdrom /mnt/auto/cdrom?
whats on hda1?
mount /dev/hda1

gives
according to mtab
/dev/hda1 already mounted on /
 
Old 01-16-2010, 10:05 AM   #11
linus72
LQ Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,087

Rep: Reputation: 337Reputation: 337Reputation: 337Reputation: 337
so where is dsl installed?
that looks like a frugal install

is dsl on hda1 or hda2?
 
Old 01-16-2010, 10:07 AM   #12
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,869

Rep: Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247Reputation: 1247
What is on the cdrom/floppy you are trying to mount?
The "no medium found" error could be a bad cd. Could also be a bad drive or more likely loose cables.

Have you tried specifying the filesystem type in the mount command?
 
Old 01-16-2010, 10:30 AM   #13
svinoba
LQ Newbie
 
Registered: Nov 2007
Location: Bengaluru, India
Distribution: Debian, Fedora, Slackware
Posts: 29

Rep: Reputation: 17
Quote:
Originally Posted by lenou View Post
I was told this may be had to do with the etc/fstab file, which for me, reads:

/dev/hda1 /ext2 defaults,errors=remount-ro 0 1
proc /proc proc defaults 0 0
/dev/fd0 /mnt/auto/floppy vfat defaults,user,noauto,showexec,umask=022 0 0
/dev/cdrom /mnt/auto/cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
/dev/hda2/mnt/hda2 auto noauto,users,exec 0 0

?

thanks,
Hi,
the 'defaults' option usually mean: rw, suid, dev, exec, auto, nouser, and async

May be we are confusing the system with rw-ro, noexec-exec, auto-noauto...
Try removing defaults from both fd0 and cdrom entries...

My /etc/fstab entry for cdrom and floppy are as below:
Code:
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
You can also try keeping filesystem 'auto' instead of iso9660/udf...

Btw, are /mnt/auto/floppy and /mnt/auto/cdrom directories present?

Last edited by svinoba; 01-16-2010 at 10:37 AM.
 
Old 01-16-2010, 12:40 PM   #14
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Thumbs up boot on hd1, hd on hd2 (I think)...

Quote:
Originally Posted by linus72 View Post
so where is dsl installed?
that looks like a frugal install

is dsl on hda1 or hda2?
from command fdisk dev/hda
Disk Dev/hda 20.0 GB
255 heads, 63 sectors, 2434 cylinders
Device Boot Start End Blocks ID System
hda1 * 1 1824 83 linux
hda2 1825 2434 82 linux swap

from command mount
dev/hda1/ on / type ext2 (rw,errors=remount-ro)
/proc on /proc type proc (rw)
/dev/pts on /dev/pts type dev/pts (rw)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
/dev/fd0 on mnt/auto/floppy type vfat (rw,noexec,nosuid,nodev,showexec,umask=022)


from this, I don't see that the cd-rom drive is mounted

I managed to mount/access the floppy by revising the command you gave me to:
mount /dev/fd0 /mnt/auto/floppy
and then reading the destination file,
being a newbie I wasn't aware I had to read the destination file (...)
too used to Windows I guess,

thanks for all your help, still looking for the command to mount the cd-rom, 1 out of 2!
 
Old 01-16-2010, 12:45 PM   #15
lenou
LQ Newbie
 
Registered: Jan 2010
Posts: 10

Original Poster
Rep: Reputation: 0
Thumbs up yes, both dir presents, floppy works,

Quote:
Originally Posted by svinoba View Post
Hi,
the 'defaults' option usually mean: rw, suid, dev, exec, auto, nouser, and async

May be we are confusing the system with rw-ro, noexec-exec, auto-noauto...
Try removing defaults from both fd0 and cdrom entries...

My /etc/fstab entry for cdrom and floppy are as below:
Code:
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
You can also try keeping filesystem 'auto' instead of iso9660/udf...

Btw, are /mnt/auto/floppy and /mnt/auto/cdrom directories present?
yes, I was able to find both dir,

was able to mount and read floppy,
still working with cd-rom
will try your suggestions in fstab, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Damn Small, damn annoying with d-link DWA-130 wireless N USB freezerburn666 Linux - Hardware 5 09-09-2008 06:28 PM
Damn Small Linux Install with USB CD-ROM and Compact Flash housatonic Linux - Newbie 5 06-18-2008 09:15 PM
How to install damn small linux from floppy disk mirza Linux - Newbie 4 09-18-2006 03:57 AM
CD Rom & Floppy Mounting harley51 Debian 4 08-29-2004 05:28 PM
Mounting CD-ROM/Floppy & NIC problems meshking Linux - Hardware 5 04-19-2004 06:00 AM


All times are GMT -5. The time now is 04:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration