LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-22-2003, 11:15 PM   #1
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Rep: Reputation: 30
cups-libs need to install cups


same old story. want to install cups with package manager i get a error that says

The following package could not be found on your system. Installation cannot continue until it is installed.
cups-libs = 1.1.15

when i download this package and try to install it it says its already intalled. what know i have been through all of this before with another package. i couldnt get it resolved so i had to reinstall my whole system.

any helpful hints
thanks
 
Old 01-23-2003, 11:19 AM   #2
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
If you know what you're doing you could force the install of the rpm.
rpm -ivh --force foo.rpm
 
Old 01-23-2003, 11:58 AM   #3
RickFriedman
LQ Newbie
 
Registered: Mar 2002
Distribution: SuSE 8.2
Posts: 14

Rep: Reputation: 0
Re: cups-libs need to install cups

Quote:
Originally posted by illtbagu
The following package could not be found on your system. Installation cannot continue until it is installed.
cups-libs = 1.1.15

when i download this package and try to install it it says its already intalled. what know i have been through all of this before with another package. i couldnt get it resolved so i had to reinstall my whole system.
Before trying to force an installation, I would suggest rebuilding the RPM database. At a command line enter:

rpm --rebuilddb

Rick
 
Old 01-23-2003, 08:02 PM   #4
illtbagu
Member
 
Registered: Dec 2002
Location: Nevada
Distribution: fedora, RHEL, ubuntu, suse
Posts: 343

Original Poster
Rep: Reputation: 30
what package manager asks for is cups-libs = 1.1.15
this is what is installed it cups-libs-1.1.17-0.2, cups-devel-1.1.17-0.2
when i try to install cups-libs = 1.1.15 it says i cant because a newer version is available
should i try to uninstall both cups-libs-1.1.17-0.2, cups-devel-1.1.17-0.2 and then try to
install cups from package manager

i tried rpm --rebuilddb with no luck i could also try a force isntall that was sugested to me

thanks for any advise
AD
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Printing Problem (cups / cups-lpd) daleman Linux - Software 3 04-08-2005 09:01 AM
remote cups printing to a smb/cups print server? justanothergeek Linux - Networking 2 09-15-2004 09:31 AM
cups Error "CUPS daemon has died" susesarus Linux - Software 2 08-21-2004 04:43 PM
Slackware 9 and CUPS (CUPS=crap) - printing carboncopy Slackware 21 07-29-2003 04:27 PM
CUPS in SuSE <> Cups RH' Like? Tiago Cruz Linux - Hardware 0 02-13-2003 01:46 PM


All times are GMT -5. The time now is 07:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration