LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 06-14-2005, 12:50 PM   #1
MAGOVIA
Member
 
Registered: Jun 2003
Location: Costa Rica
Distribution: slackware 8.1/SUSE 9.0
Posts: 45

Rep: Reputation: 15
cups error: "error-client-not-possible


hi everyone

I was gladlly using my computer (Slackware 10-Epsonc65),Everything working super. I did restart it and when it came back, my printer was unable to operate.

The error says: "error-client-not-possible"

I disable the printer and reinstalled againg but did not work

Does anybody knows anything about it?

Thank your
 
Old 06-14-2005, 07:22 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
What does
/var/log/cups/error.log
know about that problem?

If it doesn't say much edit /etc/cups/cupsd.conf
and set
LogLevel info
to
LogLevel debug


Cheers,
Tink
 
Old 06-15-2005, 01:47 AM   #3
MAGOVIA
Member
 
Registered: Jun 2003
Location: Costa Rica
Distribution: slackware 8.1/SUSE 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
This is what /var/log/cups/error_log says about my printer.
I Edited cupsd.conf to debug level, after that I reinstalled my printer

[14/Jun/2005:11:18:42 -0600] Scheduler shutting down normally.
I [14/Jun/2005:11:20:00 -0600] Listening to 0:631
I [14/Jun/2005:11:20:00 -0600] Loaded configuration file "/etc/cups/cupsd.conf"
I [14/Jun/2005:11:20:00 -0600] Configured for up to 100 clients.
I [14/Jun/2005:11:20:00 -0600] Allowing up to 100 client connections per host.
I [14/Jun/2005:11:20:00 -0600] Full reload is required.
I [14/Jun/2005:11:20:01 -0600] LoadPPDs: Read "/etc/cups/ppds.dat", 523 PPDs...
I [14/Jun/2005:11:20:01 -0600] LoadPPDs: No new or changed PPDs...
I [14/Jun/2005:11:20:01 -0600] Full reload complete.
I [14/Jun/2005:11:27:48 -0600] Denying user "root" access to printer "EPSONC65"...
I [14/Jun/2005:11:28:36 -0600] Saving printers.conf...
I [14/Jun/2005:11:28:36 -0600] Printer 'EPSONC65' modified by 'root'.
I [14/Jun/2005:11:28:36 -0600] Saving printers.conf...
I [14/Jun/2005:11:28:36 -0600] Printer 'EPSONC65' now accepting jobs ('root').
I [14/Jun/2005:11:28:36 -0600] Printer 'EPSONC65' started by 'root'.
I [14/Jun/2005:11:28:57 -0600] Denying user "root" access to printer "EPSONC65"...
I [14/Jun/2005:11:41:41 -0600] Denying user "root" access to printer "EPSONC65"...
I [14/Jun/2005:11:47:10 -0600] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=1533)
I [14/Jun/2005:11:47:24 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1534)
I [14/Jun/2005:11:47:27 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1535)
I [14/Jun/2005:11:47:27 -0600] Printer 'EPSONC65' deleted by 'root'.
I [14/Jun/2005:11:47:27 -0600] Saving printers.conf...
I [14/Jun/2005:11:47:31 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1536)
I [14/Jun/2005:11:47:32 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1537)
I [14/Jun/2005:11:48:07 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1538)
I [14/Jun/2005:11:48:10 -0600] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=1539)
I [14/Jun/2005:11:48:12 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1540)
I [14/Jun/2005:11:48:14 -0600] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=1542)
I [14/Jun/2005:11:54:28 -0600] Scheduler shutting down normally.
I [14/Jun/2005:18:18:01 -0600] Listening to 0:631
I [14/Jun/2005:18:18:01 -0600] Loaded configuration file "/etc/cups/cupsd.conf"
I [14/Jun/2005:18:18:01 -0600] Configured for up to 100 clients.
I [14/Jun/2005:18:18:01 -0600] Allowing up to 100 client connections per host.
I [14/Jun/2005:18:18:01 -0600] Full reload is required.
I [14/Jun/2005:18:18:01 -0600] LoadPPDs: Read "/etc/cups/ppds.dat", 523 PPDs...
I [14/Jun/2005:18:18:01 -0600] LoadPPDs: No new or changed PPDs...
I [14/Jun/2005:18:18:01 -0600] Full reload complete.
I [14/Jun/2005:21:32:42 -0600] Scheduler shutting down normally.
I [14/Jun/2005:23:48:58 -0600] Listening to 0:631
I [14/Jun/2005:23:48:58 -0600] Loaded configuration file "/etc/cups/cupsd.conf"
I [14/Jun/2005:23:48:58 -0600] Configured for up to 100 clients.
I [14/Jun/2005:23:48:58 -0600] Allowing up to 100 client connections per host.
I [14/Jun/2005:23:48:58 -0600] Full reload is required.
I [14/Jun/2005:23:48:59 -0600] LoadPPDs: Read "/etc/cups/ppds.dat", 523 PPDs...
I [14/Jun/2005:23:48:59 -0600] LoadPPDs: No new or changed PPDs...
I [14/Jun/2005:23:48:59 -0600] Full reload complete.

--------------Here I added the printer --------------------------------------------
I [15/Jun/2005:00:35:41 -0600] Setting tmpprinter_B7F48CCS device-uri to "usb://EPSON/Stylus%20C65" (was "file:/dev/null".)
I [15/Jun/2005:00:35:41 -0600] Saving printers.conf...
I [15/Jun/2005:00:35:41 -0600] New printer 'tmpprinter_B7F48CCS' added by 'root'.
I [15/Jun/2005:00:35:41 -0600] Saving printers.conf...
I [15/Jun/2005:00:35:41 -0600] Printer 'tmpprinter_B7F48CCS' now accepting jobs ('root').
I [15/Jun/2005:00:35:41 -0600] Saving printers.conf...
I [15/Jun/2005:00:35:41 -0600] Printer 'tmpprinter_B7F48CCS' started by 'root'.
I [15/Jun/2005:00:35:42 -0600] Adding start banner page "none" to job 1.
I [15/Jun/2005:00:35:42 -0600] Adding end banner page "none" to job 1.
I [15/Jun/2005:00:35:42 -0600] Job 1 queued on 'tmpprinter_B7F48CCS' by 'root'.
I [15/Jun/2005:00:35:42 -0600] Started backend /usr/lib/cups/backend/usb (PID 18313) for job 1.
W [15/Jun/2005:00:35:42 -0600] [Job 1] Media tray empty!
I [15/Jun/2005:00:35:45 -0600] Printer 'tmpprinter_B7F48CCS' deleted by 'root'.
I [15/Jun/2005:00:35:45 -0600] Saving printers.conf...
I [15/Jun/2005:00:36:13 -0600] Setting EPSONC65 device-uri to "usb://EPSON/Stylus%20C65" (was "file:/dev/null".)
I [15/Jun/2005:00:36:13 -0600] Saving printers.conf...
I [15/Jun/2005:00:36:13 -0600] New printer 'EPSONC65' added by 'root'.
I [15/Jun/2005:00:36:13 -0600] Saving printers.conf...
I [15/Jun/2005:00:36:13 -0600] Printer 'EPSONC65' now accepting jobs ('root').
I [15/Jun/2005:00:36:13 -0600] Saving printers.conf...
I [15/Jun/2005:00:36:13 -0600] Printer 'EPSONC65' started by 'root'.
I [15/Jun/2005:00:36:21 -0600] Denying user "root" access to printer "EPSONC65"...

-----This is the message I get when I sent any document to print-------------

A print error occurred. Error message received from system:

cupsdoprint -P 'EPSONC65' -J 'KDE Print Test' -H 'localhost:631' -U 'root' -o ' multiple-document-handling=separate-documents-uncollated-copies orientation-requested=3' '/opt/kde/share/apps/kdeprint/testprint.ps' : execution failed with message:
client-error-not-possible


---Thanks

Minor
 
Old 06-15-2005, 02:40 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
OK, try pushing the debug level up another notch,
make it debug2 ...

Stop cups, restart it, try to print, stop cups, change it back
to info (otherwise the log will fill too quickly).

Other thing to look at: are the USB drivers loaded, does
the printer show up as a connected USB device in dmesg?



Cheers,
Tink
 
Old 06-18-2005, 11:44 PM   #5
MAGOVIA
Member
 
Registered: Jun 2003
Location: Costa Rica
Distribution: slackware 8.1/SUSE 9.0
Posts: 45

Original Poster
Rep: Reputation: 15
ok, this is what I did:
chmod +x /etc/rc.d/rc.cups
then
/etc/rc.d/rc.cups start
and
kcmshell printers
and I added my printer again
then I veryfied the status
root@JahYireh:/home/minor# /etc/rc.d/rc.cups status
cups: scheduler is running.
so, I sent a test page and It worked.
but a new challenge emerged
when I do lpr under regular user :
minor@JahYireh:~$ lpr FACTURA.sxw
-bash: /usr/bin/lpr: Permission denied
It also doesnt work with OpenOffice, and I know it has something to do with lpr permissions.
any Ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
server-error-internal-error with CUPS "Configure Printer" fskmh Slackware 6 06-05-2013 01:51 PM
CUPS "client-error-not-possible" tommilo Linux - Newbie 7 09-28-2005 07:34 AM
CUPS error: client-error-not-possible bru Debian 2 02-11-2005 12:54 AM
cups Error "CUPS daemon has died" susesarus Linux - Software 2 08-21-2004 03:43 PM
Cups - "client-error-not-found" error timfair Linux - Software 0 06-13-2003 11:21 PM


All times are GMT -5. The time now is 05:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration