LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-27-2010, 11:33 AM   #1
bhanuvrat
Member
 
Registered: Jan 2010
Posts: 47

Rep: Reputation: 15
ctrl+alt+ fn1 , fn2 etc do not work


I am using opensuse 11.2 on my dell studio 14 laptop and to my surprise the key combination for bringing up text based console does not function as expected.

when I press ctrl+alt+ fn keys I am greeted with a blank screen and ctrl+alt+F7 brings me back to the GUI plasma desktop.

Does this have to do something with the acpi=off thing I did for booting successfully into linux ( without this option, the screen would go off and not respond to anything ... physical restart was the only option). although my system starts off without any fuss, OS does not detect the battery of my laptop.

more problems will come up later presently whats bugging me is this.

help me out.
 
Old 01-27-2010, 02:31 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
What happens if you do an "init 1'?

Does your machine "hang" (not display anything, not respond to keystrokes)?
Do you get to a text mode login?
 
Old 01-27-2010, 02:44 PM   #3
samsom
LQ Newbie
 
Registered: Jan 2009
Posts: 27

Rep: Reputation: 15
Hi,
I have got the same problem as well. On init 1, I get a blank screen but I don't think its hung as caps lock and num lock seem to work. Had to reboot to get out of the init 1.
Why is this happening?
Samsom
 
Old 01-28-2010, 03:27 AM   #4
bhanuvrat
Member
 
Registered: Jan 2010
Posts: 47

Original Poster
Rep: Reputation: 15
@tinkster

yes its as you suggested init 1 causes my screen to go off ( similar to what happens on booting without acpi=off ) and responds to nothing ... physical reboot is the only option left to get the machine up and running.
The screen goes off... no text login

@samson

glad to know that I am not the only one facing this stupid problem :P
 
Old 01-28-2010, 04:04 AM   #5
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,208

Rep: Reputation: 230Reputation: 230Reputation: 230
Quote:
when I press ctrl+alt+ fn keys I am greeted with a blank screen and ctrl+alt+F7 brings me back to the GUI plasma desktop.
Bhanuvrat,

It is a blessing that you have at least a "greeting..." on a shell login screen: Being "greeted" I assume that there is the usual Login: screen shell. That is normal. In most Linux distribution the Ctl+Alt+F1-6 is a short cut to your tty shell screen, this is very useful as Linux is best controlled on the terminal (shell, dos-prompt, etc.). Ctl-Alt-F7 and Ctl-Alt-F1 are tty's used by the Xwindowing server, these are not available for shell logins so you are given the keys F2 through F6.

If you don't want to enjoy this privilege you can close these tty's by editing your /etc/inittab script. But I would have you just leave them alone, as you learn more commands in linux you will begin to understand the practical need of these tty's. I can control my system outside X with these shell openings in times of either normal or emergency needs.

Hope this helps.

Good luck.
 
0 members found this post helpful.
Old 01-28-2010, 05:06 AM   #6
bhanuvrat
Member
 
Registered: Jan 2010
Posts: 47

Original Poster
Rep: Reputation: 15
@tinkster

yes its as you suggested init 1 causes my screen to go off ( similar to what happens on booting without acpi=off ) and responds to nothing ... physical reboot is the only option left to get the machine up and running.
The screen goes off... no text login

@samson

glad to know that I am not the only one facing this stupid problem :P
 
Old 01-29-2010, 11:33 AM   #7
bhanuvrat
Member
 
Registered: Jan 2010
Posts: 47

Original Poster
Rep: Reputation: 15
@ mustaq

well I think you got me wrong.. I am not able to access the terminal on ctrl+alt+F1 to F6. i have been using linux for quite a while now and do know what those tty 's are for and do really wan't to use them. I use vi editor for writing c programs (for online judges) and compile it at command line using gcc ..

I love the feel of command line...

however I am not able to access it right now as when I press ctrl+alt+ fn keys a blank screen is displayed without any prompt for login which should be there so I want the community to help me get it back

you might accuse me of posting the question in the newbie section but the problem is of newbie kind where else should have had I posted it?
 
Old 01-30-2010, 08:43 AM   #8
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,208

Rep: Reputation: 230Reputation: 230Reputation: 230
Quote:
you might accuse me of posting the question in the newbie section but the problem is of newbie kind where else should have had I posted it?
bhanuvrat,

I am not a state prosecutor to accuse anyone...

Well, glad you are familiar with the tty's sorry if I got you wrong. The OP words are often vague to people like us. When you said you are "greeted" I simply understood that there is the usual Linux Login Greetings of every tty rather than infer a "totally blank" (without a greeting) is opened. Well it's okay, that's normal, even English language users often face such communication shortcoming.

I have had the same problem recently too, however, the solution I did was only to "comment" out some unnecessary 'keyboard' 'InputDevice' options in the /etc/X11/xorg.conf. Sometimes installing some applications which need to intrude the Input Device settings automatically edit the xorg.conf arresting the normal use Ctl-Alt-Fn functions. Now you can go and make such correction.

Hope this helps.

Good luck.

Last edited by malekmustaq; 01-30-2010 at 08:48 AM.
 
Old 01-30-2010, 09:10 AM   #9
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,541
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Perhaps the key combinations are not correctly configured or perhaps there's no *getty running on the pseudo ttys. On this Slackware 13.0 system ps -ef output includes lines for them
Code:
root      3776     1  0 18:46 tty1     00:00:00 /sbin/agetty 38400 tty1 linux
root      3777     1  0 18:46 tty2     00:00:00 /sbin/agetty 38400 tty2 linux
root      3778     1  0 18:46 tty3     00:00:00 /sbin/agetty 38400 tty3 linux
root      3779     1  0 18:46 tty4     00:00:00 /sbin/agetty 38400 tty4 linux
root      3780     1  0 18:46 tty5     00:00:00 /sbin/agetty 38400 tty5 linux
root      3781     1  0 18:46 tty6     00:00:00 /sbin/agetty 38400 tty6 linux
Does you system show something similar?

Last edited by catkin; 01-30-2010 at 09:11 AM. Reason: pseudo spelling
 
Old 01-30-2010, 09:39 AM   #10
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
Are you using the proprietary nVidia driver?

When I tried it before in Fedora, it ruined the functionality of the ctrl+alt+F? terminals.
 
Old 01-30-2010, 12:39 PM   #11
bhanuvrat
Member
 
Registered: Jan 2010
Posts: 47

Original Poster
Rep: Reputation: 15
yes I am stiil in trouble :P

@MTK
My laptop has ATI Radeon Mobility 4530 graphics card ... so I installed the proprietary ATI graphics driver which happened to screw up my screen and cause windows to be repainted when being dragged. this in turn created an illusion of very slow computer. ( the kind of thing which happens if you run XP on a system with 128 MB ram). So I reinstalled the OS ... well here you can poke me but I have yet not mastered the skills required to uninstall software on linux

P.S My laptop has 4 gigs of RAM before you inquire.

@Malek
my opensuse installation does not contain xorg.conf surprisingly ( and more surprisingly I had not checked that beforehand) .. instead it has a file called xorg.conf.install .. well i have an experience of editing xorg.conf for increasing screen resolution when I had installed openSolaris and Mandriva. seems as if openSuse has some different kinda section.

@catkin

ps -ef had a pretty long output but the part that seemed to be sensible to me was

Code:
root      1980     1  0 Jan30 tty1     00:00:00 /sbin/mingetty --noclear tty1                     
root      1981     1  0 Jan30 tty2     00:00:00 /sbin/mingetty tty2                               
root      1982     1  0 Jan30 tty3     00:00:00 /sbin/mingetty tty3                               
root      1985     1  0 Jan30 tty4     00:00:00 /sbin/mingetty tty4                               
root      1988     1  0 Jan30 tty5     00:00:00 /sbin/mingetty tty5                               
root      1989     1  0 Jan30 tty6     00:00:00 /sbin/mingetty tty6
well hope this helps you in helping me
 
Old 01-30-2010, 12:53 PM   #12
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713Reputation: 713
Since you said it does not have xorg.conf, that means that Xorg automatically detects everything. It's not that it has another configuration file.
 
Old 01-30-2010, 10:37 PM   #13
bhanuvrat
Member
 
Registered: Jan 2010
Posts: 47

Original Poster
Rep: Reputation: 15
problem still persists

Quote:
Originally Posted by MTK358 View Post
Since you said it does not have xorg.conf, that means that Xorg automatically detects everything. It's not that it has another configuration file.
so how do I go about solving the problem at hand??
 
Old 01-30-2010, 11:22 PM   #14
worm5252
Member
 
Registered: Oct 2004
Location: Atlanta
Distribution: CentOS, RHEL, HP-UX
Posts: 565

Rep: Reputation: 57
What X environment are you using? Gnome? KDE? XFCE? IceWM? etc. Could be that your X Environment settings have different functions assigned to those key combinations.

I Personally use KDE. I can go to Kmenu -> Control Center (in a terminal you can run kcontrol). In Control Center I can select Regional & Accessibility on the left, and then select keyboard shortcuts. From there I can see all of the keyboard shortcuts KDE has reserved.

I would say check there. I have seen on other Forums where ATI drivers screw up tty's. Whats your /etc/inittab look like?
 
Old 01-31-2010, 03:49 AM   #15
kdelover
Member
 
Registered: Aug 2009
Posts: 311

Rep: Reputation: 36
I have an ati mobility radeon HD 4650,i have had tough time installing the ati drivers,even after installing the prop drivers i still had a sluggish desktop.After installing drivers,check for the log file that it generates,i figured out later that i did not have gcc and kernel headers installed.Can you post the output of the log file? Can you post the output of

glxinfo | grep -i "direct"

Last edited by kdelover; 01-31-2010 at 03:51 AM.
 
  


Reply

Tags
based, console, text


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CTRL+ALT+F1....F6 don't work abd_bela Debian 4 02-03-2012 04:21 PM
Ctrl+alt+(f1-f6) does not work.. email2suryaz Linux - Newbie 2 10-30-2009 01:03 AM
Ctrl + Alt + F# does not work mpajoh Fedora 3 01-08-2007 12:20 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
Ctrl+alt+F... don't work in X (Mandrake 9.1) ACMwizard Linux - Software 2 05-19-2003 01:20 PM


All times are GMT -5. The time now is 12:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration