LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-29-2012, 02:25 PM   #1
devaj
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Rep: Reputation: 1
Ctrl+Alt+F7 Does not work


Hi,
It recently came to my notice that Ctrl+Alt+F7 is not working,i.e it is not taking me back to gnome session.Ctrl+Alt+[F1-F6] works perfectly.Ctrl+Alt+[F7-F12] no luck.Compiz was never enabled and is disabled right now.
Here are the results of the following commands

1)ps -ax | grep X

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
897 ? S 0:00 avahi-daemon: running [phycosis-XP-M5ARC410.local]
1917 tty1 S+ 0:00 xinit /etc/X11/xinit/xinitrc -- /etc/X11/xinit/xserverrc :0 -auth /tmp/serverauth.mWLyA12RgO
1918 tty7 Ss+ 0:21 /usr/bin/X -nolisten tcp :0 -auth /tmp/serverauth.mWLyA12RgO
2447 pts/0 S+ 0:00 grep --colour=auto X

2)setxkbmap -print

xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us+inet(evdev)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc105)" };
};

3)xmodmap -pk | grep '(F[0-9]+)'

This command does not give any result and goes back to the prompt


4)awk '/Section "(InputDevice|ServerFlags)"/,/EndSection/' /etc/X11/xorg.conf

Section "ServerFlags"
Option "DontZap" "false"
EndSection

5)xmodmap
xmodmap: up to 4 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x69)
mod1 Alt_L (0x40), Alt_R (0x6c), Meta_L (0xcd)
mod2 Num_Lock (0x4d)
mod3
mod4 Super_L (0x85), Super_R (0x86), Super_L (0xce), Hyper_L (0xcf)
mod5 ISO_Level3_Shift (0x5c), Mode_switch (0xcb)

6)vi /etc/X11/xorg.conf
Section "Device"
Identifier "Configured Video Device"
Driver "radeon"
Option "IgnoreEDID" "on"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerFlags"
Option "DontZap" "false"
EndSection


The legacy/proprietary driver for my graphic card (radeon x200) is no longer supported by current x-server/xorg.Hence using the default.The Ctrl+Alt+F7/F8 used to work properly before on this installation.Desktop is Linux Mint 10 Julia.
I would be greatful if someone could help me out here.
(Been a long day today,gotta catch some sleep.Will look up tomorrow.)

THANK YOU ALL FOR BEING SUCH A LOVELY COMMUNITY.MAY GOD BLESS ALL OF YOU.
 
Old 02-29-2012, 02:59 PM   #2
mad4linux
Member
 
Registered: Aug 2003
Distribution: Debian Testing / kubuntu
Posts: 86

Rep: Reputation: 21
Hi devaj

To go to the X-session from the command prompt, you would use Alt+F7. To go from X-Server to command prompt, use Ctrl+Alt+{F1-F6}. Ctrl is not necessary when going from command prompt to X-Session. Usually is does work with Ctrl+Alt+F7 anyhow.
I've had the same issue some time ago with the proprietary AMD driver. For me, switching between command prompt and x-server now works with the radeon driver. So, it's exactly the other way round. I would still suspect the graphics driver and not keyboard or kernel settings.
Just a first guess: With a recent linux kernel, you shouldnt need xorg.conf at all anymore. Try renaming your xorg.conf to something like xorg.save and reboot at least gdm with /etc/init.d/gdm restart. If your X-Server works like that, you can leave your xorg.save, otherwise you will have to rename it to xorg.conf again.
Try switching from command prompt to x-server when no xorg.conf is present.

Last edited by mad4linux; 02-29-2012 at 02:59 PM. Reason: typo
 
Old 05-06-2013, 03:53 AM   #3
devaj
LQ Newbie
 
Registered: Feb 2009
Posts: 17

Original Poster
Rep: Reputation: 1
Sorry for replying after such a long time.I have learned a lot about linux in the past year and would like to contribute to this great forum.The solution that I eventually did find out was that you can change tty using chvt tty number (to all the newbs,the non-graphical+the graphical desktops from CTRL+F1 to CTRL+F8 are called tty1 to tty8 respectively).
eg
Code:
chvt 1
will take you to CTRL+F1
Code:
chvt 7
will take you to CTRL+F7(your graphical desktop)

If chvt 7 does not take you to your graphical desktop then do try
Code:
chvt 8
(Mine was mapped to F8 not F7,don't know why)

Here is the procedure:
Log in again through any tty accessible,in my case I preferred the first tty (by executing CTRL+F1).After loggin in execute
Code:
chvt 7
if chvt 7 does not work then try
Code:
chvt 8
Do also check wether it's a hardware problem or not (it was in my case,much ado about nothing,lol).
A good way to find this out is by opening a terminal,preferances and going into the shorcut key menu or keybinding menu.There select any function and try to change the shortcut key of the function with the problematic hardware key,in my case I tried changing the Zoom out function shorcut key (CTRL-) with all the functions keys one at a time and thus found out that my F7 and F8 keys were not working at all,a hardware problem.
Hope this information would help a newb in future
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CTRL+ALT+F1....F6 don't work abd_bela Debian 4 02-03-2012 04:21 PM
Ctrl+alt+(f1-f6) does not work.. email2suryaz Linux - Newbie 2 10-30-2009 01:03 AM
Ctrl + Alt + F# does not work mpajoh Fedora 3 01-08-2007 12:20 PM
ctrl-alt-F<n> doesnt work maginotjr Slackware 16 07-01-2005 01:04 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM


All times are GMT -5. The time now is 08:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration