LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2009, 04:51 PM   #1
AstralCorpse
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Rep: Reputation: 0
Creox C and Qjackctl problem.


Hey guys,

I'm trying to get Creox C to work and I understand that it requires JACK. I had no trouble installing, but when I run qjackctl and click the 'start' option I get the following message:

"Could not connect to JACK server as client.
- Overall operation failed.
- Unable to connect to server"

The message window outputs the following as well:

15:50:19.073 Startup script...
15:50:19.075 artsshell -q terminate
15:50:19.518 Startup script terminated with exit status=256.
15:50:19.520 JACK is starting...
15:50:19.521 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2
15:50:19.538 JACK was started with PID=6066.
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
loading driver ..
apparent rate = 44100
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
control device hw:0
the playback device "hw:0" is already in use. Please stop the application using it and run JACK again
cannot load driver module alsa
no message buffer overruns
15:50:19.588 JACK was stopped successfully.
15:50:19.590 Post-shutdown script...
15:50:19.591 killall jackd
jackd: no process killed
15:50:20.013 Post-shutdown script terminated with exit status=256.
15:50:21.739 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

Any ideas? I'm running Ubuntu 8.10, btw. Thanks for the help.
 
Old 01-18-2009, 04:41 AM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
Try disabling the soundsystem control in gnome/kde, and restart alsa. If after that you get problems with xine, amarok et.al. have them use alsa directly or jack.
 
Old 01-21-2009, 03:52 PM   #3
AstralCorpse
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Sorry to sound uninformed, but how do I go about disabling the soundsystem control in Gnome? Thanks.
 
Old 01-22-2009, 02:29 PM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
System -> Preferences -> Sound -> Sounds tab -> uncheck the top radiobutton to disable ESD.
 
Old 01-22-2009, 10:58 PM   #5
AstralCorpse
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Original Poster
Rep: Reputation: 0
I disabled everything and restarted alsa, but unfortunately I still got the exact same problem. Any other ideas?
 
Old 01-25-2009, 09:33 AM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 54
You could try here: http://forum.jacklab.net/viewforum.p...3de149511f544d
Look for anything using sound in top, htop, pstree, ps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
QjackCtl or Qsynth window consumes 100% of CPU (without actually starting services) Xdrummer Slackware 1 03-18-2008 02:20 PM
qjackctl - "Could not connect to JACK server as client" oskar Linux - Software 2 07-09-2007 10:51 PM
Rosegarden, jack, qjackctl error: "can't connect to server as client" deep_inda_jungl Mandriva 3 02-21-2007 12:45 AM
Linux Audio: Connecting Rosegarden to Ardour via qjackctl? mikejedw Linux - Software 0 08-19-2004 03:01 AM
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 08:45 PM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration