LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-02-2003, 11:41 AM   #1
YaPaY
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1
Posts: 5

Rep: Reputation: 0
Creative Live 5.1 Bass Problem


Hello,
I'm very new in Linux. I have Mandrake 9.1 installed with emu10k and emutools. Everything is okay but my sound card gives very noisy and only rear speakers working. No Bass, frontier sound with mp3's.
I think, I need script for startup but I couldn't find. Please help me.

P.S. I'm using 5.1 Analog Speaker with my Creative Live 5.1 Player sound card.
 
Old 04-03-2003, 11:01 AM   #2
anccert
LQ Newbie
 
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
When you installed emu-tools it should have put in /usr/local/etc:

emu10k1.conf
emu-script

Edit emu10k1.conf to your liking and put these lines in /etc/modules.conf:

#Loads script on startup
post-install emu10k1 /usr/local/etc/emu-script
#Saves mixer levels
post-install emu10k1 /usr/local/etc/emu-script restore
pre-remove emu10k1 /usr/local/etc/emu-script save
 
Old 04-03-2003, 05:36 PM   #3
YaPaY
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you anccert, I did again my emu10k1.conf file in /usr/local/etc 5.1 sound support and other settings is on but everything is same. I have make modules.conf file settings with root user and I have again restart.
Problem is still have
Bass and front speakers are not working.

P.S. Sorry my poor English.
 
Old 04-03-2003, 09:59 PM   #4
anccert
LQ Newbie
 
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
I assuming that the mixer levels are set properly(bass turned up) using aumix or another type of mixer, and I'm assuming that the speakers are plugged into the correct ports. Just to verify, you have:

CARD_IS_5_1=yes
MULTICHANNEL=yes
INVERT_REAR=yes (maybe?)

turned on in em10k1.conf. BTW: What speakers(model no.) do you have?
 
Old 04-04-2003, 04:13 AM   #5
YaPaY
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
My settings:
CARD_IS_5_1=yes
USE_DIGITAL_OUTPUT=no
ENABLE_TONE_CONTROL=yes
ENABLE_LIVEDRIVE_IR=no
INVERT_REAR=yes (no) no different
ROUTE_ALL_TO_SUB=yes
ANALOG_FRONT_BOOST=yes
ENABLE_OPTICAL_SPDIF=no # Volume control is 'Digital2'
ENABLE_LINE2_MIC2=no # Volume control is 'Line2'
ENABLE_RCA_SPDIF=no # Volume control is 'Digital3'
ENABLE_RCA_AUX=no # Volume control is 'line3'

I have 5.1 analog speakers 1subwoofer 5 klein speakers. Mixer settings is open.
I hear only rear speakers.
 
Old 04-04-2003, 08:39 AM   #6
anccert
LQ Newbie
 
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
I did not see MULTICHANNEL=yes in your config above. Other than having MULTICHANNEL=yes in emu10k1.config, I'm stumped.
 
Old 04-04-2003, 08:50 AM   #7
YaPaY
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Oops!!!
Must I compile my kernel source? Because everything seems okey. I dont understand README file. I did only emu10k1 and emu-tools compiled.
 
Old 04-04-2003, 09:17 AM   #8
anccert
LQ Newbie
 
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
I forgot to look at the Requirements and Configuring section of the Readme file for more information. Once you meet the the requirements and configuration then emu10k1 and emu-tools is all you need. It says that "Using your own kernel sources [is] (preferred)." At least make sure that you meet the requirements below.

- The kernel must be compiled:
- With loadable modules support (CONFIG_MODULES = y)
- With soundcard support (CONFIG_SOUND = y/m)
- Without any integrated emu10k1 soundcard drivers (CONFIG_SOUND_EMU10K1 = m/n)
- "PnP-compatible OS installed" option in BIOS must be disabled

Most of these should already be set by default. But if you have to make any changes, with the exception of PNP-OS turned off, then you would need to re-compile the kernel for the new settings and possibly emu10k1 as well.
 
Old 04-04-2003, 09:49 AM   #9
YaPaY
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Multichannel=yes but no different. I think, I can't do it. My ALSA driver is not working. Now, I will make ALSA problem.
 
Old 04-04-2003, 10:29 AM   #10
anccert
LQ Newbie
 
Registered: Apr 2003
Location: Earth
Distribution: Fedora 6
Posts: 28

Rep: Reputation: 15
Did you get the Alsa driver working at one point? I'm current trying to get the Alsa driver working, but no luck so far. I you want I can post what I have done so far regarding the Alsa driver. I also have a post up on this issue titled "Alsa driver problems".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Creative Sound Blaster Live 24bit Problem with RHEL 4 AS mneekhrey Linux - Hardware 1 10-25-2005 11:21 AM
Problem with creative soundblaster live and suse 9.1 rich_montana Linux - Hardware 3 10-16-2005 11:14 PM
Creative live 5.1 on Slackware10 kxorrao Slackware 2 02-18-2005 08:59 AM
Creative SB Live! problem; emu10k1 Redhat makmillar Linux - Hardware 4 04-22-2004 03:15 PM
Another sound problem on Mandrake 9.1 and Creative SB Live! 5.1 RaiReg Mandriva 7 01-17-2004 09:49 PM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration