LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-10-2008, 04:02 AM   #1
djunaedi
LQ Newbie
 
Registered: May 2008
Posts: 6

Rep: Reputation: 0
create directory failed in vsftpd


dear all,

i have a problem that my vsftpd cannot create directory, i don't know why. I can put and erase file but cannot put or create directory.

ftp> ls
227 Entering Passive Mode (127,0,0,1,125,68)
150 Here comes the directory listing.
-rwxr-xr-x 1 500 500 324511 Jun 10 03:43 countdown.psd
226 Directory send OK.
ftp> mkdir tes
550 Create directory operation failed.

does anyone have suggestion to fix it.

thanks b4
 
Old 06-10-2008, 05:00 AM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Is this on Fedora?

Last edited by alan_ri; 06-10-2008 at 05:01 AM.
 
Old 06-10-2008, 05:19 AM   #3
watcher69b
Member
 
Registered: Nov 2007
Location: /home/watcher69b
Distribution: RH, Fedora & CentOS
Posts: 544

Rep: Reputation: 40
well for 1 connect again and type pwd to see what directory you are in.
The next thing to do is to verify that your ftp user has write to that folder on the server.
check the /etc/vsftpd/vsftpd.conf
you need:
write_enable=yes
comment out local_umask
 
Old 06-11-2008, 03:41 AM   #4
djunaedi
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
i used fedora core 5. Even i ftp from localhost or client, still cannot create directory. i allready create user in home/name_of_user. chmod 777 /home/name_of_user.
Here is my vsftpd configuration ;

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
xferlog_enable=YES
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
chroot_local_user=YES
pam_service_name=vsftpd
userlist_enable=YES
userlist_deny=NO
listen=NO
tcp_wrappers=YES
 
Old 06-19-2008, 10:28 PM   #5
djunaedi
LQ Newbie
 
Registered: May 2008
Posts: 6

Original Poster
Rep: Reputation: 0
i have created the group "ftpusers"

made users "user" "user2" "user3"

made each user directory :

"/usr/ftp/user"
"/usr/ftp/user2"
"/usr/ftp/user3"

"chmod -R 755 /usr/ftp/user"
"chmod -R 755 /usr/ftp/user2"
"chmod -R 755 /usr/ftp/user3"

also i have tried 775 and 777 all dir's and taking the -R out of both chmod and chown.

"chown -R user.ftpusers /usr/ftp/user"
"chown -R user2.ftpusers /usr/ftp/user2"
"chown -R user3.ftpusers /usr/ftp/user3"


can someone help me with this?
 
Old 02-02-2009, 12:40 PM   #6
Beepa
LQ Newbie
 
Registered: May 2006
Location: The Great Plains (USA)
Distribution: FC4
Posts: 1

Rep: Reputation: 0
Just noticed

Quote:
Originally Posted by djunaedi View Post
i used fedora core 5. Even i ftp from localhost or client, still cannot create directory. i allready create user in home/name_of_user. chmod 777 /home/name_of_user.
Here is my vsftpd configuration ;

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
xferlog_enable=YES
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
chroot_local_user=YES
pam_service_name=vsftpd
userlist_enable=YES
userlist_deny=NO
listen=NO
tcp_wrappers=YES

shouldn't listen in the above file be set to YES? In my vsftpd.conf I have two entries one for Ipv4 and one for Ipv6. But I have one set to YES. other wise I have pretty much the same settings. Not that mine couldn't be wrong because I have issues getting my ftp users to authenticate.
 
Old 10-20-2009, 03:44 AM   #7
amirsarb
LQ Newbie
 
Registered: Apr 2007
Posts: 5

Rep: Reputation: Disabled
set bit

If you want ftp to allow users access to their home directories you need to turn
on the ftp_home_dir boolean: "setsebool -P ftp_home_dir=1"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openSUSE 10: Samba failed to create the cache directory in /var/cache mianmajidali Linux - Server 0 05-09-2008 02:00 AM
vsFTPd getting on my nervs... Login failed... Alchaemist Linux - Software 1 09-26-2005 12:11 PM
VSFTPD Directory Failed to open dwpondscum Linux - Wireless Networking 1 08-18-2005 06:28 PM
create ftp user for vsftpd server without home directory cccc Linux - Networking 2 07-30-2005 06:32 AM
Create and Restrict User vsftpd? LinuxNoobs Linux - Networking 1 05-20-2003 03:57 AM


All times are GMT -5. The time now is 08:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration