LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2005, 02:34 PM   #1
consty
Member
 
Registered: Feb 2004
Location: Douala-Cameroun
Distribution: RedHAt 9 ES
Posts: 85

Rep: Reputation: 15
Create a ram disk


Hi,
I have been told that the driver for Ultrium 460 tape under AS 3 exists since AS 2.1 and that I need to modify the scsi config and create a new ram disk which will recognize the device at boot.
1- Is this true ?
2- How to modify the scsi config and how to create a new ram disk ?
Regards
Consty
 
Old 05-10-2005, 03:54 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,930

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
No, at least not that I am aware of. AFAIK the SCSI tape module st in addition to the SCSI controller and the scsi_mod should work. Check the output of the command lsmod to see if the modules are loading. The SCSI tape device will be /dev/st0 & /dev/nst0 for rewind and no rewind after tape operation respectively.
 
Old 05-10-2005, 05:14 PM   #3
consty
Member
 
Registered: Feb 2004
Location: Douala-Cameroun
Distribution: RedHAt 9 ES
Posts: 85

Original Poster
Rep: Reputation: 15
Create ram drive (followed)

Hi,
There is no /dev/st0 nor /dev/nst0 device.
There is something to do to create the device, I don't know what.
THanks
 
Old 05-10-2005, 06:08 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,930

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Post the output of the commands
lspci
lsmod

This will tell us what SCSI controller is installed in your PC and what modules are being loaded.
 
Old 05-12-2005, 04:23 AM   #5
consty
Member
 
Registered: Feb 2004
Location: Douala-Cameroun
Distribution: RedHAt 9 ES
Posts: 85

Original Poster
Rep: Reputation: 15
"Create ram disk" :These are the outputs of lsmod and lspci

1) lsmod output

[root]# lsmod
Module Size Used by Not tainted
soundcore 7044 0 (autoclean)
ide-cd 34016 0 (autoclean)
cdrom 32896 0 (autoclean) [ide-cd]
st 31524 0 (autoclean) (unused)
usbserial 23964 0 (autoclean) (unused)
lp 9156 0 (autoclean)
parport 38848 0 (autoclean) [lp]
autofs4 16984 0 (autoclean) (unused)
audit 90744 3
tg3 65992 2
ipt_REJECT 4632 1 (autoclean)
ipt_state 1080 6 (autoclean)
ip_conntrack 29768 1 (autoclean)
[ipt_state]
iptable_filter 2412 1 (autoclean)
ip_tables 16544 3 [ipt_REJECT
ipt_state iptable_filter]
floppy 57520 0 (autoclean)
sg 37388 0 (autoclean) (unused)
microcode 6912 0 (autoclean)
keybdev 2944 0 (unused)
mousedev 5656 1
hid 22308 0 (unused)
input 6176 0 [keybdev mousedev
hid]
usb-ohci 23176 0 (unused)
usbcore 81152 1 [usbserial hid
usb-ohci]
ext3 89992 5
jbd 55092 5 [ext3]
cciss 45220 6
sd_mod 13936 0 (unused)
scsi_mod 115240 3 [st sg cciss sd_mod]

2) lspci output

[root]# lspci
00:03.0 VGA compatible controller: ATI Technologies
Inc Rage XL (rev 27)
00:0c.0 System peripheral: Compaq Computer Corporation
Integrated Lights Out Controller (rev 01)
00:0c.2 System peripheral: Compaq Computer Corporation
Integrated Lights Out Processor (rev 01)
00:0f.0 Host bridge: ServerWorks CSB5 South Bridge
(rev 93)
00:0f.1 IDE interface: ServerWorks CSB5 IDE Controller
(rev 93)
00:0f.2 USB Controller: ServerWorks OSB4/CSB5 OHCI USB
Controller (rev 05)
00:0f.3 ISA bridge: ServerWorks CSB5 LPC bridge
00:10.0 Memory controller: Compaq Computer Corporation
Memory Hot-Plug Controller (rev 03)
00:10.1 Memory controller: Compaq Computer Corporation
Memory Hot-Plug Controller (rev 03)
00:10.2 Memory controller: Compaq Computer Corporation
Memory Hot-Plug Controller (rev 03)
00:17.0 Host bridge: Compaq Computer Corporation:
Unknown device b1c2
00:18.0 Host bridge: ServerWorks CIOB30 (rev 04)
00:18.2 Host bridge: ServerWorks CIOB30 (rev 04)
00:18.4 Host bridge: ServerWorks CIOB30 (rev 04)
00:18.6 Host bridge: ServerWorks CIOB30 (rev 04)
00:19.0 Host bridge: ServerWorks CIOB30 (rev 04)
00:19.2 Host bridge: ServerWorks CIOB30 (rev 04)
01:04.0 Ethernet controller: Broadcom Corporation
NetXtreme BCM5703X Gigabit Ethernet (rev 02)
01:05.0 Ethernet controller: Broadcom Corporation
NetXtreme BCM5703X Gigabit Ethernet (rev 02)
02:0e.0 RAID bus controller: Compaq Computer
Corporation Smart Array 5i/532 (rev 01)
03:1e.0 PCI Hot-plug controller: Compaq Computer
Corporation PCI Hotplug Controller (rev 14)
07:02.0 SCSI storage controller: LSI Logic / Symbios
Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev
07)
07:02.1 SCSI storage controller: LSI Logic / Symbios
Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev
07)
07:1e.0 PCI Hot-plug controller: Compaq Computer
Corporation PCI Hotplug Controller (rev 14)
0b:1e.0 PCI Hot-plug controller: Compaq Computer
Corporation PCI Hotplug Controller (rev 14)
#
 
Old 05-12-2005, 07:28 AM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,930

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Your SCSI controller module is not loaded. Try:
modprobe sym53c8xx
 
Old 05-12-2005, 03:36 PM   #7
consty
Member
 
Registered: Feb 2004
Location: Douala-Cameroun
Distribution: RedHAt 9 ES
Posts: 85

Original Poster
Rep: Reputation: 15
Hi,
No change after modprobe command.
Looks like the BIOS see the driver (Ultrium) but Linux does'nt see any driver
for HP Storage Ultrium 460 or I don't see a name related to that.
Regards
 
Old 05-12-2005, 04:44 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 14,930

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
What do you mean by no change? Was there an error message like 'module not found' after you entered the command?

The SCSI tape module is called st and it is being loaded according to the output of lsmod. AFAIK this is the only tape drive required.

Look at the output of the dmesg command. Are there any messages relating to the SCSI controller module?
 
Old 05-13-2005, 03:23 PM   #9
consty
Member
 
Registered: Feb 2004
Location: Douala-Cameroun
Distribution: RedHAt 9 ES
Posts: 85

Original Poster
Rep: Reputation: 15
I solved the problem by re-installing Linux, I think that the system detected
the adapter and loaded the good driver and options.
Thanks a lot for your help
 
Old 05-19-2005, 09:06 AM   #10
froggo
LQ Newbie
 
Registered: May 2005
Posts: 28

Rep: Reputation: 15
Hi i am having the same problem with my box, i'm running AS2.1 i installed the proliant support pack from hp and it still did not work here is a list of my lspci
00:00.0 Host bridge: Intel Corporation: Unknown device 3590 (rev 0c)
00:02.0 PCI bridge: Intel Corporation: Unknown device 3595 (rev 0c)
00:06.0 PCI bridge: Intel Corporation: Unknown device 3599 (rev 0c)
00:1d.0 USB Controller: Intel Corporation: Unknown device 24d2 (rev 02)
00:1d.1 USB Controller: Intel Corporation: Unknown device 24d4 (rev 02)
00:1d.2 USB Controller: Intel Corporation: Unknown device 24d7 (rev 02)
00:1d.3 USB Controller: Intel Corporation: Unknown device 24de (rev 02)
00:1d.7 USB Controller: Intel Corporation: Unknown device 24dd (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82820 820 (Camino 2) Chipset PCI (rev c2)
00:1f.0 ISA bridge: Intel Corporation: Unknown device 24d0 (rev 02)
00:1f.1 IDE interface: Intel Corporation: Unknown device 24db (rev 02)
01:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
01:04.0 System peripheral: Compaq Computer Corporation: Unknown device b203 (rev 01)
01:04.2 System peripheral: Compaq Computer Corporation: Unknown device b204 (rev 01)
02:00.0 PCI bridge: Intel Corporation: Unknown device 0329 (rev 09)
02:00.2 PCI bridge: Intel Corporation: Unknown device 032a (rev 09)
03:01.0 Ethernet controller: BROADCOM Corporation: Unknown device 1648 (rev 10)
03:01.1 Ethernet controller: BROADCOM Corporation: Unknown device 1648 (rev 10)
04:03.0 RAID bus controller: Compaq Computer Corporation: Unknown device 0046 (rev 01)
05:00.0 PCI bridge: Intel Corporation: Unknown device 0329 (rev 09)
05:00.2 PCI bridge: Intel Corporation: Unknown device 032a (rev 09)

and here is lsmod
Module Size Used by Not tainted
soundcore 7940 0 (autoclean)
sg 35076 0 (autoclean)
ide-scsi 10464 0
pcmcia_core 57440 0
autofs 13796 0 (autoclean) (unused)
tg3 50528 1
usb-uhci 26948 0 (unused)
usbcore 68864 1 [usb-uhci]
ext3 74176 8
jbd 55304 8 [ext3]
cciss 68352 9
sd_mod 13888 0 (unused)
scsi_mod 126252 4 [sg ide-scsi cciss sd_mod]

Please help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting without RAM disk Tinku Linux - General 3 10-03-2005 03:57 PM
ram disk quiron Linux From Scratch 3 07-20-2005 03:43 AM
Ram disk consty Red Hat 1 05-11-2005 08:06 AM
Noob question... how do I create a RAM floppy? Eerath Slackware 1 03-23-2005 04:39 PM
How to create RAM drive? carboncopy Slackware 3 06-23-2003 11:32 PM


All times are GMT -5. The time now is 03:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration