LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2004, 12:55 PM   #1
mrosati
Member
 
Registered: Nov 2003
Location: Mestre - ITALY
Distribution: Debian sarge
Posts: 132

Rep: Reputation: 15
create a partition


hi,
i would like to create a partition to store my files because mi root partition is becoming too small... so i created a partition with the utility cfdisk (ext2), edited the fstab file, but:

1) i can mount it only as root
2)it mounts the partition in read only.

how can i manage to mount in read/write the partition using a normal account?

thanks

matteo
 
Old 04-20-2004, 01:03 PM   #2
qqlinuxquestion
LQ Newbie
 
Registered: Apr 2004
Distribution: redhat, debian
Posts: 6

Rep: Reputation: 0
what command did you use to mount your partition?
 
Old 04-20-2004, 01:09 PM   #3
pH*
Member
 
Registered: Nov 2003
Distribution: Slackware 10
Posts: 40

Rep: Reputation: 15
did you allow for the partition to be mounted by 'users' rather than owner and to be mounted 'rw' (read, write) rather than 'ro' (read only) in the fstab file also?
 
Old 04-20-2004, 01:09 PM   #4
mrosati
Member
 
Registered: Nov 2003
Location: Mestre - ITALY
Distribution: Debian sarge
Posts: 132

Original Poster
Rep: Reputation: 15
i simply use mount /device /destination.... the real problem is that the partition is mounted in read only!
 
Old 04-20-2004, 02:02 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,390

Rep: Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651
What filesystem did you use to format the partition?
What permissions are assigned to the mount point?
Post the fstab entry for that partition.
 
Old 04-20-2004, 02:12 PM   #6
mrosati
Member
 
Registered: Nov 2003
Location: Mestre - ITALY
Distribution: Debian sarge
Posts: 132

Original Poster
Rep: Reputation: 15
ok it's better if i told you step by step what i did:
1)root console --> cfdisk --> "type" of partition Linux (i suppose it's ext2..?) --> write.
2)edited fstab... here you got what i wrote

/dev/hda7 /mnt/dati ext2 noauto,user 0 0

now when i mount (mount /mnt/dati) i get

mount: wrong fs type, bad option, bad superblock on /dev/hda7,
or too many mounted file system

.....what can i do?!?!

p.s. i get this error both with normal user and root
 
Old 04-20-2004, 04:31 PM   #7
pH*
Member
 
Registered: Nov 2003
Distribution: Slackware 10
Posts: 40

Rep: Reputation: 15
/dev/hda7 /mnt/dati ext2 noauto,user 0 0

changing 'user' to 'users' will allow you to acces the partition when not logged in as root.

add 'rw' to the end of those options to make it look like this:

noauto,users,rw

that will allow you to access the partition as read+write

its possible you could leave the fs type as auto rather than ext2 and let it auto-detect the fs type... but i could be wrong about that. seems like i remember reading something about that possibly messing up file systems it was a monday or the date was divisible by two, or some other esoteric reason.

best to make the other changes i posted above, reboot, and try it again.

might be helpful if you posted your entire /etc/fstab file too.

edit: and just to be sure, you have created the directory you're trying to mount the partition on, right? /mnt/dati (or whatever) is actually there, within the /mnt directory? the mount command doesn't create that for you...

Last edited by pH*; 04-20-2004 at 04:42 PM.
 
Old 04-21-2004, 06:08 AM   #8
mrosati
Member
 
Registered: Nov 2003
Location: Mestre - ITALY
Distribution: Debian sarge
Posts: 132

Original Poster
Rep: Reputation: 15
ok i will try to make these modifies, in the meantime, thanks a lot for your help!
 
Old 04-21-2004, 06:30 AM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,390

Rep: Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651Reputation: 1651
It doesn't appear like you formatted the partition.
Once you have created the partition you need to format it with a file system. To format an ext3 file system:

mke2fs -j /dev/hda7

Then your /etc/fstab file should be:
/dev/hda7 /mnt/dati ext3 noauto, users 0 0

The difference between the options user and users is:
user - Allows an ordinary user to mount the file system but only that user that mounted can unmount.

users - Allows any user to mount and unmount the file system.

See man mount for additional information.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using partition magic to create Linux partition then install EviLBoX Linux - General 5 09-12-2008 05:01 AM
How to resize a partition and create/mount a new partition? Maarten_Holland Linux - Newbie 1 04-20-2005 08:56 AM
Trying to create a partition help embassy Linux - Software 3 12-08-2004 07:03 PM
create new partition vande Linux - Newbie 1 10-13-2004 11:35 PM
Create partition? mikeshn Linux - General 7 02-08-2004 08:31 PM


All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration