LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2010, 08:00 AM   #1
EAI
Member
 
Registered: Jun 2010
Posts: 34

Rep: Reputation: 15
CPU 100% using resources


Hi

I am using Ubuntu 10.04, using the TOP command in terminal shows all resources being used, the one that is drawing the most usage is a function called "phy0".

It will appear for a couple of seconds then stop the reappear.

With all of this going on it is messing up the machine, slowing it down and using 100% cpu.

I normally have five to six packages opened all at once with no problems at all and the hard drive light very rarely comes on with this "phy0" function it is causing the hard drive light to come on continuously.


Thanks EAI
 
Old 06-29-2010, 09:42 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,921

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
iirc phy0 is some sort of virtual device in the network stack. Stop your network. Does the 100% cpu still appear?
 
Old 06-30-2010, 02:54 AM   #3
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
Hi

Stopping the network it still appears.

Thanks EAI




Quote:
Originally Posted by business_kid View Post
iirc phy0 is some sort of virtual device in the network stack. Stop your network. Does the 100% cpu still appear?
 
Old 06-30-2010, 03:15 AM   #4
fruttenboel
Member
 
Registered: Jul 2008
Location: Tilburg NL
Distribution: Slackware 14.2 ciurrent, kernel 3.18.11
Posts: 270

Rep: Reputation: 48
Quote:
Originally Posted by EAI View Post
Hi

I am using Ubuntu 10.04, using the TOP command in terminal shows all resources being used, the one that is drawing the most usage is a function called "phy0".

It will appear for a couple of seconds then stop the reappear.

With all of this going on it is messing up the machine, slowing it down and using 100% cpu.

I normally have five to six packages opened all at once with no problems at all and the hard drive light very rarely comes on with this "phy0" function it is causing the hard drive light to come on continuously.


Thanks EAI
A 'phy' used to be a physical network interface. In most cases, the Ethernet transformers were called "phy's". But, 'phytech' used to be a german comany selling micro processor systems. So the name is ot very unique. Probably a network component. These can be very busy in bursts.

what's more important: which 6 applications have you running for standard?

Ubuntu is to Linux what an SUV is to cars. It tries to please so very much by all the things that have made The Other System so popular, that the zillions of ncessities that provide colour, sound and smells to the user eat up all the resources.

Try running a live distro like www.slax.org and see if that also eats up all your GHz's and CPU cores. The problem is not an application that's gone berzerk. The problem is Ubuntu. The Linux that cannot please all but will do anything to still have this done. Thereby causing your system behavior.

What's the CPU of your system? AM size? Disk size? KDE, xfce or Gnome? How much eye candy do you have enabled? Which background processes? Your geographic location?
 
Old 06-30-2010, 03:36 AM   #5
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
Hi

Stopping the network it still appears.

Thanks EAI




Quote:
Originally Posted by business_kid View Post
iirc phy0 is some sort of virtual device in the network stack. Stop your network. Does the 100% cpu still appear?
 
Old 06-30-2010, 03:47 AM   #6
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
100% cpu pgy0

Hi

Copy of the terminal read out.

I am using a single cpu 2.8ghz intel

The earlier Linux op 9.0 and above, I have had no problems, even using the same packages, since I loaded the last op 10.04, all sorts of problems, but phy being the worst.

I am using gnome.

Thanks EAI



sgu@sgu-desktop:~$ top

top - 16:38:58 up 53 min, 2 users, load average: 0.48, 0.63, 0.67
Tasks: 152 total, 1 running, 151 sleeping, 0 stopped, 0 zombie
Cpu(s): 3.3%us, 1.3%sy, 0.0%ni, 95.3%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 2061448k total, 627288k used, 1434160k free, 53216k buffers
Swap: 3226616k total, 0k used, 3226616k free, 296768k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
992 root 20 0 38628 20m 8640 S 1.7 1.0 1:47.29 Xorg
2258 sgu 20 0 42996 13m 10m S 1.3 0.7 0:00.65 gnome-terminal
1538 sgu 20 0 318m 77m 27m S 1.0 3.9 2:35.03 firefox-bin
1178 sgu 20 0 63600 23m 7824 S 0.3 1.2 0:20.46 compiz
1 root 20 0 2796 1636 1192 S 0.0 0.1 0:00.43 init
2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root RT 0 0 0 0 S 0.0 0.0 0:00.00 migration/0
4 root 20 0 0 0 0 S 0.0 0.0 0:00.16 ksoftirqd/0
5 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
6 root 20 0 0 0 0 S 0.0 0.0 0:00.06 events/0
7 root 20 0 0 0 0 S 0.0 0.0 0:00.00 cpuset
8 root 20 0 0 0 0 S 0.0 0.0 0:00.00 khelper
9 root 20 0 0 0 0 S 0.0 0.0 0:00.00 netns
10 root 20 0 0 0 0 S 0.0 0.0 0:00.00 async/mgr
11 root 20 0 0 0 0 S 0.0 0.0 0:00.00 pm
12 root 20 0 0 0 0 S 0.0 0.0 0:00.00 sync_supers
13 root 20 0 0 0 0 S 0.0 0.0 0:00.00 bdi-default

























Quote:
Originally Posted by fruttenboel View Post
A 'phy' used to be a physical network interface. In most cases, the Ethernet transformers were called "phy's". But, 'phytech' used to be a german comany selling micro processor systems. So the name is ot very unique. Probably a network component. These can be very busy in bursts.

what's more important: which 6 applications have you running for standard?

Ubuntu is to Linux what an SUV is to cars. It tries to please so very much by all the things that have made The Other System so popular, that the zillions of ncessities that provide colour, sound and smells to the user eat up all the resources.

Try running a live distro like www.slax.org and see if that also eats up all your GHz's and CPU cores. The problem is not an application that's gone berzerk. The problem is Ubuntu. The Linux that cannot please all but will do anything to still have this done. Thereby causing your system behavior.

What's the CPU of your system? AM size? Disk size? KDE, xfce or Gnome? How much eye candy do you have enabled? Which background processes? Your geographic location?
 
Old 07-01-2010, 04:11 AM   #7
fruttenboel
Member
 
Registered: Jul 2008
Location: Tilburg NL
Distribution: Slackware 14.2 ciurrent, kernel 3.18.11
Posts: 270

Rep: Reputation: 48
Quote:
Originally Posted by EAI View Post
Hi

Copy of the terminal read out.

I am using a single cpu 2.8ghz intel
That should be no problem.

Code:
top - 16:38:58 up 53 min,  2 users,  load average: 0.48, 0.63, 0.67
Tasks: 152 total,   1 running, 151 sleeping,   0 stopped,   0 zombie
Cpu(s):  3.3%us,  1.3%sy,  0.0%ni, 95.3%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   2061448k total,   627288k used,  1434160k free,    53216k buffers
Swap:  3226616k total,        0k used,  3226616k free,   296768k cached
Your CPU load is 3%, not 100%. It is 95% idle. You have 2 GB of RAM and 3 GB of swap. This i all pretty normal. Your system should not feel sluggish.

Here's my 'top':
Code:
top - 11:06:08 up 13 min,  5 users,  load average: 0.00, 0.04, 0.05
Tasks: 108 total,   3 running, 105 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    963348k total,   361120k used,   602228k free,    19632k buffers
Swap:  1461872k total,        0k used,  1461872k free,   200584k cached
I just started multiple movies and here is 'top' again:
Code:
top - 11:09:25 up 17 min,  5 users,  load average: 1.35, 0.55, 0.23
Tasks: 108 total,   4 running, 104 sleeping,   0 stopped,   0 zombie
Cpu(s): 88.7%us,  3.7%sy,  0.0%ni,  0.0%id,  4.3%wa,  0.0%hi,  3.3%si,  0.0%st
Mem:    963348k total,   550988k used,   412360k free,    20356k buffers
Swap:  1461872k total,        0k used,  1461872k free,   255000k cached
This is a super sluggish system....
 
Old 07-01-2010, 10:22 AM   #8
cantab
Member
 
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by EAI View Post
sgu@sgu-desktop:~$ top

top - 16:38:58 up 53 min, 2 users, load average: 0.48, 0.63, 0.67
Your load average is the important thing. Load average is, loosely speaking, how many programs are trying to run. The numbers are over the last one, five, and 15 minutes.

If the load average is below the number of processors/cores you have, the system has power to spare. If the load average is higher, the system is overloaded. In your case, you have one processor with one core, and the numbers are below one, so everything is fine.

This is a simple view - there are some fine details.
 
Old 07-02-2010, 02:38 AM   #9
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
100% cpu pgy0

Hi

Even when the pc is idle phyo appears and still causes the cpu to run at 100%, I will try and copy next time it dose this.

It only occurs sometimes for a few minutes or hours.

Could it be a virus?


Thanks EAI








Quote:
Originally Posted by cantab View Post
Your load average is the important thing. Load average is, loosely speaking, how many programs are trying to run. The numbers are over the last one, five, and 15 minutes.

If the load average is below the number of processors/cores you have, the system has power to spare. If the load average is higher, the system is overloaded. In your case, you have one processor with one core, and the numbers are below one, so everything is fine.

This is a simple view - there are some fine details.
 
Old 07-02-2010, 02:29 PM   #10
fruttenboel
Member
 
Registered: Jul 2008
Location: Tilburg NL
Distribution: Slackware 14.2 ciurrent, kernel 3.18.11
Posts: 270

Rep: Reputation: 48
Quote:
Originally Posted by EAI View Post
Hi

Could it be a virus?

Thanks EAI
Not very likely. It might be your expectations are too high....
 
Old 07-02-2010, 11:19 PM   #11
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
100% cpu pgy0

How dose one capture TOP in terminal or freeze the results, because the data is changing all the time.

The earlier versions of ubuntu 10.04 do not have this problem has I have loaded these onto other machines.

It is the later 10.04 that is showing "phy0" and using 100%cpu, even on the dual core pc that I am using, the only reason that it it dose not effect that pc because it has dual core, but that is running at 100% cpu when there is no programs running.

Thanks EAI






Quote:
Originally Posted by fruttenboel View Post
Not very likely. It might be your expectations are too high....
 
Old 07-02-2010, 11:32 PM   #12
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,546

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
Sounds like a driver problem - stopping the network won't normally unload a driver.
I'd be keeping an eye on /proc/interrupts and the context switches (cs in vmstat for example). If either/both keep increasing quickly might indicate a driver problem. Won't hep fix it though, you'll need a specific resolution for that; google for that.

As for your "top" question, run it in batch mode with an iteration count of one - redirect it to a file
Code:
top -b -n 1 > saveit.top
 
1 members found this post helpful.
Old 07-03-2010, 01:06 AM   #13
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
100% cpu pgy0

Hi

This time I was able to freeze terminal and it is showing "phy0" using 99% cpu resources, all I have running in the back ground as a quiet state is evolution and firefox.

Thanks EAI



top - 14:01:49 up 1:50, 2 users, load average: 1.40, 0.93, 0.63
Tasks: 148 total, 2 running, 146 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.0%us, 99.0%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 2061444k total, 564228k used, 1497216k free, 51288k buffers
Swap: 3226616k total, 0k used, 3226616k free, 263176k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
946 root 20 0 0 0 0 R 98.4 0.0 8:15.59 phy0
1755 sgu 20 0 2544 1196 904 R 0.6 0.1 0:00.14 top
231 root 20 0 0 0 0 S 0.3 0.0 0:04.09 scsi_eh_6
1185 sgu 20 0 62996 23m 7812 S 0.3 1.2 0:08.37 compiz
1531 sgu 20 0 301m 63m 27m S 0.3 3.2 1:11.22 firefox-bin
1 root 20 0 2796 1636 1192 S 0.0 0.1 0:00.43 init
2 root 20 0 0 0 0 S 0.0 0.0 0:00.00 kthreadd
3 root RT 0 0 0 0 S 0.0 0.0 0:00.00 migration/0
4 root 20 0 0 0 0 S 0.0 0.0 0:00.48 ksoftirqd/0
5 root RT 0 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
6 root 20 0 0 0 0 S 0.0 0.0 0:00.08 events/0
7 root 20 0 0 0 0 S 0.0 0.0 0:00.00 cpuset
8 root 20 0 0 0 0 S 0.0 0.0 0:00.00 khelper
9 root 20 0 0 0 0 S 0.0 0.0 0:00.00 netns
10 root 20 0 0 0 0 S 0.0 0.0 0:00.00 async/mgr
11 root 20 0 0 0 0 S 0.0 0.0 0:00.00 pm
12 root 20 0 0 0 0 S 0.0 0.0 0:00.00 sync_supers












Quote:
Originally Posted by syg00 View Post
Sounds like a driver problem - stopping the network won't normally unload a driver.
I'd be keeping an eye on /proc/interrupts and the context switches (cs in vmstat for example). If either/both keep increasing quickly might indicate a driver problem. Won't hep fix it though, you'll need a specific resolution for that; google for that.

As for your "top" question, run it in batch mode with an iteration count of one - redirect it to a file
Code:
top -b -n 1 > saveit.top
 
Old 07-03-2010, 02:59 AM   #14
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 7,921

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
stop yopur network, (& network manager) remove modules, etc and see if phy0 still shows top. Then tell us about your network setup
 
Old 07-04-2010, 01:25 AM   #15
EAI
Member
 
Registered: Jun 2010
Posts: 34

Original Poster
Rep: Reputation: 15
1oo%cpu

Hi

I went back to ubuntu 9.10, problem solved.

Interesting to note that before I loaded the updates for 9.10 phy0 was using the cpu to about 90%, since the updates no longer see phy0 occuring.

In 10.01 it was just causing to many interupts.

Thanks EAI
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Plasma plasmoid using 100% resources; cannot remove peteyperson Linux - Newbie 12 02-07-2009 06:42 AM
Inappropriate use of CPU resources Swift&Smart Slackware 4 01-18-2007 02:02 AM
100% cpu use 100% of the time serafean Linux - Newbie 4 05-04-2006 03:36 PM
Share CPU resources and memory? corbintechboy General 3 03-17-2006 04:36 AM
XORG using a lot of CPU resources GreatBrak Ubuntu 1 12-02-2005 02:56 PM


All times are GMT -5. The time now is 02:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration