LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 11-11-2003, 04:27 AM   #1
p3ngu!n
Member
 
Registered: Oct 2003
Posts: 64

Rep: Reputation: 15
Couple of questions...


Is there such a thing as defragmentation in linux? If so, how do I do it?

And two: when I install glib-2.3.0 and gtk+-2.3.0 I think I'm installing them in the wrong directories. Where the hell do they go? Here's what I get when I try to install gtk+-2.3.0:

Quote:
checking for glib-2.0 >= 2.3.0 atk >= 1.0.1 pango >= 1.2.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.3.0 atk >= 1.0.1 pango >= 1.2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[root@localhost gtk+-2.3.0]#
What do I do?
 
Old 11-11-2003, 04:29 AM   #2
p3ngu!n
Member
 
Registered: Oct 2003
Posts: 64

Original Poster
Rep: Reputation: 15
Same thing for trying to install XMMS 1.2.8
Quote:
checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.2...
*** 'glib-config --version' returned 1.2.9, but GLIB (1.2.10)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***
[root@localhost xmms-1.2.8]#
But I DID install GLIB 2.3.0 so I'm guessing it IS more recent than 1.2.2. What am I doing wrong? Wrong directory?
 
Old 11-11-2003, 05:41 AM   #3
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 65
Defragmentation is not a big problem in Linux. The file system is very different than windoze. It kind of does it automatically. It also does it during fsck to I think. It did that on mine anyway.

Mine may run about 1 to 2%. I wouldn't worry about it in windoze and I surely won't in Linux.

Hope that helps to clear that up a bit.

Later

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple questions. kuplo Linux - Newbie 0 11-26-2005 10:48 AM
couple of questions?? Lucas10 Linux - Newbie 23 06-04-2005 05:45 PM
a Couple of questions! Nik0s Linux - Newbie 14 01-25-2004 11:01 AM
Just a couple of questions... LI-6Y LUCY Linux - Newbie 4 09-07-2003 09:33 AM
A couple questions aceman817 Linux - Networking 2 04-25-2001 06:02 PM


All times are GMT -5. The time now is 12:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration