LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2002, 02:05 PM   #1
Blackice
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Rep: Reputation: 0
Question Cound install LILO correctly


Hello there,

i've got a problem with my Mandrake 8.1...
I want to install Lilo manually - create a /etc/lilo.conf and installed Lilo on the Primary Master HD (/dev/hda) but when I reboot my PC it just writes 0101010101010101 an so on! I want to write lilo on /dev/hda. My Linux hd is /dev/hdc. Here is my Lilo.conf:

boot=/dev/hda
prompt
timeout=5
vga=normal
root=/dev/hdc1
menu-title="Gateway Boot:"

image=/boot/vmlinuz
label=Mandrake_Linux

other=/dev/hda1
label=Windows_2000

What is wrong with the config file? Or forgot I just to use any params?
 
Old 02-25-2002, 06:29 PM   #2
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Make your lilo.conf look like the one below and see if that fixes the problem.



boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=5
vga=normal
menu-title="Gateway Boot:"

image=/boot/vmlinuz
label=Mandrake_Linux
root=/dev/hdc1
read-only

other=/dev/hda1
label=Windows_2000
table=/dev/hda

After you make the changes, run /sbin/lilo.
 
Old 02-25-2002, 07:41 PM   #3
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
This is the whole lilo.conf on my system (dual boot Mandy and RH)
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
vga=normal
default=linux_redhat
keytable=/boot/us.klt
lba32
prompt
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label=linux
root=/dev/hda1
initrd=/boot/initrd.img
append=" hdc=ide-scsi hdd=ide-scsi devfs=mount quiet"
vga=788
read-only
image=/boot/vmlinuz
label=linux-nonfb
root=/dev/hda1
initrd=/boot/initrd.img
append=" hdc=ide-scsi hdd=ide-scsi devfs=mount"
read-only
image=/boot/vmlinuz
label=failsafe
root=/dev/hda1
initrd=/boot/initrd.img
append=" hdc=ide-scsi hdd=ide-scsi devfs=mount failsafe"
read-only
image=/boot/vmlinuz-2.2secure
label=linux-2.2
root=/dev/hda1
initrd=/boot/initrd-2.2secure.img
append=" hdc=ide-scsi hdd=ide-scsi devfs=mount"
vga=788
read-only
image=/mnt/redhat/boot/vmlinuz-2.4.7-10
label=linux_redhat
initrd=/mnt/redhat/boot/initrd-2.4.7-10.img
read-only
root=/dev/hdb2
append="hdc=ide-scsi hdd=ide-scsi"
 
Old 02-26-2002, 06:37 AM   #4
Blackice
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Original Poster
Rep: Reputation: 0
THANKS

I'll try these settings as soon as possible! Thanks
 
Old 02-26-2002, 06:37 AM   #5
Blackice
LQ Newbie
 
Registered: Feb 2002
Posts: 3

Original Poster
Rep: Reputation: 0
THANKS

I'll try these settings as soon as possible! Thanks
 
Old 02-26-2002, 12:52 PM   #6
CragStar
Senior Member
 
Registered: Oct 2000
Location: UK - Frome
Distribution: Ubuntu
Posts: 1,081

Rep: Reputation: 47
I've had that problem before, and if you can't get it to work by changing your /etc/lilo.conf then you may have to change the physical place of your HD. I had my Linux disk on /dev/hdc but I had to chnage it to /dev/hdb to get rid of the error, which was

101010101010101010101010101010101

all over the screen.

Let me know if you succeed, as I never found a way apart from what I said I did.
 
Old 02-27-2002, 09:52 AM   #7
kodiakmook
Member
 
Registered: Nov 2001
Location: Ohio
Distribution: Redhat 7.3, Mandrake 8.1
Posts: 43

Rep: Reputation: 15
Don't know if this should be on a separate thread or not, but I'm getting a similar error when installing MDK 8.1 on a second hard drive.

hda is Win2k Pro, mandrake is installed on hdb1. Mdk runs fine, I just have to boot from a diskette. I tried installing lilo on MBR, but just as lilo starts to kick in I get 070707070707070707 written to the screen and I have to manually restart.

After reformatting MBR for windows, I installed lilo to hdb1 and used the windows bootloader. Now, on boot, the windows bootloader comes up and Win2K boots fine. But, if I choose Mandrake, I'm greeted with the 070707070707 again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO not functioning correctly for Mandrake 8.2, Only prints "07" frogger12 Mandriva 3 05-31-2004 10:11 PM
Did I install GD correctly? lexington Linux - Newbie 15 04-15-2004 12:06 PM
Lilo not working correctly after installing slackware. jpierce09 Slackware 5 07-15-2003 02:04 PM
Did i install xinetd correctly? OlRoy Linux - Newbie 4 06-07-2003 03:56 PM
cound not open default font 'fixed'...HELP! andym Linux - Newbie 4 05-26-2003 06:13 PM


All times are GMT -5. The time now is 10:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration