LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 10-01-2008, 05:32 AM   #1
dalvis
LQ Newbie
 
Registered: Oct 2008
Posts: 16

Rep: Reputation: 0
Question couldn't add command channel 127.0.0.1#953


Hello all

I am trying to setup nameserver it look like up and running
but with following errors in my log it shows as follows

Oct 1 06:29:13 localhost named[8369]: starting BIND 9.3.4-P1 -u named -D -t /var/named/chroot
Oct 1 06:29:13 localhost named[8369]: found 1 CPU, using 1 worker thread
Oct 1 06:29:13 localhost named[8369]: loading configuration from '/etc/named.conf'
Oct 1 06:29:13 localhost named[8369]: listening on IPv6 interfaces, port 53
Oct 1 06:29:13 localhost named[8369]: listening on IPv4 interface lo, 127.0.0.1#53

Oct 1 06:29:13 localhost named[8369]: listening on IPv4 interface eth0, 192.168.1.1#53
Oct 1 06:29:13 localhost named[8369]: listening on IPv4 interface eth0:0, 192.168.1.3#53
Oct 1 06:29:13 localhost named[8369]: command channel listening on 127.0.0.1#953
Oct 1 06:29:13 localhost named[8369]: zone 0.in-addr.arpa/IN/internal: loaded serial 42
Oct 1 06:29:13 localhost named[8369]: zone 0.0.127.in-addr.arpa/IN/internal: loaded serial 2008092501
Oct 1 06:29:13 localhost named[8369]: zone 1.168.192.in-addr.arpa/IN/internal: loaded serial 2008093001
Oct 1 06:29:13 localhost named[8369]: zone 2.168.192.in-addr.arpa/IN/internal: loaded serial 2008093001
Oct 1 06:29:13 localhost named[8369]: zone 255.in-addr.arpa/IN/internal: loaded serial 42
Oct 1 06:29:13 localhost named[8369]: zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN/internal: loaded serial 1997022700
Oct 1 06:29:13 localhost named[8369]: zone infotechs.in/IN/internal: loaded serial 2008092901
Oct 1 06:29:13 localhost named[8369]: zone localdomain/IN/internal: loaded serial 42
Oct 1 06:29:13 localhost named[8369]: zone localhost/IN/internal: loaded serial 2008092602
Oct 1 06:29:13 localhost named[8369]: zone myexample2.com/IN/internal: loaded serial 2008092901
Oct 1 06:29:13 localhost named[8369]: zone myexample.com/IN/external: loaded serial 2008093001
Oct 1 06:29:13 localhost named[8369]: zone myexample2.com/IN/external: loaded serial 2008093001
Oct 1 06:29:13 localhost named[8369]: D-BUS dhcdbd subscription disabled.
Oct 1 06:29:13 localhost named[8369]: D-BUS service enabled.
Oct 1 06:29:13 localhost named[8369]: running
Oct 1 06:29:13 localhost named[8369]: zone 0.0.127.in-addr.arpa/IN/internal: sending notifies (serial 2008092501)
Oct 1 06:29:13 localhost named[8369]: zone myexample.com/IN/internal: sending notifies (serial 2008092901)
Oct 1 06:29:13 localhost named[8369]: zone myexample2.com/IN/external: sending notifies (serial 2008093001)
-------------------
Oct 1 06:29:38 localhost NetworkManager: <WARNING> add_ip4_config_to_named (): Could not set forwarders for zone '.'. Error: 'Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.'.
---------------------
Oct 1 12:59:30 localhost named[8369]: zone myexample.com/IN/external: serial number (1) received from master 21.179.181.159#53 < ours (2008093001)
Oct 1 12:59:30 localhost named[8369]: zone myexample.com/IN/external: serial number (1) received from master 138.97.225.165#53 < ours (2008093001)

[root@united ~]# named -g -p 53
01-Oct-2008 13:41:52.219 starting BIND 9.3.4-P1 -g -p 53
01-Oct-2008 13:41:52.220 found 1 CPU, using 1 worker thread
01-Oct-2008 13:41:52.223 loading configuration from '/etc/named.conf'
01-Oct-2008 13:41:52.224 listening on IPv6 interfaces, port 53
01-Oct-2008 13:41:52.225 binding TCP socket: address in use
01-Oct-2008 13:41:52.225 listening on IPv4 interface lo, 127.0.0.1#53
01-Oct-2008 13:41:52.225 binding TCP socket: address in use
01-Oct-2008 13:41:52.225 listening on IPv4 interface eth0, 192.168.1.1#53
01-Oct-2008 13:41:52.225 binding TCP socket: address in use
01-Oct-2008 13:41:52.225 listening on IPv4 interface eth0:0, 192.168.1.3#53
01-Oct-2008 13:41:52.225 binding TCP socket: address in use
01-Oct-2008 13:41:52.229 /etc/named.conf:8: couldn't add command channel 127.0.0.1#953: address in use
01-Oct-2008 13:41:52.229 ignoring config file logging statement due to -g option
01-Oct-2008 13:41:52.229 couldn't open pid file '/var/run/named/named.pid': Permission denied
01-Oct-2008 13:41:52.229 exiting (due to early fatal error)
[root@united ~]#

I had changed the permission of '/var/run/named/named.pid' to 777 but still I am getting above errors

I shall highly appreciate if someone could let me know what and where i am doing wrong.
 
Old 10-01-2008, 05:52 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,973

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Posting /etc/named.conf should help.
Anyway since you're running named chrooted you must check the permissions under /var/named/chroot/ not /var/run/named/
About the title of you post, you should set up rndc
 
Old 10-02-2008, 05:33 PM   #3
dalvis
LQ Newbie
 
Registered: Oct 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Lightbulb couldn't add command channel 127.0.0.1#953

Quote:
Originally Posted by bathory View Post
Posting /etc/named.conf should help.
Anyway since you're running named chrooted you must check the permissions under /var/named/chroot/ not /var/run/named/
About the title of you post, you should set up rndc
Hello bathory,

I had changed the permission from 600 to 755 on /var/named/chroot/
and I am inserting my name config and all zone files for your review.

# Use with the following in named.conf, adjusting the allow list as needed:


include "/etc/rndc.key";


controls {
inet 127.0.0.1 port 953
allow { 127.0.0.1; } keys { "rndckey"; };
};

//include "/etc/named.custom";

options {
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
//statistics-file "/var/named/data/named_stats.txt";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
//query-source address * port 53;
allow-query { any; }; // default query access
allow-recursion { internals; }; // restrict recursion or externals;
//why i am getting rndc: connect failed: 127.0.0.1#953
zone-statistics yes;
statistics-file "/var/log/named.stats";
listen-on-v6 { any; };
notify yes;
recursion yes;

};




acl slaves {
72.9.106.68; // zoneedit
209.126.159.118; // zoneeditinclude "/etc/.unrndckey";
};

acl internals {
127.0.0.1/8;
192.168.10.1/24;
192.168.100.1/24;
192.168.20.1/24;

};


view "internal" {

forwarders { 192.168.10.1; 192.168.100.2; };
allow-query { internals; };
allow-transfer { internals; };
match-clients { internals; };


zone "." IN {
type hint;
file "/var/named/named.root";
};

zone "localdomain." IN {
type master;
file "/var/named/localdomain.zone";
allow-update { none; };
};

zone "localhost." IN {
type master;
file "/var/named/localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa." IN {
type master;
file "/var/named/named.local";
allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa." IN {
type master;
file "/var/named/named.ip6.local";
allow-update { none; };
};

zone "255.in-addr.arpa." IN {
type master;
file "/var/named/named.broadcast";
allow-update { none; };
};

zone "0.in-addr.arpa." IN {
type master;
file "/var/named/named.zero";
allow-update { none; };
};

zone "maxtechs.in" {
type master;
file "/var/named/internals/db.maxtechs.in";
};

zone "maxtechs2.net"{
type master;
file "/var/named/internals/db.maxtechs2.net";

};

zone "10.168.192.in-addr.arpa" {
type master;
notify no;
file "/var/named/internals/db.192.168.1";
allow-transfer { 192.168.10.1; 192.168.100.1; 176.74.236.21; 16.98.150.36; 29.16.159.18; };
};

zone "100.168.192.in-addr.arpa" {
type master;
notify no;
file "/var/named/internals/db.192.168.2";
allow-transfer { 192.168.1.1; 192.168.2.1; 176.74.236.21; 16.98.150.36; 29.16.159.18; };
};

};

view "external" {

zone "." IN {
type hint;
file "/var/named/named.root";
};

match-clients { any; };
zone "ns1.maxtechs.in" {
type master;
file "/var/named/externals/db.ns1.maxtechs.in";

};

zone "ns1.maxtechs2.net"{
type master;
file "/var/named/externals/db.ns1.maxtechs2.net";

};

zone "21.81.159.in-addr.arpa" {
type master;
notify no;
file "/var/named/externals/db.159.81.21";
allow-transfer { 192.168.1.1; 192.168.2.1; 176.74.236.21; 16.98.150.36; 29.16.159.18; };
};

};

------------------------------
My Internal zone files
------------------------------
Zone 10.168.192.in-addr.arpa
$TTL 86400
@ IN SOA ns1.maxtechs.in. root.maxtechs.in (
2008100203 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL


@ IN NS ns1.maxtechs.in.
@ IN NS ns18.zoneedit.com
@ IN NS ns4.zoneedit.com

1 IN PTR ns1.maxtechs.in.
2 IN PTR maxtechs.in.
2 IN PTR www.maxtechs.in.
2 IN PTR ftp.maxtechs.in.
2 IN PTR 3dsecure.maxtechs.in.
7 IN PTR ns1.maxtechs2.net.
3 IN PTR maxtechs2.net.
3 IN PTR www.maxtechs2.net.
3 IN PTR ftp.maxtechs2.net.
3 IN PTR 3dsecure.maxtechs2.net.
4 IN PTR mail.maxtechs.in.
4 IN PTR smtp.maxtechs.in.
5 IN PTR mail.maxtechs2.net.
5 IN PTR smtp.maxtechs2.net.
------------------------------------------
Zone 100.168.192.in-addr.arpa
$TTL 864000
@ IN SOA ns1.maxtechs2.net. root.maxtechs2.net (
2008100203 ; serial
28800 ; refresh
7200 ; retry
2419200 ; expire
864000 ; ttk
)

@ IN NS ns2.maxtechs2.net.

1 IN PTR ns2.maxtechs2.net.
-----------------------------------------
zone "maxtechs.in"
$TTL 86400
@ IN SOA ns1.maxtechs.in. root.maxtechs.in. (
2008100201 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL

@ IN NS ns1.maxtechs.in.
@ IN NS ns18.zoneedit.com.
@ IN NS ns17.zoneedit.com.

@ IN MX 10 mail.maxtechs.in.
@ IN MX 20 smtp.maxtechs.in.

localhost A 127.0.0.1
ns1 IN A 192.168.10.1
www IN A 192.168.10.2
ftp IN A 192.168.10.2
mail IN A 192.168.10.4
smtp IN A 192.168.10.4
--------------------------------------------
zone "maxtechs2.net"
$TTL 864000
@ IN SOA ns1.maxtechs2.net. root.maxtechs2.net. (
2008100203 ; serial
28800 ; refresh
7200 ; retry
2419200 ; expire
864000 ; ttl
)


@ IN NS ns1.maxtechs2.net.
@ IN NS ns3.zoneedit.com
@ IN NS ns4.zoneedit.com

localhost A 127.0.0.1
ns1 IN A 192.168.10.7
ns2 IN A 192.168.100.1
www IN A 192.168.10.3
ftp IN A 192.168.10.3
mail IN A 192.168.10.5
smtp IN A 192.168.10.5
--------------------------------------
My External Zone files
--------------------------------------
zone "21.81.159.in-addr.arpa"
$TTL 86400
@ IN SOA ns1.maxtechs.in. root.maxtechs.in. (
2008100203 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL

@ IN NS ns1.maxtechs.in.
@ IN NS ns1.maxtechs2.net.

21 IN PTR ns1.maxtechs.in.
21 IN PTR maxtechs.in.
21 IN PTR www.maxtechs.in.
21 IN PTR ftp.maxtechs.in.
21 IN PTR 3dsecure.maxtechs.in.
21 IN PTR smtp.maxtechs.in.
21 IN PTR mail.maxtechs.in.
21 IN PTR ns1.maxtechs2.net.
21 IN PTR maxtechs2.net.
21 IN PTR www.maxtechs2.net.
21 IN PTR ftp.maxtechs2.net.
21 IN PTR 3dsecure.maxtechs2.net.
21 IN PTR mail.maxtechs2.net.
21 IN PTR smtp.maxtechs2.net.
---------------------------------------------
zone "ns1.maxtechs.net"

$TTL 86400
@ IN SOA ns1.maxtechs.in. root.maxtechs.in. (
2008100203 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL


@ IN NS ns1.maxtechs.net.
@ IN MX 10 mail.maxtechs.net.
@ IN MX 20 smtp.maxtechs.net.

localhost A 127.0.0.1
ns1 IN A 59.81.21.21
www IN A 59.81.21.21
ftp IN A 59.81.21.21
mail IN A 59.81.21.21
smtp IN A 59.81.21.21

---------------------------------------------
zone "ns1.maxtechs2.net"

$TTL 86400
@ IN SOA ns1.maxtechs.in. root.maxtechs.in. (
2008100203 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL


@ IN NS ns1.maxtechs2.net.
@ IN MX 10 mail.maxtechs2.net.
@ IN MX 20 smtp.maxtechs2.net.

localhost A 127.0.0.1
ns1 IN A 59.81.21.21
ns2 IN A 59.81.21.21
www IN A 59.81.21.21
ftp IN A 59.81.21.21
mail IN A 59.81.21.21
smtp IN A 59.81.21.21
----------------------------------------
I hope above details are enough for troubleshooting the ipaddresses
and server names i have changed those are fake if you need as it is
give me your email so i can send it to you.

Thank you.
 
Old 10-03-2008, 03:33 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,973

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Here are some things to look:
1.
You need a
Code:
key "<key-name>" {
  algorithm hmac-md5;
  secret "<key-value>";
};
in /etc/named.conf
2.
Quote:
Oct 1 12:59:30 localhost named[8369]: zone myexample.com/IN/external: serial number (1) received from master 21.179.181.159#53 < ours (2008093001)
From the zone files you've posted I cannot see which zone is myexample.com, but in any way since you're supposed to be the master for that zone you shouldn't receive this warning.
3.
Quote:
recursion yes;
You should not allow recursion globally. You can allow it in your internal zone and for specific hosts (if you need to) in external zone.
4.
In external view move "match-clients { any; };" right after the "view external}" line.
5.
About the permissions problem it's due to the fact that you've started named using -g and without "-u named" option.
Start named normally and post here the logs if you see any error.
 
Old 10-03-2008, 11:58 AM   #5
dalvis
LQ Newbie
 
Registered: Oct 2008
Posts: 16

Original Poster
Rep: Reputation: 0
1,
I have inserted the key block in named conf
key "rndckey" {
algorithm hmac-md5;
secret "nmgfdsrngfdrakljhjd==";
};
2,
The zone file is which is in external view
zone "ns1.maxtechs.in"
3,
recursion yes;changed to no
4,
match-clients { any; }; moved right below external view first line in
external view.
5,
I used this command # named -g -p 53 to check the errors
I have started named with command # service named start
My Service Configration Tool shows this after named start

number of zones: 12
debug level: 0
xfers running: 0
xfers deferred: 0
soa queries in progress: 0
query logging is OFF
recursive clients: 0/1000
tcp clients: 0/100
server is up and running
named (pid 9051) is running...

and following in massage log :-

Oct 3 21:02:38 ns1 named[9051]: starting BIND 9.3.4-P1 -u named -D -t /var/named/chroot
Oct 3 21:02:38 ns1 named[9051]: found 1 CPU, using 1 worker thread
Oct 3 21:02:38 ns1 named[9051]: loading configuration from '/etc/named.conf'
Oct 3 21:02:38 ns1 named[9051]: listening on IPv6 interfaces, port 53
Oct 3 21:02:38 ns1 named[9051]: listening on IPv4 interface lo, 127.0.0.1#53
Oct 3 21:02:38 ns1 named[9051]: listening on IPv4 interface eth0, 192.168.0.10#53
Oct 3 21:02:38 ns1 named[9051]: listening on IPv4 interface eth0:0, 192.168.0.11#53
Oct 3 21:02:38 ns1 named[9051]: command channel listening on 127.0.0.1#953
Oct 3 21:02:38 ns1 named[9051]: could not open entropy source /dev/random: permission denied
Oct 3 21:02:38 ns1 named[9051]: using pre-chroot entropy source /dev/random
Oct 3 21:02:38 ns1 named[9051]: zone 0.in-addr.arpa/IN/internal: loaded serial 42
Oct 3 21:02:38 ns1 named[9051]: zone 0.0.127.in-addr.arpa/IN/internal: loaded serial 2008092501
Oct 3 21:02:38 ns1 named[9051]: zone 168.192.10.in-addr.arpa/IN/internal: loaded serial 2008100302
Oct 3 21:02:38 ns1 named[9051]: zone 168.192.100.in-addr.arpa/IN/internal: loaded serial 2008100302
Oct 3 21:02:38 ns1 named[9051]: zone 255.in-addr.arpa/IN/internal: loaded serial 42
Oct 3 21:02:38 ns1 named[9051]: zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN/internal: loaded serial 1997022700
Oct 3 21:02:38 ns1 named[9051]: zone maxtechs.in/IN/internal: loaded serial 2008100302
Oct 3 21:02:38 ns1 named[9051]: zone localdomain/IN/internal: loaded serial 42
Oct 3 21:02:38 ns1 named[9051]: zone localhost/IN/internal: loaded serial 2008092602
Oct 3 21:02:38 ns1 named[9051]: zone maxtechs2.net/IN/internal: loaded serial 2008100302
Oct 3 21:02:38 ns1 named[9051]: zone 21.81.159.in-addr.arpa/IN/external: loaded serial 2008100301
Oct 3 21:02:38 ns1 named[9051]: zone ns1.maxtechs.in/IN/external: loaded serial 2008100301
Oct 3 21:02:38 ns1 named[9051]: zone ns1.maxtechs2.net/IN/external: loaded serial 2008100301
Oct 3 21:02:38 ns1 named[9051]: dbus_mgr initialization failed. D-BUS service is disabled.
Oct 3 21:02:38 ns1 named[9051]: running
Oct 3 21:02:38 ns1 named[9051]: zone 0.0.127.in-addr.arpa/IN/internal: sending notifies (serial 2008092501)
Oct 3 21:02:38 ns1 named[9051]: zone ns1.maxtechs.in/IN/external: sending notifies (serial 2008100301)
Oct 3 21:02:38 ns1 named[9051]: zone ns1.maxtechs2.net/IN/external: sending notifies (serial 2008100301)
Oct 3 21:02:38 ns1 named[9051]: zone maxtechs.in/IN/internal: sending notifies (serial 2008100302)
Oct 3 21:02:38 ns1 named[9051]: zone maxtechs2.net/IN/internal: sending notifies (serial 2008100302)
Oct 3 21:02:38 ns1 named[9051]: zone 21.81.159.in-addr.arpa/IN/external: sending notifies (serial 2008100301)

Thank you
 
  


Reply

Tags
dnsserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
127 Can't execute command '/usr/sbin/sendmail kiganda Linux - Newbie 1 10-03-2007 06:50 AM
Sendmail : relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refuse macadam Linux - Software 0 09-23-2007 03:44 PM
How To Add Iso(suse 10.2 5cd) To Smart Channel? bigbighill Suse/Novell 1 02-15-2007 12:50 PM
DSN: Data format error & relay=[127.0.0.1] [127.0.0.1] calmbomb Linux - Software 0 11-07-2004 04:24 PM
make: Command not found, Error 127. I'm on Redhat Arild2 Linux - Newbie 3 10-30-2004 02:27 PM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration