LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-10-2009, 12:22 AM   #1
ah_gal06
LQ Newbie
 
Registered: Aug 2009
Posts: 5

Rep: Reputation: 0
Unhappy could not upload ftp files


hi! i manage to download files from the ftp server. but i can't upload my files to the ftp server. why is this happening?

i even chmod 777 to my ftp directory. this is my vsftpd.config file:

Quote:
anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=0777
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
#chown_uploads=YES
#chown_username=whoever
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
#idle_session_timeout=600
#nopriv_user=ftpsecure
#async_abor_enable=YES
#ascii_upload_enable=YES
#ascii_download_enable=YES
ftpd_banner=Welcome to FTP service!
#deny_email_enable=YES
#banned_email_file=/etc/vsftpd/banned_emails
#chroot_list_enable=YES
#chroot_list_file=/etc/vsftpd/chroot_list
#ls_recurse_enable=YES
listen=YES
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=NO
tcp_wrappers=YES
file_open_mode=0777
this thing keep appearing in my client computer when i tried to upload file (using local user and anonymous):
Quote:
ftp> put greetings
local: greetings remote: greetings
227 Entering Passive Mode (10,0,0,1,98,182)
553 Could not create file.
what is happening? please help! by the way, i m using redhat linux. thanks.

Last edited by ah_gal06; 08-10-2009 at 12:27 AM.
 
Old 08-10-2009, 03:33 AM   #2
ah_gal06
LQ Newbie
 
Registered: Aug 2009
Posts: 5

Original Poster
Rep: Reputation: 0
anyone pls help~~~ i will be grateful.
 
Old 08-10-2009, 03:45 AM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,551
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Grateful doesn't figure; helping someone else out does.

My guess (I don't know vsftpd) is that you don't have write permission on the ftp server when logged in as anonymous; you probably need to log in to the ftp server as a known user. anonymous does have read permission which is why you can get/download OK.

If you really want anonymous to have write permission then it may be configurable but it's wide-open security-wise; that may not matter in your particular situation.
 
Old 08-10-2009, 04:39 AM   #4
ah_gal06
LQ Newbie
 
Registered: Aug 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by catkin View Post
Grateful doesn't figure; helping someone else out does.

My guess (I don't know vsftpd) is that you don't have write permission on the ftp server when logged in as anonymous; you probably need to log in to the ftp server as a known user. anonymous does have read permission which is why you can get/download OK.

If you really want anonymous to have write permission then it may be configurable but it's wide-open security-wise; that may not matter in your particular situation.
the thing is normal users cannot upload as well. dunno why.. permission i set all to 777 already. seems so weird that it keep coming:
227 Entering Passive Mode (10,0,0,1,225,163)
553 Could not create file.
 
Old 08-10-2009, 05:17 AM   #5
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Maybe the log files reveal something. Seem to remember that there is something like vsftp.log and maybe something like transfer.log, somewhere in /var.

No access to a server at this stage.
 
Old 08-10-2009, 06:07 AM   #6
jeromeNP7
Member
 
Registered: Jun 2009
Posts: 101

Rep: Reputation: 19
You wrote that you have set everything to 777. What directory locations have been made writeable exactly? For logged in users the home directories should be accessed, for anonymous users it's rather /var/ftp/pub/ or some similar location.

In your config file you have commented out chown_uploads and chown_username - I would run a test with these enabled. Not being able to upload even for logged users indicates that the ftp server somehow doesn't deal correctly with chown issues.

Linux

Last edited by jeromeNP7; 09-04-2009 at 08:54 PM.
 
Old 08-17-2009, 09:04 AM   #7
ah_gal06
LQ Newbie
 
Registered: Aug 2009
Posts: 5

Original Poster
Rep: Reputation: 0
thanks everyone! i haf solved my problem... looks like i did not configure the firewall correctly in the setup.. that results in my failure in putting greetings to the ftp directory. thank u for your solutions though!
 
Old 08-17-2009, 09:44 AM   #8
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,551
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by ah_gal06 View Post
thanks everyone! i haf solved my problem... looks like i did not configure the firewall correctly in the setup.. that results in my failure in putting greetings to the ftp directory. thank u for your solutions though!
Thank you for posting the solution; it may help somebody. Please mark the thread solved via Thread Tools.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Server -- Hiding files after upload dnoy Linux - Newbie 3 05-05-2009 05:41 PM
C++: how to upload files using ftp matiasar Programming 3 02-25-2009 05:01 AM
Not able to upload files through FTP in Linux thiagarn Linux - Newbie 3 02-24-2008 09:53 PM
upload files on ftp zafar466 Programming 2 12-14-2006 07:16 AM
Upload files to newly setup server via FTP Madone_SL_5.5 Linux - Newbie 4 10-27-2006 06:59 PM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration