LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-05-2011, 01:54 PM   #1
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Rep: Reputation: 4
Could not make folder /home/theif519/.local/share/Trash ; Arch Linux


After removing GDM, XFCE4, and the crap-load of dependencies that came with it, something must have gone wrong. I can not place items nor delete items any more. How do I fix this problem of mine? I'm using KDE at the moment.

Code:
Could not make folder /home/theif519/.local/share/Trash
Deletion of files is necessary. I have installed libtrash hoping it'd work, but it didn't, I even did chmod 755 like it suggested I do. What do I do?
 
Old 06-05-2011, 02:21 PM   #2
saivnoba
Member
 
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
user/group/uid/gid anything changed? I've this habit of changing default uid from 500 to 1000 on my Fedora installs (and therefore sometimes get into trouble. :-)
 
Old 06-05-2011, 03:11 PM   #3
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by saivnoba View Post
user/group/uid/gid anything changed? I've this habit of changing default uid from 500 to 1000 on my Fedora installs (and therefore sometimes get into trouble. :-)
Code:
[theif519@theif519 Documents]$ /user/group/uid/gid
bash: /user/group/uid/gid: No such file or directory
[theif519@theif519 Documents]$ /usr/group/uid/gid
bash: /usr/group/uid/gid: No such file or directory
[theif519@theif519 Documents]$ nano /user/group/uid/gid
[theif519@theif519 Documents]$ Nothing...
 
Old 06-05-2011, 05:50 PM   #4
saivnoba
Member
 
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
I'm sorry that was not a command. I meant to ask if the ownership of your home directory or your username's (theif519) userid or groupid changed. Since you are inside your 'Documents' directory (outputs above) and you said you changed permission to 755, that does not seem to be problem. I've no clue.
 
Old 06-06-2011, 08:33 PM   #5
jake3988
Member
 
Registered: Mar 2005
Location: Ohio
Distribution: Freebsd and Ubuntu
Posts: 69

Rep: Reputation: 17
I'm assuming you lost even read permissions to those directories (in fact, it looks like you lose read permissions to ALL directories!).

Su into root and see if everything is ok. If it is, check permissions. If permissions are ok, then you probably accidentally changed your uid. In which case, you'll have to change it.

If permissions were not ok, give your username rw permissions again.
 
Old 06-06-2011, 10:35 PM   #6
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by jake3988 View Post
I'm assuming you lost even read permissions to those directories (in fact, it looks like you lose read permissions to ALL directories!).

Su into root and see if everything is ok. If it is, check permissions. If permissions are ok, then you probably accidentally changed your uid. In which case, you'll have to change it.

If permissions were not ok, give your username rw permissions again.
If this will help, I tried to upload a picture of what I see in the file browser, Konqueror.

I can't find my Trash directory

Can you give me a list of commands to use, or hint to me where I can find them?
 
Old 06-07-2011, 11:06 AM   #7
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,870

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
It appears that you were trying to create the "info" directory in your Trash sub-directory??
Do all the directories above "info" exist?
If so, what are the permissions? run ls -al on each directory and sub-directory to get them. Your owner should be the user "theif519"? and you should have write permissions.
I'm not really clear on what the problem is. Did you somehow remove these Trash related directories? or are you just not able to delete? or both??
 
Old 06-07-2011, 11:24 AM   #8
saivnoba
Member
 
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
hi,
launch 'konsole' program and post the output of the following commands?
Code:
cat /etc/passwd | grep theif519
Code:
ls -la /home
Code:
ls -la /home/theif519
Also, as suggested above (and also in your screenshot), check if all the directories do exits. i.e., share inside .local, Trash inside share,...

Just to remind, Linux is case sensitive. It may be 'trash' not 'Trash', or other way.
 
Old 06-07-2011, 03:35 PM   #9
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by saivnoba View Post
hi,
launch 'konsole' program and post the output of the following commands?
Code:
cat /etc/passwd | grep theif519
Code:
ls -la /home
Code:
ls -la /home/theif519
Also, as suggested above (and also in your screenshot), check if all the directories do exits. i.e., share inside .local, Trash inside share,...

Just to remind, Linux is case sensitive. It may be 'trash' not 'Trash', or other way.
Before I do, I have something to report. I deleted the Documents directory and it's default directory is ~/ now, but whenever I add the directory "Documents" it sets it as it's default. If I make something like "Docs" it doesn't set it to default. That's strange...

Code:
[theif519@theif519 ~]$ cat /etc/passwd | grep theif519
theif519:x:1000:100::/home/theif519:/bin/bash

[theif519@theif519 ~]$ ls -la /home/
total 28
drwxr-xr-x  4 root     root   4096 Jun  2 19:41 .
drwxr-xr-x 22 root     root   4096 Jun  5 12:59 ..
drwx------  2 root     root  16384 Jun  2 17:54 lost+found
drwx------ 31 theif519 users  4096 Jun  7 15:29 theif519

[theif519@theif519 ~]$ ls -la /home/theif519
total 288
drwx------ 31 theif519 users   4096 Jun  7 15:29 .
drwxr-xr-x  4 root     root    4096 Jun  2 19:41 ..
drwx------  3 theif519 users   4096 Jun  2 21:02 .adobe
-rw-r--r--  1 theif519 users    843 Jun  6 22:11 .alunn.conf
-rw-------  1 theif519 users   3652 Jun  7 15:31 .bash_history
-rw-r--r--  1 theif519 users     21 May  7 21:42 .bash_logout
-rw-r--r--  1 theif519 users     57 May  7 21:42 .bash_profile
-rw-r--r--  1 theif519 users    141 May  7 21:42 .bashrc
drwx------  7 root     root    4096 Jun  2 20:46 .cache
drwxr-xr-x  9 root     root    4096 Jun  2 20:38 .config
drwx------  3 theif519 users   4096 Jun  2 20:18 .dbus
drwxr-xr-x  2 theif519 users   4096 Jun  5 13:32 Desktop
drwxr-xr-x  3 theif519 users   4096 Jun  2 19:53 devel
-rw-------  1 theif519 users     26 Jun  5 12:58 .dmrc
drwxr-xr-x  2 theif519 users   4096 Jun  7 15:29 Doc
drwxr-xr-x  2 theif519 users   4096 Jun  2 20:48 Downloads
-rw-------  1 theif519 users     16 Jun  2 21:22 .esd_auth
drwxr-xr-x  2 theif519 users   4096 Jun  2 20:48 Games
drwx------  3 theif519 users   4096 Jun  7 15:23 .gconf
drwx------  2 theif519 users   4096 Jun  7 15:27 .gconfd
drwx------  6 theif519 users   4096 Jun  5 22:23 .gnome2
drwx------  2 theif519 users   4096 Jun  2 20:52 .gnome2_private
drwx------  3 theif519 users   4096 Jun  2 20:46 .gnupg
drwxr-xr-x  2 theif519 users   4096 Jun  3 17:47 .gstreamer-0.10
-rw-------  1 theif519 users      0 Jun  2 20:47 .gtk-bookmarks
dr-x------  2 theif519 users      0 Jun  7 15:28 .gvfs
-rw-------  1 theif519 users   5550 Jun  5 12:30 .ICEauthority
drwx------  4 theif519 users   4096 Jun  5 12:59 .kde4
drwxr-xr-x  3 root     root    4096 Jun  2 20:14 .local
drwx------  3 theif519 users   4096 Jun  2 21:02 .macromedia
drwx------  3 theif519 users   4096 Jun  2 20:18 .mission-control
drwx------  4 theif519 users   4096 Jun  2 20:52 .mozilla
-rw-r--r--  1 theif519 users   1186 Jun  5 22:04 .nvidia-settings-rc
drwxr-xr-x  3 theif519 users   4096 Jun  3 18:52 Packages
drwxr-xr-x  2 theif519 users   4096 Jun  6 22:31 Pictures
drwx------  3 theif519 users   4096 Jun  3 17:34 .pki
drwx------  2 theif519 users   4096 Jun  7 15:23 .pulse
-rw-------  1 theif519 users    256 Jun  2 20:18 .pulse-cookie
drwx------  6 theif519 users   4096 Jun  3 18:13 .purple
drwxr-xr-x  3 theif519 users   4096 Jun  2 21:30 .thumbnails
drwx------  4 theif519 users   4096 Jun  7 15:28 Trash
-rw-------  1 theif519 users    102 Jun  7 15:23 .Xauthority
drwx------  4 theif519 users   4096 Jun  3 18:13 .xchat2
-rw-------  1 theif519 users 121958 Jun  7 15:33 .xsession-errors
Also, I was very reluctant at first to use the cat /etc/passwd command though, until I saw that it didn't show my password.
 
Old 06-07-2011, 03:38 PM   #10
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Also, the "Trash" thing is the Trash sub-directory I tried adding after I found out I couldn't delete files. It didn't work, and I hope it didn't make it worse or cause any confusion.
 
Old 06-07-2011, 03:40 PM   #11
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Also, to clarify, "Could not make folder /home/theif519/.local/share/Trash" was the error that showed up
 
Old 06-07-2011, 03:56 PM   #12
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720Reputation: 720
Quote:
Originally Posted by theif519 View Post
Before I do, I have something to report. I deleted the Documents directory and it's default directory is ~/ now, but whenever I add the directory "Documents" it sets it as it's default. If I make something like "Docs" it doesn't set it to default. That's strange...
How is that strange? Computers have no clue that "Docs" is short for "Documents". They just check whether the characters match.
 
Old 06-07-2011, 03:58 PM   #13
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by MTK358 View Post
How is that strange? Computers have no clue that "Docs" is short for "Documents". They just check whether the characters match.
I thought that it was just setting the last directory I made as the default, not just Documents.
 
Old 06-07-2011, 08:29 PM   #14
saivnoba
Member
 
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
Quote:
Also, I was very reluctant at first to use the cat /etc/passwd command though, until I saw that it didn't show my password.
Sorry if I scared you. ;-)

Code:
[theif519@theif519 ~]$ ls -la /home/theif519
drwx------  7 root     root    4096 Jun  2 20:46 .cache
drwxr-xr-x  9 root     root    4096 Jun  2 20:38 .config
drwxr-xr-x  3 root     root    4096 Jun  2 20:14 .local
This is why you are not able to create folders in .local. Its owned by root (administrator) account. All sub-directories inside our home directory should be owned by us. Try (as root),
Code:
chown -R 1000:100 /home/theif519
Quote:
Originally Posted by theif519 View Post
Before I do, I have something to report. I deleted the Documents directory and it's default directory is ~/ now, but whenever I add the directory "Documents" it sets it as it's default. If I make something like "Docs" it doesn't set it to default. That's strange...
I'm confused with these many 'it'. Which program are you referring. Still not sure what your actual question was/is.
 
1 members found this post helpful.
Old 06-07-2011, 10:10 PM   #15
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by saivnoba View Post
Sorry if I scared you. ;-)

Code:
[theif519@theif519 ~]$ ls -la /home/theif519
drwx------  7 root     root    4096 Jun  2 20:46 .cache
drwxr-xr-x  9 root     root    4096 Jun  2 20:38 .config
drwxr-xr-x  3 root     root    4096 Jun  2 20:14 .local
This is why you are not able to create folders in .local. Its owned by root (administrator) account. All sub-directories inside our home directory should be owned by us. Try (as root),
Code:
chown -R 1000:100 /home/theif519
I'm confused with these many 'it'. Which program are you referring. Still not sure what your actual question was/is.
Thank you very much, and I'll assume that chown -R 1000:100 /home/theif519 gives me added permissions. Thank you for helping me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to make read only share folder with no printout access to clients on linux mohdsuboor23 Linux - Server 3 11-30-2010 02:48 AM
How to make a ARCH pkg from a local folder? linus72 Arch 6 07-01-2010 11:40 AM
delete the home folder and trash icon dissident_goodchild SUSE / openSUSE 11 11-20-2007 03:30 AM
how to make local repo on home folder/CD fireedo Fedora 2 04-19-2006 01:11 PM
gnome home folder and trash folder ambelos Linux - Software 2 02-24-2004 07:44 AM


All times are GMT -5. The time now is 07:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration