LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-09-2013, 04:44 PM   #1
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Rep: Reputation: Disabled
Correct resolution not offered with Nvidia X Server


I've just loaded Ubuntu 12.04 on a new(used) HTPC which I have hooked up to a Panasonic TV (this is to be used as a MythTV frontend). The TV's max resolution is 1024x768 but the option isn't available in X-server or the Ubuntu display controls. It is currently set at 1280x720 and subsequently the controls are not completely visible on screen making it very difficult to work with.

The output graphic controller is :NVIDIA Corporation C77 [GeForce 8200] (rev a2) (I don't know if you need any more information).

I tried the below (sorry I forgot how to get it into the little scrollable box) taken from the following website (http://ubuntuforums.org/showthread.p...ar#post8595940) but as you can see I came to a dead end.

Any help anyone could provide would be greatly appreciated.


chris@HTPC-1:~$ xrandr
Screen 0: minimum 8 x 8, current 1280 x 720, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1280x720+0+0 (normal left inverted right x axis y axis) 698mm x 392mm
1280x720 60.0*+ 59.9
1920x1080 60.0 59.9 24.0 30.0 30.0
1440x480 30.0
720x480 59.9 30.0
640x480 59.9
"1024x768_60.00" (0x280) 63.5MHz
h: width 1024 start 1072 end 1176 total 1328 skew 0 clock 47.8KHz
v: height 768 start 771 end 775 total 798 clock 59.9Hz
chris@HTPC-1:~$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsync
chris@HTPC-1:~$ xrandr --newmode "1024x768_60.00" 63.50 1024 1072 1176 1328 768 771 775 798 -hsync +vsyn
chris@HTPC-1:~$ xrandr --addmode HDMI-0 1024x768_60.00
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 25
Current serial number in output stream: 26
 
Old 03-09-2013, 06:32 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
what driver are you using
the open nouveau
the nvidia.run from the nvidia web site
or the kmod-nvidia in the Ubuntu repos
 
Old 03-09-2013, 08:21 PM   #3
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Here is the output of sudo cat /proc/driver/nvidia/version

NVRM version: NVIDIA UNIX x86_64 Kernel Module 304.64 Tue Oct 30 10:58:20 PDT 2012
GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)

I installed it today using the ubuntu additional drivers utility.
 
Old 03-10-2013, 12:52 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
In your /etc/X11/xorg.conf
add a mode line .Below it a section
Code:
Section "Screen"
	Identifier "Screen0"
	Device     "Device0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes    "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
current OS's do not need this file ,but , if it is there it will be used to override udev

you might also need to run "nvidia-xconfig" as root to first make the xorg.conf

or
the nvidia gui tool( as root "nvidia-config-display" ) and save the file it makes
 
Old 03-10-2013, 01:51 PM   #5
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Thanks John VV but no joy.
I did what you said but the only effect seems to be the computer now defaults to 640x480 on bootup.
The 1024x768 resolution still not offered.
 
Old 03-10-2013, 02:16 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
odd
you are using the hdmidi
and not the vga output
by chance is there a adapter on the end of the hdmidi cable ( the end that connects to the computer )

also one other possibility
when you installed the nvidia driver from the ubuntu repos
did you also remove the nouveau driver
see:
https://help.ubuntu.com/community/Bi...erHowto/Nvidia

As a long time "red hat" family user i had a hard time getting Ubuntu ( bt5r3) to remove the nouveau driver to use the nvidia 313.run driver

you might also need to run "grub2-update" to after adding the "blacklist nouveau" to the default /etc/default/grub file
then update the initramfs
Code:
 sudo update-initramfs -u

Last edited by John VV; 03-10-2013 at 02:21 PM.
 
Old 03-10-2013, 03:12 PM   #7
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Yikes, now I'm getting a blank screen.

So I went in to synaptic package manager and there was a nouveau driver called "X.Org X server -- Nouveau display driver" that was active. I deselected it and 'applied' and sure enough it was deselected. I then did a restart but still no 1024x768 option.

I then did the grub-2 update you suggested above followed by complete shutdown and restart. I get the initial text scrolling through the blank screen, followed by the coloured screen where it normally shows the "advancing dots" (no text or dots though), and then it just settles on a blank screen. I've tried hard boot two more times but same thing. Is this recoverable or do I have to do a new install?

Last edited by CSA60; 03-10-2013 at 03:14 PM.
 
Old 03-10-2013, 05:31 PM   #8
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
I came back to the computer after being out for a few hours and rebooted. I was going to see if I could do something from the bios- but it booted right up with no intervention at all. So we are able to continue if anyone is still interested in helping me with this.

Of interest, I'm not seeing the Grub anymore. I wonder if that is what is behind the blank screen.

In any case, I am still in the same place I was at the beginning; that is, no ability to alter the resolution to 1024x768. I am wondering if we should be concentrating on the error message in my original post. That is:

Code:
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 18 (RRAddOutputMode)
Serial number of failed request: 25
Current serial number in output stream: 26

As always, any help would be greatly appreciated.

Last edited by CSA60; 03-10-2013 at 05:35 PM.
 
Old 03-10-2013, 06:02 PM   #9
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
W.r.t. your question about the HDMI cable John VV (I assume that is what you meant when you referred to HDMIDI), I wasn't sure what you meant about an adapter at the end of the cable earlier so I put that aside. However, I was rooting around the connections on the computer to see if there was an alternative plugin to the TV and I noticed that the cable has these large (relatively) cylindrical structures on the cord (at both ends) I wondered if that was the thing to which you were referring. I tried a different cable without this feature but still no luck. So we can probably scratch that off the list.

Continuing thanks.
 
Old 03-10-2013, 06:06 PM   #10
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
getting nouveu off the set up needs the steps done in order

1)
sudo apt-get --purge remove xserver-xorg-video-nouveau
2)
add the blacklist to the /etc/default/grub file
3)
update the /boot/grub2/grub.cfg
4)
rebuild the boot image without nouveau
sudo update-initramfs -u
5)
install the nvidia driver from the restricted repos or the .run
 
Old 03-10-2013, 06:14 PM   #11
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
Thanks John VV but I have some quick questions.

1) Should I reinstall the nouveau driver and uninstall the NVIDIA drivers before I do all this?
2) How exactly does one add the blacklist to the /etc/default/grub file?
3) To update the /boot/grub2/grub.cfg is it: update-grub?

Thank you for your patience. Please remember this is the Newbie Forum.
 
Old 03-10-2013, 07:56 PM   #12
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
Quote:
1) Should I reinstall the nouveau driver and uninstall the NVIDIA drivers before I do all this?
no need , everything can be done from the text terminal if needed

Quote:
2) How exactly does one add the blacklist to the /etc/default/grub file?
slight oops on my part

sometimes the /etc/modeprobe.d/blacklist.conf with the nouveau listing in it is not read at boot
one way around that bug is to add a line in the "boot" line of the grub.conf
but that is auto remade from updates so you instead add a bit the the file that makes that one
look for this line in the text file "/etc/default/grub "
Code:
GRUB_CMDLINE_LINUX_DEFAULT="text splash nouveau.modeset=0 vga=791"
add the red bit " nouveau.modeset=0 "

there is a nice little and easy to use terminal text editor called " nano "
the keyboard shortcuts are displayed at the bottom
to save < control > + < o > to exit nano < control > + < x >

if not already installed
Code:
sudo apt-get install nano
Quote:
3)To update the /boot/grub2/grub.cfg is it: update-grub?
should be this for grub2
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
but if the old legacy grub1 ( grub 0.9) is used then it will be "update-grub"


the good news
this is a ONE TIME thing
You only need to do this for moving from the default nouveau to the nvidia
or
if you go back again



so right now x is not starting ? right ?
as in no gui
if so then on some paper ( paper and pencil are still needed )

add "nouveau.modeset=0" to the to /etc/default/grub

update the grub conf

make sure that the nvidia-current is installed
then
rebuild the boot image !!!
( yes that is in bold )
Code:
sudo update-initramfs -u
then reboot
 
Old 03-11-2013, 11:15 AM   #13
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
So I feel we are getting close. Just a few more things.

1) This is the text in my grub File.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

As you can see we are missing the "text splash vga-791" bit.

Should I put "nouveau.modeset=0" after the "quiet splash" or add the whole GRUB_CMDLINE_LINUX_DEFAULT="text splash nouveau.modeset=0 vga=791" line?

2) I looked in the boot file and the there is no grub2 folder just a grub folder. I can't see anything about grub 0.9 but I am guessing that I have the old legacy grub1. Do you agree?

3) W.r.t. which drivers are installed.

When I look into the Additional Drivers Utility it tells me that "NVIDIA accelerated graphic driver (post-released udates) (version current updates)" is installed and currently in use.

When I look in Synaptic Package Manager there seems to be three associate package currently selected.

i) Experimental NVIDIA binary Xorg driver, kernel module and VDPAU library (310.14-0ubunutu0.3)
ii) NVIDIA binary Xorg driver, kernel module and VDPAU library (173.14.36-0ubunutu0.0.1)
iii) NVIDIA binary Xorg driver, kernel module and VDPAU library (304.64-0ubunutu0.2)

So I'm pretty sure the the nvidia-current is installed.

In summary, once I am sure about where to add the edit I'm going to:
1) Add "nouveau.modeset=0" to the appropriate place in "/etc/default/grub "
2) sudo update-grub
3) sudo update-initramfs -u
4) Reboot

Is alright?
 
Old 03-11-2013, 02:00 PM   #14
John VV
Guru
 
Registered: Aug 2005
Posts: 12,808

Rep: Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705Reputation: 1705
Quote:

In summary, once I am sure about where to add the edit I'm going to:
1) Add "nouveau.modeset=0" to the appropriate place in "/etc/default/grub "
2) sudo update-grub
3) sudo update-initramfs -u
4) Reboot
sounds about right

i think earlier you missed the part about rebuilding the boot image to remove the nouveau driver from it
the old(er) image will be looking for the opensource driver and not the nvidia driver

that is very easy to do .Even for a long time linux user
i did that with fedora some years back
 
Old 03-11-2013, 03:10 PM   #15
CSA60
LQ Newbie
 
Registered: Jan 2013
Posts: 26

Original Poster
Rep: Reputation: Disabled
So it's okay for the "/etc/default/grub " to read.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=0"

rather than,

GRUB_CMDLINE_LINUX_DEFAULT="text splash nouveau.modeset=0 vga=791"?
 
  


Reply

Tags
nvidia drivers, screen resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Choices Offered for Partitioning - No Swap Offered? cbl48 Ubuntu 1 04-03-2010 06:41 PM
Index.php (on Server) offered for download rather than being interpreted? AndreasM Linux - Server 2 01-19-2010 03:58 AM
nvidia X server settings for LCD resolution will not stay set on native james2b Linux - Hardware 4 11-23-2008 05:35 AM
After correct nvidia install, I hit a bad resolution in configuration of KDE hgb Debian 4 07-12-2006 11:56 PM
Correct desktop resolution. Incorrect screensaver & lock resolution mybootorg Linux - General 6 05-03-2006 02:39 AM


All times are GMT -5. The time now is 05:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration