LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-18-2009, 12:23 AM   #1
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Rep: Reputation: 43
Correct graphics display?


I am currently running Slackware64, version 13. I am using KDE 4.2.4.

I installed the latest ATI drivers with instructions from this website.

http://wiki.cchtml.com/index.php/ATI...lackbuild_(ENG)

They compiled and installed. When I restarted X, everything was much faster than before(Opera would bog down on flash video, but after installing the latest ATI drivers, everything is very very smooth).

My problem is I can't set my graphics display to 1280x1024.

I've used ATICONFIG to set a graphics mode of 1280x1024, but when I use KDE's configure display, it doesn't give me an option for 1280x1024. 1280x1024 is the ONLY option in xorg.conf.

In my searching I've found this on the Ubuntu forum, which seems to be my issue. It doesn't matter what I set up in xorg.conf file, it ignores it.

http://ubuntuforums.org/showthread.php?t=327238

It references a file called "kcmrandrrc", which doesn't seem to exist on my system. I am not sure where KDE is getting the 320x200, 320x240, 400x300,...,640x480, 800x600 and 1024x768 graphics modes. It's not from xorg.conf.

I found this file...

"krandrrc"

Which contains the following...

[Screen_0]
OutputsUnified=false
UnifiedRect=0,0,0,0
UnifiedRotation=1

[Screen_0_Output_CRT1]
Active=true
Rect=0,0,1024,768
RefreshRate=60.0038414001465
Rotation=1

[Screen_0_Output_VGA-0]
Active=true
Rect=0,0,1280,1024
RefreshRate=60.0197410583496
Rotation=1

My xorg.conf is as follows...

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
Load "dri"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection



How can I get my desktop display to go to 1280x1024?
 
Old 11-18-2009, 03:47 AM   #2
ekamlesh
Member
 
Registered: Jun 2008
Distribution: Debian Wheezy
Posts: 43

Rep: Reputation: 17
In Slackware there is a command "xorgsetup". It did work for me. I don't know whether it is your 64bit system or not. If yes try it. To know your current resolution enter the follwing command in konsole
Quote:
xrandr -q
 
Old 11-18-2009, 05:26 AM   #3
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Ask for this thread to be moved to the Slackware forum. There's been quite a few questions & answers regarding resolution, ATI drivers, etc.
 
Old 11-18-2009, 07:42 PM   #4
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
How/who do I ask to have this thread moved?
 
Old 11-18-2009, 08:00 PM   #5
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
try xrandr -s 1280x1024 to set it in 1280x1024.
Quote:
How/who do I ask to have this thread moved?
click the report button and ask.
 
Old 11-20-2009, 10:48 AM   #6
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
I guess they don't think it needs to be moved.
 
Old 11-20-2009, 06:44 PM   #7
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
Quote:
Originally Posted by smeezekitty View Post
try xrandr -s 1280x1024 to set it in 1280x1024.
That gets me...

"Size 1280x1024 not found in available modes"

Where can I set the modes? I've been trying to research HAL and the new xorg. Setting things in xorg.conf doesn't do anything.
 
Old 11-21-2009, 09:56 PM   #8
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
Turns out, the EDID information from the monitor tops out at 1024x768 @ 85Hz. The monitor can do 1280x1024 at 60Hz, but that isn't contained in the EDID data in the monitor.

I have to set the 1280x1024 resolution in X manually, then I should be able to use it, but I need to figure out all the data required by X to do it.
 
Old 11-22-2009, 09:56 AM   #9
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
Well, after an entire evening of researching, I believe the problem is that the EDID does not find/display 1280x1024 so it doesn't detect that graphics mode. By default with the newest xorg configured monitors are ignored.

It doesn't seem to matter what graphics modes or changes I make to xorg.conf, nothing really changes, unless I delete it. When I delete it, it doesn't use the ATi proprietary driver and I can get 1280x1024 again. Once I configure it to use fgrlx, I can't get it to manually change anything.

It seems to be a common problem along all of the newest distros using the latest xorg. Most people either give up and live with it, don't use the driver or use the radeonhd driver.

Going through the xorg log file, it does seem like it picks up the 1280x1024, but why it doesn't display it as an option, I don't know.
 
Old 11-23-2009, 07:58 AM   #10
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
Still playing around with it. I could change the display settings dynamically with XRANDR and I was able to add 1280x1024 as a graphics mode, but XRANDR still won't change the graphics mode to 1280x1024 because it says the largest I can go is 1024x1024.

fgrlx detects 1280x1024 at 65Hz, although windows does it at 60Hz and xrandr doesn't recognize it because of the EDID.

Still working on trying to figure it out.
 
Old 11-23-2009, 03:02 PM   #11
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
I've heard a lot of people have had issues with 'fglrx', the proprietary ATI drivers.

I believe your card is supported by the open-source 'radeon' driver that comes with slackware. Have you tried that before using the proprietary ones ?
 
Old 11-23-2009, 03:40 PM   #12
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
I don't know if this works with fglrx, but with the open source drivers you can force a resolution by adding a modeline and using the PreferredMode option. It *should* work with any driver that supports xrandr 1.2, but fglrx is a bit iffy when it comes to xrandr 1.2 :-)

For example, adding this to the Monitor section should force the driver to use 1280x1024@60:

Code:
        Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
        Option  "PreferredMode" "1280x1024_60.00"
That modeline was generated with cvt. You can obviously change it as needed.

Again, I can't guarantee this will work, but it might be worth a shot.

As for fglrx vs. radeon... The card is supported by 2D only with the radeon driver in Slackware 13, so if the OP needs 3D acceleration, fglrx is the way to go (unless the OP is willing to start compiling development code).

Adam
 
Old 11-23-2009, 03:59 PM   #13
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Quote:
Originally Posted by adamk75 View Post
As for fglrx vs. radeon... The card is supported by 2D only with the radeon driver in Slackware 13, so if the OP needs 3D acceleration, fglrx is the way to go (unless the OP is willing to start compiling development code).

Adam
yeah, that's true, it's a good question.
 
Old 12-02-2009, 02:37 PM   #14
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
Quote:
Originally Posted by H_TeXMeX_H View Post
I've heard a lot of people have had issues with 'fglrx', the proprietary ATI drivers.

I believe your card is supported by the open-source 'radeon' driver that comes with slackware. Have you tried that before using the proprietary ones ?
No, I did not try that. How do I change to that particular driver to at least try it out.
 
Old 12-02-2009, 02:41 PM   #15
JamesGT
Member
 
Registered: Oct 2009
Location: St. Louis, MO, USA
Distribution: Slackware64 14.0
Posts: 225

Original Poster
Rep: Reputation: 43
Quote:
Originally Posted by adamk75 View Post
I don't know if this works with fglrx, but with the open source drivers you can force a resolution by adding a modeline and using the PreferredMode option. It *should* work with any driver that supports xrandr 1.2, but fglrx is a bit iffy when it comes to xrandr 1.2 :-)

For example, adding this to the Monitor section should force the driver to use 1280x1024@60:

Code:
        Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
        Option  "PreferredMode" "1280x1024_60.00"
That modeline was generated with cvt. You can obviously change it as needed.

Again, I can't guarantee this will work, but it might be worth a shot.

As for fglrx vs. radeon... The card is supported by 2D only with the radeon driver in Slackware 13, so if the OP needs 3D acceleration, fglrx is the way to go (unless the OP is willing to start compiling development code).

Adam
Thanks Adamn, I've been down that road and it doesn't work. It totally ignores any settings I put in the Monitor section. My slackware comes with xrandr 1.3, but I don't know if that makes a difference.

I was able to use xrandr to add 1280x1024 but when I try to select that graphics mode it says I can't go any higher than 1024x1024.

fgrlx does see 1280x1024.

I don't NEED 3D, but it would be nice to have at some point.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't display graphics, display manager may not be setup dsollen Linux - Software 5 06-17-2009 03:13 PM
[SOLVED] How do I correct faulty graphics config Woozle Ubuntu 4 11-14-2008 11:00 AM
correct DISPLAY setting mathfeel Linux - Software 2 05-26-2006 03:15 PM
Correct X11 display??? s1lv1a9999 Linux - Software 2 05-03-2004 02:39 AM
PC Display Not Correct Mal495 Linux - Newbie 1 10-30-2003 11:08 PM


All times are GMT -5. The time now is 11:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration