LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2011, 01:34 AM   #1
canceriandebu
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Rep: Reputation: Disabled
Copying folder from network in RHEL


The problem is i have to copy folders from network into the RHEL server. When i am copying i can copy the folders and documents which do not have a sub folder. But the folders with subfolders is not getting copied. How should i do it?
 
Old 07-04-2011, 01:49 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Hi,

How ARE you doing it?
(s)cp -pr should work ...
 
Old 07-04-2011, 02:01 AM   #3
canceriandebu
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hello Tinkster

Well through the GUI where it says Network server i go through that. Then i connect to the windows server from where i have to copy the data. I do a right click and choose the option of copy and paste it in my home folder of RHEL. I do not know what command line input if that can solve the problem.
 
Old 07-04-2011, 02:35 AM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Now there's an interesting detail: have you checked the permissions
on the sub-directories on the windows share? If you're using a GUI
tool I can't see any good reason for the copy not to take sub-dirs
along ...

Alternatively you could try on the command-line; at least that would
more likely give you a useful messages as to why things aren't quite
working the way you'd like them to.

Try opening a terminal; enter the command "mount" by itself; do you
see your windows share in the output?



Cheers,
Tink
 
Old 07-04-2011, 02:49 AM   #5
canceriandebu
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hello Tink,

Thanks for such a quick reply.
Well i cannot see the windows share with the "mount" command. Also if there were permissions problem why would the folders without subfolders get copied and folders with subfolders doesn't. I doubt it is the permission problem because i am using SUSE machines where i can do it easily. Maybe i am missing something somewhere. I do not know. Should i mount the full folder editing the samba file in it? I know where and what to edit in case of openSUSE machine but have no idea regarding RHEL.

Regards,
Debu
 
Old 07-04-2011, 03:52 AM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,107

Rep: Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478
guessing but
is this using the NFS ?
if so is the recursive files option set ?

the default is not to.If i go into one of mine i need to wait for the subfolders to be read
 
Old 07-12-2011, 11:29 PM   #7
canceriandebu
LQ Newbie
 
Registered: Jul 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hello John,

Sorry about such delay in replying. Well it is using network file sharing. I don't know about recursive files option setting? where should i look into for it?

Regards,

Debu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
There was an error copying the file into smb:// PcName/Folder/Folder morbid_bean Linux - Networking 3 01-19-2017 04:44 AM
[SOLVED] Copying the files inside a folder, without copying the folder (hopefully easy) tibberous Linux - Software 3 12-23-2010 01:50 AM
Copying latest 10 files from one folder to another kingjaffi Linux - Newbie 5 11-20-2010 01:09 AM
Copying folder content and not folder NevadaSam Linux - Newbie 4 11-26-2008 07:58 AM
error copying nfs folder jkeertir Linux - Hardware 3 03-27-2008 11:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration