LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-22-2006, 10:17 PM   #1
Kaname
LQ Newbie
 
Registered: May 2006
Posts: 15

Rep: Reputation: 0
Question Copy too slow (system slow too)


Hi everybody.

My Stystem:
AMD Athlon 64 3200
1Ghz RAM
Slackware 64bits (Slamd64)
Kernel: 2.6.17-rc5 (I had the same problem with kernel 2.6.16)

I have 2 HDD:
1. 80GB IDE Maxtor 7200rpm (as primary master)
2. 250GB IDE Maxtor 7200rpm (as secundary master)
(same IDE cable)

My partitions are:

hda1 NTFS 10487.24
hda2 Linux ext3 10487.24
hda3 Linux ext3 40493.06

hdb1 Linux ext3 62512.13
hdb2 NTFS 62512.13
hdb3 Linux ext3 62512.13
hdb4 Linux ext3 62520.36

running:
$ hdparm -Tt /dev/hda

/dev/hda:
Timing cached reads: 1212 MB in 2.00 seconds = 605.93 MB/sec
Timing buffered disk reads: 6 MB in 3.21 seconds = 1.87 MB/sec

$ hdparm -Tt /dev/hdb

/dev/hdb:
Timing cached reads: 1512 MB in 2.02 seconds = 748.62 MB/sec
Timing buffered disk reads: 6 MB in 3.43 seconds = 1.75 MB/sec

The partition hda2 was formated by the system when I installed Linux at first time. The other Linux partitions, I formated like this:

mkfs.ext3 -m 0 /dev/hda3

mkfs.ext3 -m 0 -T largefiles4 /dev/hdb1
mkfs.ext3 -m 0 -T largefiles4 /dev/hdb3
mkfs.ext3 -m 0 -T largefiles4 /dev/hdb4
(because I use that space mainly for videos and movies).

I also tried without the "-m 0" but I had the same performance but 5% less space.

WHEN COPYING... (with cp command)
small files, I have no problem.
60MB file FROM:
hda3 to hda3: 1 min 10 sec (877 KB/s)
hda3 to hda2: 30 sec (2MB /s)
hda2 to hdb1: 35 sec (1.7MB /s)
hdb1 to hdb4: 40 sec (1.5MB /s)
hdb4 to hdb3: 35 sec (2MB /s)
hdb4 to hdb4: 40 sec (1.5MB /s)
hdb4 to hda2: 35 sec (2MB /s)
hda2 to hda2: 30 sec (2MB /s)

Sometimes, when moving large files I get up to 600 KB/s. (using kde file manager)

I don't know if these speeds are correct, but in windows copying largefiles, from one linux partition to other linux partition (using ext3 library on windows) it spend less time.

I don't care too much about the speed or time, but the main problem, I think, is that all my system slows down. For example, CPU usage during copy process is about from 30% to 90%, but I can not use normally my computer, like if I was executing a huge process (even if I use the "nice" command).

What is wrong?

Thank you.
 
Old 06-22-2006, 11:23 PM   #2
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
Quote:
[10:06:40]root@prozac:~# hdparm -tT /dev/hda1
/dev/hda1:
Timing cached reads: 1216 MB in 2.00 seconds = 608.16 MB/sec
Timing buffered disk reads: 92 MB in 3.06 seconds = 30.02 MB/sec
your timing buffer disk reads are low. what does hdparm /dev/hda? shows?
you man not have dma enabled check it out.mine shows like this
Quote:
[10:07:05]root@prozac:~# hdparm /dev/hda1

/dev/hda1:
multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 65535/16/63, sectors = 208782, start = 63
hdparm --help will help you.
 
Old 06-23-2006, 06:08 AM   #3
Kaname
LQ Newbie
 
Registered: May 2006
Posts: 15

Original Poster
Rep: Reputation: 0
Thank you.

Yes, my using_dma was off... (but something strange is happening)

I enable that kernel option (because it was disabled)
Then, I enabled:

hdparm -d1 -u1 -X udma5 /dev/hda (same for /dev/hdb)

/dev/hda:
setting unmaskirq to 1 (on)
setting using_dma to 1 (on)
setting xfermode to 69 (UltraDMA mode5)
unmaskirq = 1 (on)
using_dma = 1 (on)

Now I get:
hdparm -tT /dev/hda

/dev/hda:
Timing cached reads: 1884 MB in 2.00 seconds = 940.45 MB/sec
Timing buffered disk reads: 86 MB in 3.07 seconds = 28.05 MB/sec
hdparm -tT /dev/hdb

/dev/hdb:
Timing cached reads: 1932 MB in 2.00 seconds = 964.96 MB/sec
Timing buffered disk reads: 78 MB in 3.02 seconds = 25.83 MB/sec

When copying the same 60MB file, It spend 40 secs (about the same as before)
but the strange thing is that after copying from hda3 to hda3, I get this:

hdparm -tT /dev/hda

/dev/hda:
Timing cached reads: 1964 MB in 2.00 seconds = 980.41 MB/sec
Timing buffered disk reads: 6 MB in 3.92 seconds = 1.53 MB/sec

And when running "hdparm -d /dev/hda"

/dev/hda:
using_dma = 0 (off)

So, why dma is turning off by itself? (dmesg is not displaying anything)

FIXED: I used -X udma2 instead of udma5 (even though my hdd support it).

by the way, in slackware, where I configure hdparm to be initialized automatically?
 
Old 06-23-2006, 06:11 AM   #4
prozac
Member
 
Registered: Oct 2005
Location: Australia
Distribution: slackware 12.1
Posts: 753

Rep: Reputation: 32
how abt setting up the keep_settings option too?
 
Old 06-26-2006, 03:15 AM   #5
Kaname
LQ Newbie
 
Registered: May 2006
Posts: 15

Original Poster
Rep: Reputation: 0
Thank you.. I just added -k1 (to keep settings).

by the way, for those people reaching this comment, this link can help you too:

http://www.linuxquestions.org/questi...=75181&page=22
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow performance!!! System using a lot of Physical Memory SLOW HELP! badgerbox76 Linux - Newbie 31 07-19-2007 10:23 AM
Suse 9.2 & SATA - Slow, Slow, Slow jess1975 SUSE / openSUSE 6 01-28-2007 12:17 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 01:39 PM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 01:55 PM
Slow, slow system guyd Linux - General 3 09-01-2003 12:39 PM


All times are GMT -5. The time now is 05:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration