LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-13-2006, 07:56 PM   #1
Shaw-n
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Rep: Reputation: 0
Copied xorg.conf file, now X won't load


Hello. Total newbie here.
I wanted to remap my mouse buttons so the side button would act as the middle button. I looked at some sites, told me to edit xorg.conf. So I first copied the file somwhere else. Then looked at the original via a text editor. Gave up, did not edit anything and shut down. Next to I turn on computer X won't load. Says,
Incomplete data in xorg.conf. No Input device driver line.
Sure enough there wasn't. But there was none originaly. I put in a line,
Driver "mouse"
And tried starting X. Then it tells me
(EE) no drivers available
I don't understand why X would load before, but now it won't.
 
Old 04-14-2006, 02:01 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Well you just need to compare the new xorg.conf with the older one and see what changes you have made or post the changes you have made in the xorg.conf here so that we can help you out

regards
 
Old 04-14-2006, 05:39 AM   #3
ultramancool
Member
 
Registered: Jul 2004
Location: Hell
Distribution: Gentoo 2005.1 r1
Posts: 92

Rep: Reputation: 15
To compare the two files:
diff oldconf newconf
 
Old 04-14-2006, 07:53 PM   #4
Shaw-n
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Here is my xorg.conf file:
Code:
# /.../
# SaX generated X11 config file
# Created on: 2006-04-13T14:11:17+1000.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/X11R6/lib/X11/fonts/local/"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
  FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
  FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
  RgbPath      "/usr/X11R6/lib/X11/rgb"
  InputDevices "/dev/ttyS0"
  InputDevices "/dev/ttyS1"
  InputDevices "/dev/ttyS2"
  InputDevices "/dev/ttyS3"
  InputDevices "/dev/ttyS4"
  InputDevices "/dev/ttyS5"
  InputDevices "/dev/ttyS6"
  InputDevices "/dev/ttyS7"
  InputDevices "/dev/ttyS8"
  InputDevices "/dev/psaux"
  InputDevices "/dev/logibm"
  InputDevices "/dev/sunmouse"
  InputDevices "/dev/atibm"
  InputDevices "/dev/amigamouse"
  InputDevices "/dev/atarimouse"
  InputDevices "/dev/inportbm"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/mouse"
  InputDevices "/dev/usbmouse"
  InputDevices "/dev/adbmouse"
  InputDevices "/dev/input/mice"
  InputDevices "/dev/input/event0"
  InputDevices "/dev/pointer0"
  InputDevices "/dev/pointer1"
  InputDevices "/dev/pointer2"
  InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
EndSection

Section "Module"
  Load         "glx"
  Load         "extmod"
  Load         "freetype"
  Load         "dbe"
  Load         "type1"
  Load         "dri"
EndSection


Section "InputDevice"
  Identifier   "Mouse[1]"
  Driver       "mouse" 
  Option       "ButtonNumber" "5"
  Option       "Device" "/dev/mouse"
  Option       "Protocol" "ExplorerPS/2"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  HorizSync    31.5-80.5
  Identifier   "Monitor0"
  Option       "DPMS"
  VertRefresh  20-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x800" 80.58 1280 1344 1480 1680 800 801 804 827
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      24
    Modes      "1280x800" 
  EndSubSection
  Device       "ATI"
  Identifier   "Screen0"
  Monitor      "Monitor0"
EndSection


Section "Device"
  BoardName    "Unknown"
  Driver       "vga"
  Identifier   "Standard"
  Screen       0
  VendorName   "Unknown"
EndSection

Section "Device"
  Driver       "fglrx"
  Identifier   "ATI"
  Option       "no_accel" "no"
  Option       "DesktopSetup" "0x00000000"
  Option       "no_dri" "no"
  Option       "MonitorLayout" "AUTO"
  Option       "mtrr" "off"
  Screen       0
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
I believe the original didn't have the
Driver "mouse"
line. But even with it, when I startx it says
Code:
(EE) no drivers available

Fatal server error:
no screens found
If I run xorgconfig, it still won't startx.
Any suggestions?
 
Old 04-16-2006, 11:59 PM   #5
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
Well Is this your original xorg.conf?

doesn't look to me

It does not have any other reference to Screen0 as I have it in my xorf.conf (I have 2 references to screen0)


regards
 
Old 04-17-2006, 09:20 AM   #6
Dtsazza
Member
 
Registered: Oct 2005
Location: Oxford, UK
Distribution: Debian Etch (w/ dual-boot XP for gaming)
Posts: 282

Rep: Reputation: 30
Right, let's think. Clearly you have changed something about your config file, else things wouldn't have changed. Perhaps you made some adjustment with the editor without realising (can quite easily happen under vi, if you're not used to it). Let's take a look at when the file was modified:
Code:
ls -l /etc/X11/xorg.conf | cut -d' ' -f7
(change the file location if it's somewhere else in your distro).

My guess is that you've managed to mangle the ServerLayout section. This section normally refers to screens and mice, and yours doesn't, so it could conceivably throw the errors you're encountering. Adding some relevant lines in there may well fix your problem.

But wait, let's backtrack a bit. You say you backed the file up before editing it (a sensible precaution). Have you tried restoring the backup? Your posts so far suggest you haven't, and that should be the first thing to try (it's why we take backups, after all!). I'd advise you to keep your current "broken" xorg.conf in case things don't immediately start working and we have to dig around for more clues. Something like
Code:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
mv /wherever/you/backed/up/xorg.conf /etc/X11/xorg.conf
should restore your backup while preserving the current file.
 
Old 04-19-2006, 12:54 AM   #7
Shaw-n
LQ Newbie
 
Registered: Apr 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Ok the problem is solved. It turns out that on SuSE, which I have, there is a program SAX which writes its own xorg file and sets up X. All I had to do was to start YAST. But then I had to spend hours trying to get the resolution correct.
Anyway I'm happy to say it works now.
Thanks heaps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Will my XF86Config file work in place of xorg.conf file BillyGalbreath Linux - General 2 03-08-2006 06:18 AM
Problem with Xorg.conf + ATI Drivers + X Won't Load TaaDow Linux - Hardware 1 01-24-2006 07:11 AM
keep loosing the xorg.conf file Veteq Linux - Software 2 11-28-2005 09:42 AM
xorg.conf file is stubborn! msmales Linux - Software 1 01-03-2005 04:05 AM
I made an error in xorg.conf - now I can't load x server Joe Belmaati Linux - Newbie 3 11-13-2004 06:54 PM


All times are GMT -5. The time now is 03:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration