LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-04-2008, 11:54 PM   #1
Daravon
Member
 
Registered: Mar 2006
Posts: 166

Rep: Reputation: 15
Console window very small in basic Xorg install--does not fill screen


I'm building a digital picture frame.

I did a commandline install of Ubuntu on an old laptop and then got xorg over apt. When I startx (I have no window manager, and no mouse), most of the screen is grey, with the active window taking up the top-left quarter of the screen. I'm sure I need to specify the resolution in the xorg.conf but i'm not sure how. This isn't a great problem, just annoying to waste the screen.

I'm also having trouble getting rid of the mouse cursor, which sits in the middle of the screen because i have no mouse...I tried the method of blank bitmap here, doing it in tty1 while X was running on tty7 but i get
Code:
chaz@frame: xsetroot -cursor blankbmp blankbmp
xsetroot: unable to open window ''
.
I thought maybe it was from entering the command on a different tty than the one that was running X but when I put the command in my Xsession, right next to other commands that work, X fails to launch.

Maybe to fix both problems I should go with a window manager? I don't want to give up much disk space.

Last edited by Daravon; 09-04-2008 at 11:55 PM.
 
Old 09-05-2008, 02:30 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
It usually works to find someone who's done this before...

for your resolutions - compare you xorg.conf with another that works.
for your mouse pointer - there is an enlightening discussion on this here.
 
Old 09-05-2008, 02:55 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Rep: Reputation: Disabled
Does your xorg.conf have a mouse section? If so, try to comment it out. If that doesn't help search LQ for kiosk and mouse, I remember seeing a discussion of that problem for a kiosk set up.

<edit> ooops, I didn't see Simon's post. Please ignore this one </edit>

Last edited by JZL240I-U; 09-05-2008 at 02:58 AM.
 
Old 09-05-2008, 08:43 AM   #4
Daravon
Member
 
Registered: Mar 2006
Posts: 166

Original Poster
Rep: Reputation: 15
Quote:
It usually works to find someone who's done this before...
That has almost nothing to do with me because he has internet access and I don't, he has a window manager and I don't, and he has more than 1GB of hard disk space and I don't. He does say, however, that he uses feh for 'fullscreen and no-mouse-pointer goodness'. I use feh and fullscreen, but the mouse pointer remains. It must be because I don't have a window manager.

Quote:
Does your xorg.conf have a mouse section? If so, try to comment it out.
I tried. Heck I deleted it completely.


EDIT: After rtfmp again, it seems feh has a --hide-pointer option. It works here at work, but I'll have to see if it works on the laptop, since it doesn't have a window manager.

Last edited by Daravon; 09-05-2008 at 08:47 AM.
 
Old 09-05-2008, 04:04 PM   #5
Reasa
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 53

Rep: Reputation: 16
there is a window manager (or de? forgot) which is especially for those who prefer keyboard only, or just dont have a mouse. its called Ratpoison - rat is the mouse, so its like mousepoison =)
 
Old 09-05-2008, 09:01 PM   #6
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Originally Posted by Daravon View Post
That has almost nothing to do with me because he has internet access and I don't, he has a window manager and I don't, and he has more than 1GB of hard disk space and I don't.
That's sort of my point. When you depart substantially from the trodden path, expect rocks and weeds.
Quote:
He does say, however, that he uses feh for 'fullscreen and no-mouse-pointer goodness'. I use feh and fullscreen, but the mouse pointer remains. It must be because I don't have a window manager.
A WM would help - however - the knowledge that someone else has had success with feh tells you to look again. Which you did:
Quote:
EDIT: After rtfmp again, it seems feh has a --hide-pointer option. It works here at work, but I'll have to see if it works on the laptop, since it doesn't have a window manager.
Note for next time - I could have just told you to use the --hide-pointer option had you been specific about what you had tried. If you ask a general question you will only get a general answer which will not obviously point out your exact solution.
 
Old 09-05-2008, 09:16 PM   #7
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,036

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
Quote:
Originally Posted by Daravon View Post
I'm building a digital picture frame.

I did a commandline install of Ubuntu on an old laptop and then got xorg over apt. When I startx (I have no window manager, and no mouse), most of the screen is grey, with the active window taking up the top-left quarter of the screen. I'm sure I need to specify the resolution in the xorg.conf but i'm not sure how. This isn't a great problem, just annoying to waste the screen.
Well, technically it's not a window, since you have no WM. If you really don't want a WM, you can use ~/.Xdefaults to configure your terminal application. Maybe you can configure the initial size (80x24 by default, surely).

But, just for the sake of usability, I advise to you use a WM. Ratpoison has been suggested, and it will take just a few k's on your disk. Dwm is another good one for those worried about every kb. Neither of these will need a mouse to work.

Quote:
I'm also having trouble getting rid of the mouse cursor, which sits in the middle of the screen because i have no mouse...I tried the method of blank bitmap
Try unclutter if nothing else works:
http://www.ibiblio.org/pub/X11/contr...utter-8.README
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My native linux games keep going from full screen, to a small window and freezes symon1980 Linux - Games 13 01-07-2008 11:43 AM
How to get tvtime to fill my screen biscristi Linux - Software 1 03-06-2005 08:27 AM
Dell 510M Letterbox / Small screen in X and Console before fb activates dezza Linux - Laptop and Netbook 3 11-09-2004 03:20 PM
Bootloaders fill the screen with garbage dharms Linux - General 4 03-15-2004 04:43 PM
A small rectangular window blocking screen gokib Linux - Newbie 2 07-23-2002 09:54 PM


All times are GMT -5. The time now is 03:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration