LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-04-2012, 10:44 PM   #1
pedenski
Member
 
Registered: Feb 2012
Posts: 33

Rep: Reputation: Disabled
Consistent Network Device Naming in Fedora


Fedora does not use the conventional ethX naming anymore, theyre using this thing called 'ConsistentNetworkDeviceNaming'

when i use #ifconfig
its shows lo, p3p1 where (p3p1 p<slot>p<port>

according to the wiki, if i want to disable the 'CNDN' and go back to the old naming convention 'ethX' i should edit the linux kernel cmd line to "biosdevname=0" which i assume is /etc/grub.config

my question is, where do i find the linux kernel?

im using fedora16 and cant find it anywehere
/etc/
 
Old 03-04-2012, 11:52 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
you do not edit " the kernel"

you add the option to the boot line

example - for SL6 and not fedora
but the same principle
menu.lis
Code:
kernel /vmlinuz-2.6.32-220.4.1.el6.x86_64 ro root=UUID=c98b635c-59e8-4419-ad0c-623260ef5a90 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=128M rhgb quiet
you would add it to the end of the line
Code:
kernel /vmlinuz-2.6.32-220.4.1.el6.x86_64 ro root=UUID=c98b635c-59e8-4419-ad0c-623260ef5a90 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=128M rhgb quiet biosdevname=0
and t is NOT "/etc/grub.config"
it is
/boot/grub/grub.conf
-- or --
/boot/grub/menu.lis

Last edited by John VV; 03-04-2012 at 11:54 PM.
 
Old 03-05-2012, 01:25 AM   #3
pedenski
Member
 
Registered: Feb 2012
Posts: 33

Original Poster
Rep: Reputation: Disabled
turns out that fedora's boot grup is located at

/boot/grub2/grub.cfg

when i open it in vi, its just blank
im really not sure if this is the right place to append 'biosdevname=0'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 15 naming network devices lealsaballos Linux - Networking 1 06-23-2011 09:49 PM
LXer: Kernel Log: Consistent names for network interfaces LXer Syndicated Linux News 0 02-01-2011 11:01 PM
Fedora 15 - Changing Eth Device Naming Scheme! zer0signal General 10 01-26-2011 07:46 PM
LXer: Breaking a few eggs: Fedora 15 changes network device naming LXer Syndicated Linux News 0 01-25-2011 12:40 PM
device naming didi156 Linux - General 3 07-14-2006 07:37 AM


All times are GMT -5. The time now is 08:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration