LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-28-2001, 04:11 PM   #1
jd300
Member
 
Registered: Nov 2001
Posts: 71

Rep: Reputation: 15
Connecting with Redhat 7.2


I have just switched over to Redhat 7.2 and cannot connect to any sites on the net. I appear to be connected but when I try to surf I get an error message that says 'can't find or locate redhat or whatever site I am trying to get to.
 
Old 12-28-2001, 04:58 PM   #2
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Can you ping any sites by their IP? Try pinging 209.133.27.161. If you get a response, you've probably got DNS issues. Recheck the entries for your pri. and sec. DNS servers in your /etc/resolv.conf file (for that matter, make sure you can ping them as well).

Also- how are you connecting?

Last edited by DMR; 12-28-2001 at 05:00 PM.
 
Old 12-28-2001, 07:11 PM   #3
transfix
LQ Newbie
 
Registered: Dec 2001
Posts: 3

Rep: Reputation: 0
Another thing to check...
Check your firewall settings. I screwed up when I first installed Red Hat 7.2 and did not allow applications persmission to use the internet connection.
 
Old 12-28-2001, 11:10 PM   #4
jd300
Member
 
Registered: Nov 2001
Posts: 71

Original Poster
Rep: Reputation: 15
No Access

I have no luck at all. I either get an error message saying the browsers (netscape, Mozilla, Konquerer cannot be found or that the host can't be located. I have checked the DNS numbers and they are the same as I used without problem on Mandrake 8.1.
 
Old 12-29-2001, 07:28 AM   #5
Wazza
Member
 
Registered: Dec 2000
Location: South Australia
Distribution: RedHat 7.2
Posts: 55

Rep: Reputation: 15
Hi.
Transfix mentioned the firewall settings.
Dump yourself at a terminal and (as root) enter
/usr/sbin/ntsysv
Scroll down until you see ipchains and iptables, uncheck them so they are not started next boot.
Re-boot, then try the net.
You can re-enable them after, but it proves a point.

/etc/rc.d/init.d/iptables stop
will stop iptables on the fly if you dont want to re-boot.
Or ipchains, if thats the one running.
Good luck

Wazza
 
Old 12-29-2001, 04:12 PM   #6
jd300
Member
 
Registered: Nov 2001
Posts: 71

Original Poster
Rep: Reputation: 15
Angry Thanks...But

Thanks for the info, unfortunately my RH has crashed and I cannot boot back in as of yet. I submitted a new post regarding the 'crash' . As soon as I can get back in I will give your info a try...Thanks for the help.
 
Old 01-01-2002, 02:04 PM   #7
jd300
Member
 
Registered: Nov 2001
Posts: 71

Original Poster
Rep: Reputation: 15
Angry No success

After 5 days and no help from Redhat Support, I had to completely remove Linux from my system and reinstall it. I still cannot connect to the net though. I followed the procedure as suggested by Wassa but that to did not work. I still get the same message: unabe to locate or find host.realnames.com
Is Redhat really this bad? I think I should take it back to the store and plead for my money back. Windows was never this bad.
 
Old 01-02-2002, 03:29 AM   #8
Wazza
Member
 
Registered: Dec 2000
Location: South Australia
Distribution: RedHat 7.2
Posts: 55

Rep: Reputation: 15
Naaaaaaaaaaaaaaaaa, dont give up mate!

You will feel great when you get it going.
Can I ask what your using to dial up with?
Also, did you check the dns settings already mentioned?
I know it's frustrating when you keep getting asked the same old questions over and over again, with no results, but there must be an answer, and someone in here will know what it is.
All I do in RH 7.2 is set the dns addresses to a public dns server, because the ISP I use dynamically assignes the dns through their proxy, which is hard to get going in linux I believe.
In case you want to try them:
Primary 195.92.195.94
Secondary 195.92.195.95
Based in the UK if I remember correctly.
I also always use "wvdial" from the command line, as I find it very easy to set up, and reliable.
Windows does most of the hard work for you (what do you learn from it?), Linux gives you the control and options you dont get in Windows.
Try DMR's ping suggestion, at a terminal type in:
ping -c 4 195.92.195.95 see what you get.
Good Luck

Wazza
 
Old 01-02-2002, 03:39 AM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
hey to add after reading all these posts... you never stated how your actually connecting ?? also, did you ever try pinging a IP number and not typing it in the browser interface...

i wouldn't give up though... its probably something simple your overlooking or missing...
 
Old 01-02-2002, 03:47 AM   #10
Wazza
Member
 
Registered: Dec 2000
Location: South Australia
Distribution: RedHat 7.2
Posts: 55

Rep: Reputation: 15
Dial up? an assumption on my part I'm afraid.

Last edited by Wazza; 01-02-2002 at 03:51 AM.
 
Old 01-02-2002, 12:31 PM   #11
jd300
Member
 
Registered: Nov 2001
Posts: 71

Original Poster
Rep: Reputation: 15
DSL

Thanks for the support. I am using DSL. I am using the same DNS numbers that I got from Earthlink. These numbers worked without problem in Mandrake. The weird thing is that when I highlight the connection icon in Gnome it says I am connected to the internet but the same message appears when I try to surf:host not found:Redhat or whichever site I am trying to connect to.
 
Old 01-02-2002, 06:03 PM   #12
umpa
LQ Newbie
 
Registered: Jan 2002
Location: Denver, Co
Distribution: Redhat 7.2
Posts: 10

Rep: Reputation: 0
same boat

im in the same boat as jd i also just got rh 7.2 and i cant connecet either (im on dial up) i fallowed the instrucions and when i hit connect it connects (or seems to) but i tried using netscape and it give me an error saying that i cant use and websites for an unknown reason...
please help

-umpa
 
Old 01-06-2002, 09:01 AM   #13
viporx
LQ Newbie
 
Registered: Jan 2002
Posts: 5

Rep: Reputation: 0
the redhat 7.2 rp-pppoe package is broke. Get the new pkg from here ( fits on a floppy ) and install it, then run adsl-setup

http://www.roaringpenguin.com/pppoe/...3.3-1.i386.rpm
 
Old 01-06-2002, 02:42 PM   #14
jd300
Member
 
Registered: Nov 2001
Posts: 71

Original Poster
Rep: Reputation: 15
Thanks but...

Thanks for the help but I have run out of patience with Redhat and the support from Redhat. I have swapped it for Mandrake 8.1. I know it has its own problems but at least I connect without problem. Again, thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting to the Internet with Redhat 7.3 Blake Linux - Hardware 0 11-20-2005 12:16 PM
connecting with RedHat FD789 Linux - Newbie 8 08-25-2005 01:16 AM
Connecting RedHat and M$ from SUSE sathu Linux - Networking 0 10-30-2004 04:08 AM
Connecting Via RedHat Server Patchouli Linux - Newbie 2 05-26-2003 08:04 AM
Connecting Windows 2K and RedHat 8.0 kalliste Linux - Networking 2 03-05-2003 09:03 PM


All times are GMT -5. The time now is 08:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration