LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-29-2008, 10:04 AM   #1
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Rep: Reputation: 15
Connecting to Wireless Internets


Hi,

I'm trying to connect to a free wifi network but it doesn't come up on my linux (ubuntu) platform. However, when I reboot in Vista, it connects automatically. Under Network properties, I have tried enable roaming mode, as well as just selecting DHCP as the configuration type. Still no luck. I'm not sure what else to do. I have the correct driver I think. It is the following:

Broadcom Coporation BCM94311MCG wlan mini-PCI(rev 02)

Any help would be appreciated.

Thanks
 
Old 09-29-2008, 10:11 AM   #2
mk27
Member
 
Registered: Sep 2008
Distribution: fedora, gentoo, ubuntu
Posts: 148

Rep: Reputation: 23
I use madwifi (http://madwifi.org): it works great and I can scan and connect to anyone in the neighbourhood if i want. They also provide a lot of decent documentation.

You need your kernel configured correctly or (most likely) some kind of module loaded, in any case.

[update] as arochester points out madwifi is for Atheros stuff. Sorry...

Last edited by mk27; 09-29-2008 at 11:20 AM.
 
Old 09-29-2008, 10:26 AM   #3
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Is your wireless interface "UP" under Linux?
Ususally your eth0 interface is your rj45 jack for a cable connection and eth1 is for the wireless connection
Code:
$ ifconfig
will show state of your interfaces. If there is no entry for eth1 bring it up by:
Code:
$ ifconfig eth1 up
If you re-run ifconfig it should not show you that eth1 is up and the inet line should show you the IP addr that it is pulling from the DHCP server

Last edited by john test; 09-29-2008 at 10:29 AM.
 
Old 09-29-2008, 10:29 AM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Open up a terminal and run the following:

dmesg|grep wlan (to find out what your interface is named--try also eth)

ifconfig (to verify if your interface is active)

If not, then:
ifconfig wlan0 up (substitute correct name if "wlan0" is not the name of the interface)

Assuming the interface is up, try:
iwlist wlan0 scan
 
Old 09-29-2008, 10:33 AM   #5
arochester
Member
 
Registered: May 2006
Distribution: Debian
Posts: 608

Rep: Reputation: 98
Madwifi is associated with Atheros cards not Broadcom. Have a look at e.g. http://ubuntuforums.org/showthread.php?t=684359

Broadcom on Hardy had to install a few extra lines
 
Old 09-29-2008, 10:51 AM   #6
linuxer8786
Member
 
Registered: Sep 2008
Posts: 43

Rep: Reputation: 15
you try to turn off wireless then return on wireless

Last edited by Tinkster; 10-30-2010 at 03:42 PM.
 
Old 09-29-2008, 03:01 PM   #7
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
To open up a terminal, I just hit, CTRL ALT F1, right? I am completely new to Linux. I plan on pretty much becoming an expert though. :P

Thanks
 
Old 09-29-2008, 03:24 PM   #8
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pixellany View Post
Open up a terminal and run the following:

dmesg|grep wlan (to find out what your interface is named--try also eth)

ifconfig (to verify if your interface is active)

If not, then:
ifconfig wlan0 up (substitute correct name if "wlan0" is not the name of the interface)

Assuming the interface is up, try:
iwlist wlan0 scan

I tried running these in a terminal. When I run this: iwlist wlan0 scan it tells me wlan0 no scan results.

When I run dmesg grep wlan it tells me the following:

usage: dmesg [-c] [-n level] [-s bufsize]

I tried it like this dmesg|grep wlan and it did absolutely nothing.

I tried the other command, and it gave me a huge list of stuff...
 
Old 09-29-2008, 06:10 PM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Try "dmesg|grep eth"
We're trying to see if your wireless is being recognized by the system.

You can also run lspci to fing the name of the card, and then do something like:
dmesg|grep Broadcom

Did you try "ifconfig wlan0 up"? This turns on wlan0.

Here's what we are looking for in the output of ifconfig:
Code:
eth0      Link encap:Ethernet  HWaddr 00:19:B9:21:2A:F6  
          inet addr:137.78.227.82  Bcast:137.78.227.255  Mask:255.255.255.0
          inet6 addr: fe80::219:b9ff:fe21:2af6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         <snipped>
          Interrupt:16
The things in bold tell us if your connection is working.
 
Old 09-30-2008, 08:32 AM   #10
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
Okay I will try that. Sorry I'm so retarded with Linux. I just need to breach the learning curve.
 
Old 09-30-2008, 08:40 AM   #11
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pixellany View Post
Try "dmesg|grep eth"
We're trying to see if your wireless is being recognized by the system.

You can also run lspci to fing the name of the card, and then do something like:
dmesg|grep Broadcom

Did you try "ifconfig wlan0 up"? This turns on wlan0.

Here's what we are looking for in the output of ifconfig:
Code:
eth0      Link encap:Ethernet  HWaddr 00:19:B9:21:2A:F6  
          inet addr:137.78.227.82  Bcast:137.78.227.255  Mask:255.255.255.0
          inet6 addr: fe80::219:b9ff:fe21:2af6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
         <snipped>
          Interrupt:16
The things in bold tell us if your connection is working.
Okay I put in the dmesg|grep eth and it spit out a bunch of gibberish. The one line did catch me though. It says:
[23.211065] Driver 'sd' needs updating - pleaseu use bus-type methods
[23.212880] sda:<4>Driver 'sr' needs updating - please use bus-type methods
[33.163073] eth0: no link during initialization.
 
Old 09-30-2008, 08:42 AM   #12
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
Then it says..

[255.529620] b43-phy0 ERROR: Firmware file "b43/ucode13.fw" not found or load failed.

I think that sounds like the problem right there probably...
 
Old 09-30-2008, 08:46 AM   #13
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
I ran ifconfig wlan up and it told me there is no such device....

Says I should go to http://linuxwireless.org/en/users/dr...devicefirmware and download the correct firmware.
 
Old 09-30-2008, 10:26 AM   #14
R Tanner
Member
 
Registered: Sep 2008
Posts: 96

Original Poster
Rep: Reputation: 15
So I suppose the relevant question would be how I can download the firmware file b43/ucode13.fw...

I will try searching online to see what I can find..I have already googled it and been to the linuxwireless.org site but I haven't found a download link yet. It did say however that there are only certain 'distribution points' where I can obtain it. I'm wondering, would that be like from HP or something..?
 
Old 09-30-2008, 02:55 PM   #15
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Google found this:
http://linuxwireless.org/en/users/Dr...devicefirmware

Looks promising.....

for completeness, note that you cannot "up" an interface which has no driver associated. To ifconfig, the driver is the device.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5: Setting Up Wireless Internets knoppixguy Linux - Distributions 1 01-15-2007 11:26 PM
Wireless not connecting stratcat Linux - Wireless Networking 14 12-19-2006 11:17 PM
wireless linux not connecting to router pc, windows wireless works glorsplitz Linux - Wireless Networking 1 10-01-2006 07:59 PM
connecting to the internet via wireless through Intel PRo/Wireless LAN 2100 3B Mini P k_wjss Linux - Newbie 1 09-28-2004 05:00 PM
connecting 2wire wireless to a linksys wireless pengStudent Linux - Wireless Networking 0 02-09-2004 10:51 AM


All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration