LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-19-2004, 09:04 PM   #1
redkazan
Member
 
Registered: Dec 2003
Location: Maine, US
Distribution: Slack 9.1
Posts: 55

Rep: Reputation: 15
Connecting to the internet...


Hey Folks:

I've succesfully shared an internet connection between my Linux box and my XP box at home. I'm back at school, however, and am having problems setting up the internet connection. I can connect perfectly fine via WinXP (the laptop is dual-booted), and I've since nabbed my IP, gateway, DNS server, etc. However, when I enter in this info manually in Slack [via netconfig], it doesn't work. Likewise, when I select the DHCP option, it doesn't work. However, I've confirmed via XP that the IP is assigned via DHCP. What am I doing wrong? I'm sure that I'm missing an obvious step. It seems as though I have all of the relevant info, I just don't know how to configure it. Please shed some light on this.

Thanks,

rk

Slackware 9.1/2.6.1
Gateway 450XL

Edit: Cross-posted in the networking forum and Slack forums. Please excuse the multiple posts.

Last edited by redkazan; 01-20-2004 at 11:37 AM.
 
Old 01-20-2004, 01:08 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Have you tried doing a dhclient eth0 manually?
 
Old 01-20-2004, 01:10 AM   #3
redkazan
Member
 
Registered: Dec 2003
Location: Maine, US
Distribution: Slack 9.1
Posts: 55

Original Poster
Rep: Reputation: 15
Nope.

adz:

No, could you explain how I'd go about doing that? Thanks .

rk
 
Old 01-20-2004, 02:59 AM   #4
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
You type the words "dhclient eth0" and the prompt. You have to be root, though. If it comes up as "command not found" then try /sbin/dhclient eth0. If still no joy then you haven't installed the dhcp-client package.
 
Old 01-20-2004, 11:07 AM   #5
redkazan
Member
 
Registered: Dec 2003
Location: Maine, US
Distribution: Slack 9.1
Posts: 55

Original Poster
Rep: Reputation: 15
Crap.

Heya:

When I first tried it, dhclient complained about a copy of initd that was running, so I killed the process (as instructed) and tried again. This time dhclient claimed that it couldn't find eth0. However, I know that the network card is properly configured, and I can ping myself (127.0.0.1). I'm at a loss.

Thanks,

rk
 
Old 01-20-2004, 12:30 PM   #6
fragglehorn
Member
 
Registered: Oct 2002
Location: I-Town, NY
Distribution: Debian, Slackware
Posts: 130

Rep: Reputation: 15
'ifconfig eth0 up', then 'ifconfig' to make sure the settings are correct. what are your answers, step-by-step, to netconfig?

note: mods here are pretty insistent on the double-posting rule.
 
Old 01-20-2004, 03:01 PM   #7
redkazan
Member
 
Registered: Dec 2003
Location: Maine, US
Distribution: Slack 9.1
Posts: 55

Original Poster
Rep: Reputation: 15
Results...

fragglehorn:

Thanks for the response. I did as you suggested, and the settings do indeed match XP's. My IP address is the same, at least (140.232.158.79). Bcast is set at 140.232.158.255 (should this match my gateway? In XP my gateway is 140.232.158.1).

Exact responses to netconfig:

hostname: backdrift (made up)
domain: in (made up)

Then I select DHCP, leave the nameserver blank, and select yes when it asks if these are the correct settings:

Hostname: backdrift
domain name: in
IP address: (use DHCP server)
Netmask: "
Gateway: "
Nameserver: "

When I save the settings, and try to ping an outside address, it returns 'host unknown'. However, when I reboot, and try to ping something, I get the following:

Code:
redkazan@backdrift:~$ ping -c 3 www.yahoo.com
PING www.yahoo.akadns.net (216.109. 118.71) 56(84) bytes of data.
From 140.232.158.1 icmp_seq=3 Packet filtered

--- ww.yahoo.akadns.net ping statistics ---
3 packets transmitted, 0 received, +1 errors, 100% packet loss, time 2010 ms
Any ideas?

rk
 
Old 01-20-2004, 04:38 PM   #8
fragglehorn
Member
 
Registered: Oct 2002
Location: I-Town, NY
Distribution: Debian, Slackware
Posts: 130

Rep: Reputation: 15
Okay, try this:

Hostname: backdrift
domain name: in
IP address: (use DHCP server)
Netmask: 255.255.255.0
Gateway: 140.232.158.1
Nameserver: 140.232.158.1

The broadcast address is already as it should be.
 
Old 01-20-2004, 04:44 PM   #9
redkazan
Member
 
Registered: Dec 2003
Location: Maine, US
Distribution: Slack 9.1
Posts: 55

Original Poster
Rep: Reputation: 15
fragglehorn:

How do I change my gateway/nameserver, while still letting DHCP handle my IP? When I run netconfig, if I select DHCP, it uses DHCP for *everything*.

Plus, what do you make of the fact that when using DHCP, I can kinda ping the outside world, but I get those 'packet filtered' errors?

Thanks,

rk
 
Old 01-21-2004, 02:26 PM   #10
fragglehorn
Member
 
Registered: Oct 2002
Location: I-Town, NY
Distribution: Debian, Slackware
Posts: 130

Rep: Reputation: 15
Forget what I said about changing settings manually. Just let dhcp do everything, it's at least letting you talk to outside addresses.

The filtered packet is a little strange. You say you're back at school now? If you're living in a dorm and plugging into a school network, they could be running a firewall that doesn't like your box. Perhaps you're running services (http, smtp, etc) that they don't trust. Is this machine strictly a workstation?
 
Old 01-21-2004, 02:52 PM   #11
t3___
Member
 
Registered: Sep 2003
Posts: 240

Rep: Reputation: 30
~~~~~~~~~~~~~~
Perhaps you're running services (http, smtp, etc) that they don't trust. Is this machine strictly a workstation?
~~~~~~~~~~~~~~

And its worth metioning that some Distros (im not sure about slackware) run these services (esp Apache/http) by default...
 
Old 01-21-2004, 05:03 PM   #12
redkazan
Member
 
Registered: Dec 2003
Location: Maine, US
Distribution: Slack 9.1
Posts: 55

Original Poster
Rep: Reputation: 15
Which services would be troublesome? How do I find/disable them?

Thanks guys,

rk
 
Old 01-22-2004, 06:04 AM   #13
fragglehorn
Member
 
Registered: Oct 2002
Location: I-Town, NY
Distribution: Debian, Slackware
Posts: 130

Rep: Reputation: 15
As root, 'nmap localhost'. This will list your open ports.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 04:29 PM
Connecting to the Internet jthomas98 Linux - Networking 1 10-29-2005 02:26 PM
connecting to internet reznik Linux - Networking 2 07-19-2003 07:37 PM
Connecting to Internet dfries Linux - Networking 6 02-13-2003 01:31 PM
Connecting to the Internet mjl1297 Linux - Software 2 02-06-2002 04:33 AM


All times are GMT -5. The time now is 05:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration