LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2004, 04:30 PM   #1
ejbest
Member
 
Registered: Jul 2004
Posts: 34

Rep: Reputation: 15
connecting to samba


Here is the problem, there are Fedora 2 servers running Samba that I try to connect to with using a Windows XP machine. On the Windows Box both Samba servers are seen under 'Entire Network' 'Workgroup name' and are listed. Browsing or connecting to them beyond seeing them in this list is the problem.

When clicking on them, a message appears as follows.

\\servername is not accessable. You might no have permission to use this network resource. Contact the administrator (duh myself) of this server to find out if you have permissions.

Anyway the username on the Windows box is entered on the 'Authentication' portion; more over, the Samba boxes are set to 'browse' for 'anyone'. Both samba servers have been made dam near totally open and still there is no ablility to browse or connect. And yes, the password option is encrypted.

Thank You in advance,
 
Old 10-17-2004, 05:56 PM   #2
crm
Member
 
Registered: Apr 2004
Location: leeds - UK
Distribution: Gentoo Stage 1 on Riser FS 4
Posts: 204

Rep: Reputation: 30
well samba usually alwaise needs authentication.....

first off make accounts on your linux box for everyone accessing the shares giv em a username and password as normal (if you like security its alwaise fun to make there shells /bin/false -- try cracking that one! :P )
next tell samba that theese users are likley to be accesing samba shares via the network by adding them to the samba password list....

smbpasswd -a <USERNAME>

(the -a option means ADD.. omitting it changes an already existing smb password... the smb password and unix passwords dont haev to be the same!
finially have a look over your smb.conf file type and then reed 'man smb.conf' for security and fine tuning...

remember, samba = fun

Last edited by crm; 10-17-2004 at 05:58 PM.
 
Old 10-17-2004, 08:26 PM   #3
ejbest
Member
 
Registered: Jul 2004
Posts: 34

Original Poster
Rep: Reputation: 15
Thank you for the post; however, all was done.

The user name was the same, and the password was the same on.....

1) the xp machine
2) the smbpasswd
3) the /etc/passwd file

Again, 'more over', with things like this, this should be expected to show up 'anyway'

[tmp]
comment = /tmp
path = /tmp
guest ok = yes

Also I turned off the firewall on the xp box.

Thanks again in advance, any ideas are cool.
 
Old 10-18-2004, 12:23 AM   #4
SweetLou
Member
 
Registered: Oct 2004
Distribution: Debian Testing
Posts: 171

Rep: Reputation: 30
I have had that same message before. With me, it was caused my Norton Anti-virus changing a registry key. There was a fix to change it back and everything was fine. I just did a quick google search and there seems to be other reasons also. I saw on Microsoft's site that Trend Micro caused the same problem but on a W2K box. I know this isn't much help but it might lead you in the right direction. It seems to me, it is a problem on the XP box and not with Samba. But, that could be a problem also.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - Connecting from WinXP Pro to Samba running on Debian critical Linux - Networking 1 02-03-2005 10:36 AM
samba seeing, but not connecting shelbydz Linux - Networking 1 10-21-2004 06:28 PM
Serious lag connecting to samba tisource Linux - Networking 2 03-24-2004 09:58 PM
Connecting with samba andystreet Linux - Networking 1 11-04-2003 08:37 PM
Samba not Connecting artman62 Linux - Networking 5 06-10-2002 11:52 PM


All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration