LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-06-2007, 10:58 PM   #1
QuantumPressure
LQ Newbie
 
Registered: Apr 2007
Posts: 4

Rep: Reputation: 0
Unhappy Connecting to net as a user won't work


For some reason, I can't connect to the internet when I'm logged in as a user. So I always have to log out and sign in as root. Then it works. This is the error message I get when I use KPPP when logged in as a user...

You do not have sufficient permission to run
/usr/sbin/pppd
Please make sure KPPP is owned by root and has the SUID bit set


Now, I'm new to Linux so I am completely lost as to what this says. So how can I use KPPP signed in as user? I'm getting tired of constantly signing back and forth between the bloody accounts.


Oh yeah, I'm using openSUSE 10.2 if that helps anyone.
 
Old 05-06-2007, 11:17 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
First, try running YaST2. There may be a ppp config program that will do this for you.
Second, locate the kppp program. It probably is somewhere in /opt/kde3/bin/ or /opt/kde3/sbin. Look at the long listing of it, i.e. "ls -l /opt/kde3/bin/kppp"
It will be owned by root. But look at the group owner of the file. It might by owned by "kppp". If so a member of the group kppp will be able to run the program.
---

Update: I googled on "suid" to refresh my memory on the chmod command to set the suid bit. I found out that the solution is to make yourself a member of the "dialout" group.
So setting the suid bit for the kppp program is probably not the correct thing to do, so I won't even post the third option.

I'm not at my Linux machine now so I wasn't able to locate the kppp and pppd programs and look at them.

Last edited by jschiwal; 05-06-2007 at 11:18 PM.
 
Old 05-06-2007, 11:53 PM   #3
kstan
Member
 
Registered: Sep 2004
Location: Malaysia, Johor
Distribution: Dual boot MacOS X/Ubuntu 9.10
Posts: 851

Rep: Reputation: 31
Hi,
another alternative which is use setuid method(not recommended if you share computer with other user),
as root,
chmod +s /opt/kde3/bin/kppp

so next time you will automatically run kppp as root.

Regards,
Ks
 
Old 05-07-2007, 05:35 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Using the dialout group is a much better solution. You should never have to suid a program like kppp.
 
  


Reply

Tags
error, internet, kppp, opensuse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help connecting to 'Net Chappy7777 Ubuntu 4 01-24-2006 03:40 PM
Digikam connecting as root/not connecting as regular user jayhel Slackware 5 09-29-2005 06:57 PM
Connecting to the Net LinuxNewBeeSwrm Linux - Networking 5 03-06-2005 01:53 PM
Connecting to the net... Fasn8n Mandriva 17 12-31-2004 06:18 AM
connecting to the net bmxermark Linux - Newbie 5 05-05-2003 09:46 AM


All times are GMT -5. The time now is 06:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration