LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2007, 09:53 AM   #1
PocketSam
LQ Newbie
 
Registered: Jan 2007
Location: Russia - Novosibirsk
Distribution: Slackware 11
Posts: 10

Rep: Reputation: 0
Unhappy connecting to internet with winXP through slackware 11


In advance I'd like to beg your pardon for my English. It's not my native language, so sometimes it's a bit hard to understand some moments. And in fact I'm not sure if I write correctly.

Well.. As you see I've got a problem with connecting to the internet. I've got two PCs. One with Slackware 11(connected to the internet) and one with XP. I would like to organize a little "network" of two computers and to give the second machine an opportunity to connect to the internet thought the fist one.
The connection scheme is like that:
internet---Slackware PC---XP PC

This are the info my ISP gave me:
ip: 172.21.3.39
Subnet Mask: 255.255.255.0
Default Gateway: 172.21.3.1
DNS: 80.64.93.130 and 80.64.94.2

This is my /etc/rc.d/rc.inet1
# Config information for eth1: //as U understand, it connected to the second machine
IPADDR[1]="192.168.1.1"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2: //to the isp
IPADDR[2]="172.21.3.39"
NETMASK[2]="255.255.255.0"
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

My ifconfig:
eth1 Link encap:Ethernet HWaddr 00:14:2A:C4:72:2F
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth2 Link encap:Ethernet HWaddr 00:11:95:25:71:1D
inet addr:172.21.3.39 Bcast:172.21.3.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:26438 errors:0 dropped:0 overruns:0 frame:0
TX packets:9394 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:10133820 (9.6 MiB) TX bytes:1933381 (1.8 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:164 errors:0 dropped:0 overruns:0 frame:0
TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:60518 (59.0 KiB) TX bytes:60518 (59.0 KiB)

My route -n: //seemes to be wrong?
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
172.21.3.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 172.21.3.1 0.0.0.0 UG 1 0 0 eth2

Else i've configured BIND, but it doesn't work. Unfortunately, as my experience in linux is rather poor yet, I can't exactly understand how to solve this problem. //compile and install the "capability" module? Am I right?

Here is rc.bind restart command:
Stopping BIND: /usr/sbin/rndc stop
Starting BIND: /usr/sbin/named
WARNING: named did not start. Perhaps this is because
the "capability" module required by newer kernels is
not loaded (or built into the kernel)?
Attempting to load security capability module:
/sbin/modprobe capability
Attempting to start named again: /usr/sbin/named
FAILED: Sorry, but even after attempting to load
the "capability" module, named did not start.
There may be a different configuration error that
needs fixing. Good luck!

And else i've minimally configured iptables:
iptables -F; iptables -t nat -F; iptables -t mangle -F
iptables -t nat -A POSTROUTING -o eth2 -j SNAT --to 172.21.3.39

and turned on routing:
echo 1 > /proc/sys/net/ipv4/ip_forward

On the computer with XP I set these settings:
ip: 192.168.1.2
netmask: 255.255.255.0
gateway: 192.168.1.1

I would like to test my suggested settings if they'll work but i can't cause i even can't ping my second PC.. :8`(

I'm new to linux, so sometimes i need help. First I try to do everything by myself - the best way to learn, i think, but already for a week I can't solve this puzzle. I haven't much time to read many linux books or articles in the net, so I would be incredibly glad if you help me!

Best wishes, Sam!

p.s. And one more question. How can I start the LISA daemon for KDE? I didn't find it anywhere. And even KDE Help Center didn't help me. :8$

Last edited by PocketSam; 05-18-2007 at 10:27 AM.
 
Old 05-18-2007, 05:01 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Hi,

You won't need bind for any of this (unless you want to set-up
a domain with your own nameserver [which seems overkill for a
network with two machines]).

As far as the routing table goes: that looks correct to me. Is
the slack-machine able to talk to the internet?

The XP box can talk to the slack-machine?

Basically I think it *should* work (didn't spend hours of
thought on it, though). What problems are you having?


Cheers,
Tink
 
Old 05-19-2007, 06:30 AM   #3
lozza1978
LQ Newbie
 
Registered: Feb 2005
Posts: 23

Rep: Reputation: 15
Hi Sam,

Your slackbox has 2 nics - have you tried pinging both IP address from the slack machine?, you should get a reply from both address -

On the xp machine have you tried pinging its own IP - you should also get a reply from this.

Assuming you get replies from all 3 IP address above - try and ping the XP machine from the slackbox, and from the xp machine to the slackbox. - you should also get ping replies here..

Can the slackbox access the internet ok? can you surf the internet on the slackbox?

if yes this rules out DNS.

Try what I suggested and let us know the results, good luck.

Lozza1978
 
Old 05-19-2007, 07:16 AM   #4
PocketSam
LQ Newbie
 
Registered: Jan 2007
Location: Russia - Novosibirsk
Distribution: Slackware 11
Posts: 10

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Tinkster
Hi,
You won't need bind for any of this (unless you want to set-up a domain with your own nameserver which seems overkill for a network with two machines])
It means configuring network would be easier. But nevertheless one day I want to set up the working DNS. I really want to know Linux (and all UNIX-like) excellently!

Quote:
Originally Posted by Tinkster
Is the slack-machine able to talk to the internet?
Yep.. I'm using it right now.

Quote:
Originally Posted by lozza1978
Your slackbox has 2 nics - have you tried pinging both IP address from the slack machine?, you should get a reply from both address
Yes. I can ping all ip-adresses from linux machine. (172.21.3.39, 192.168.1.1)

Quote:
Originally Posted by lozza1978
On the xp machine have you tried pinging its own IP - you should also get a reply from this.
Yes. It works normally.

Last edited by PocketSam; 05-19-2007 at 07:26 AM.
 
Old 05-19-2007, 08:23 AM   #5
lozza1978
LQ Newbie
 
Registered: Feb 2005
Posts: 23

Rep: Reputation: 15
Hello again.

I have not used slackware in about 5 years or so, But in your /etc/rc.d/rc.inet1.conf you posted i did not see any mention of gateways.

Could you please post the complete output from

Code:
/etc/rc.d/rc.inet1.conf

your config looks all good and the only thing i can think off at the moment is that you have 2 gateways running from your slackbox - but could be wrong!!

Lozza1978
 
Old 05-19-2007, 09:07 AM   #6
PocketSam
LQ Newbie
 
Registered: Jan 2007
Location: Russia - Novosibirsk
Distribution: Slackware 11
Posts: 10

Original Poster
Rep: Reputation: 0
Here it is:
my rc.inet1.conf:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]="192.168.1.1"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]="172.21.3.39"
NETMASK[2]="255.255.255.0"
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY="172.21.3.1"

# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

...I have no wireless network adapter, so it's configuration is not needed, I hope.

Maybe I need to run some services to have correctly working network? I could disable some of them by any chance.
Or maybe I've injured the rc.inet1? I've used the KDE Network Settings (In KDE Control Center) and it had added "eth_up" in the top and somewhere else in the rc.inet1. I've deleted them, but maybe something else was changed. Can you post the contents of rc.inet1 for slackware 11?

Else, I've found an interesting site with many-many documentations. Will study it in the evening after a walk. Hope to find something useful.

Anyway, would be glad to any help and/or suggestions! You LQ community surprised me because you help to everyone and give answers even to rather simple questions! Most of people would refer such users to read man and "(to)google". I'm really proud of you all!!!

Last edited by PocketSam; 05-19-2007 at 11:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting to internet on new Slackware installation kernco Slackware 4 10-01-2006 01:32 PM
[beginner] Connecting fedora core to internet through winXP machine RhysBJ Linux - Networking 8 06-09-2006 09:03 AM
Problems connecting to internet using Slackware Dead_Linux_User Linux - Networking 11 09-14-2004 07:22 PM
WAG511 on Slackware 10.0 not connecting to internet donk Linux - Wireless Networking 5 07-19-2004 09:30 AM
Connecting to the Internet in Slackware 9.1 rfsatxeng Linux - Newbie 2 01-10-2004 11:13 AM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration