LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2010, 11:18 AM   #1
asab
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Rep: Reputation: 0
Unhappy Connecting to internet using MTS Mblaze on Fedora 14


I have installed Fedora 14 on my laptop
And trying to use MTS MBlaze Mobile BroadBand Connection
And its a USB MODEM

in order to use usb modem
I am using use 3 packages
ie
1. usb_modeswitch
2. usb_modeswitch_data
3. wvdial

Its connecting when i Dial using wvdial as below

root@Athreyasa Athreyasa]# wvdial
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
ATDT#777
CONNECT
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Tue Dec 14 21:14:07 2010
--> Pid of pppd: 3397
--> Using interface ppp0
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> local IP address 180.215.44.134
--> pppd: �[7f]
--> remote IP address 10.212.64.1
--> pppd: �[7f]
--> primary DNS address 10.216.126.132
--> pppd: �[7f]
--> secondary DNS address 10.216.254.132
--> pppd: �[7f]


After connecting i am getting ip as 180.215.44.134 gateway as 10.212.64.1 but if i try to browse the Internet using firefox it says no server found error.

I tried to ping google.com and its not pinging after connecting. nslookup also fails against google.com

however if i ping any of the ip that i am getting while connecting it is pinging

Also disabled the firewall and selinux is set to disable just in case to check something else is blocking but no luck

Guys, Any suggestion in this regard would be of great help.

Thanks
asab
 
Old 12-17-2010, 01:20 PM   #2
ilvista
Member
 
Registered: Nov 2010
Location: Ghazaouet
Distribution: Fedora OpenSuse
Posts: 150

Rep: Reputation: 21
you've been assigned a public ip address ,that means that internet connection works fine.
it could be a DNS problem.

try to change you DNS .here is a list of free dns servers
http://theos.in/windows-xp/free-fast...s-server-list/

or better yet you can install BIND dns server on your machine.
 
Old 12-17-2010, 08:13 PM   #3
asab
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I did the same, i.e manually added the DNS entries in /etc/resolv.conf but No luck.Any other suggestions

Thanks
Adarsha.
 
Old 12-18-2010, 01:00 PM   #4
ilvista
Member
 
Registered: Nov 2010
Location: Ghazaouet
Distribution: Fedora OpenSuse
Posts: 150

Rep: Reputation: 21
try to ping this 74.125.232.144
it's google's.and see what happens!if i goes then definitely it's a DNS problem.
also you can install your own BIND dns server on your box.

can you post your resolv.conf
and ifconfig command
 
Old 12-19-2010, 07:57 PM   #5
asab
LQ Newbie
 
Registered: Dec 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I manually added the DNS entries in /etc/rsolv.conf restarted network service then it started working.

ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:48 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3600 (3.5 KiB) TX bytes:3600 (3.5 KiB)

ppp0 Link encap:Point-to-Point Protocol
inet addr:180.215.69.112 P-t-P:10.212.0.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:64 (64.0 b) TX bytes:94 (94.0 b)


resolv.conf
cat /etc/resolv.conf
# Generated by NetworkManager

nameserver 10.216.126.132

nameserver 10.216.254.132


Marking it as solved


Thanks lot for the help
asab
 
Old 05-26-2011, 02:13 AM   #6
vaidik
LQ Newbie
 
Registered: May 2011
Posts: 4

Rep: Reputation: Disabled
Hi asab!

I have recently purchased a MTS MBLAZE and I was trying to get it to work on Fedora 14. As a matter of fact, it started working and I got it to work by referring to this very post.

The issue is that the internet works fine but I am not able to sign in to Google. Google.co.in opens but google.com doesn't open. I am also able to search on google.co.in. GMAIL and Google Analytics also don't open. But somehow, code.google.com opens and works fine. In fact, I committed some code on one of my projects on Google Code using Mercurial SCM.

Any suggestions?

P.S.: Apologies for posting in a [SOLVED] thread, if it is not allowed.

Last edited by vaidik; 05-26-2011 at 02:19 AM.
 
Old 06-10-2011, 12:18 AM   #7
narayanad9
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Rep: Reputation: Disabled
how to chek befroe installing any operating system it is 64-bit / 32-bit cd
 
Old 06-10-2011, 03:13 AM   #8
narayanad9
LQ Newbie
 
Registered: Jun 2011
Posts: 3

Rep: Reputation: Disabled
plz any body tell me if i want to install operating system on my pc. how can i check before it is a 32-bit / 64-bit cd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] MTS MBlaze fails to connect on fedora 14 arul315 Linux - Newbie 16 05-30-2011 12:10 PM
[SOLVED] Issues with Mobile Broadband Connection ( Service Prov.-MTS MBlaze ) abhi.daemon Linux - General 2 12-12-2010 12:35 AM
[SOLVED] connecting to the internet with wmp54g on fedora 12 moGi7 Linux - Wireless Networking 9 01-12-2010 03:30 AM
connecting internet in fedora core 6 Gayathri.P Linux - Newbie 1 02-13-2008 03:41 AM
Connecting to the Internet Using Fedora godzilla_roar20 Linux - Newbie 2 07-20-2004 04:49 PM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration