LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-27-2011, 05:29 PM   #1
nine9nine
Member
 
Registered: Jan 2011
Distribution: Ubuntu
Posts: 123

Rep: Reputation: 1
Connecting to internet Slackware 13.37


Hi, everyone. I have a couple year old laptop that I've been testing different Linux distros on. I just installed Slackware 13.37 on it, but I can't connect to the internet on it, wifi or ethernet. During the installation, there was a part about setting up a network. I started, but then skipped it because it seemed like it was for hosting a website (I'm not sure about that). Was I supposed to do that, and if so, how can I do that without a reinstallation? If I have to reinstall, that's ok since I don't use that computer for anything important.
 
Old 09-27-2011, 06:04 PM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,145

Rep: Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503
You should not have to re-install, assuming you did a full install.

This is a very good link and should guide you through wired and wireless configs.

-->http://alien.slackbook.org/dokuwiki/...ckware:network
 
1 members found this post helpful.
Old 09-27-2011, 06:06 PM   #3
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 63
For wired connections, you should run netconfig as root and provide the information. The host and domain names can be made-up. Choose dhcp. For wireless, choose loopback and install wicd in the extra directory of the DVD. Reboot the computer to be safe (restarting just dbus and starting the wicd daemon might work) and configure your connection.

Edit: check camorri's link. You'll get a better understanding that way.
 
1 members found this post helpful.
Old 09-27-2011, 06:07 PM   #4
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
netconfig to run that setup again. dont think this works for the wireless btw
 
1 members found this post helpful.
Old 09-27-2011, 06:10 PM   #5
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
What does your /etc/rc.d/rc.inet1.conf look like?
If you want to use DHCP, then try this:

Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""
Then make sure /etc/rc.d/rc.inet1 is executable

chmod +x /etc/rc.d/rc.inet1

Last edited by andrewthomas; 09-27-2011 at 06:47 PM.
 
1 members found this post helpful.
Old 09-27-2011, 06:11 PM   #6
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 63
Why make rc.inet1.conf executable?
 
Old 09-27-2011, 06:48 PM   #7
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Quote:
Originally Posted by bonixavier View Post
Why make rc.inet1.conf executable?
Sorry typo.
 
Old 09-28-2011, 02:12 AM   #8
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
gday mate, i use mobile broadband and the only way i know how to connect to that on linux is through, network manager, and slackware does not include this. i had to go onto a different computer with internet access, go to slackbuilds.org, and download the network manager and its dependencies then bring them over to my slack computer and install them.
 
Old 09-28-2011, 03:55 PM   #9
nine9nine
Member
 
Registered: Jan 2011
Distribution: Ubuntu
Posts: 123

Original Poster
Rep: Reputation: 1
Ok, so I have a wired connection, and am able to see my wifi network. However, I can't seem to connect on wifi. I opened the properties and put in my code, but when I try to connect, it starts to, but then says "Connection failed: Unable to obtain ip address." What should I do now?
 
Old 09-28-2011, 04:44 PM   #10
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Do you have a mac filter enabled on your router ? (without having your wireless card's mac address configured on it to allow access)

Last edited by svu; 09-28-2011 at 04:46 PM.
 
Old 09-29-2011, 05:13 AM   #11
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
are you a member of the udev group?
 
Old 09-29-2011, 09:28 AM   #12
nine9nine
Member
 
Registered: Jan 2011
Distribution: Ubuntu
Posts: 123

Original Poster
Rep: Reputation: 1
I don't know if I have a mac filter enabled on my router. I previously had openSuse 11.4 installed on the laptop, and it was able to connect to wifi without anything special.
 
Old 09-29-2011, 10:30 AM   #13
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Ok. No macfilter problem then
 
Old 09-30-2011, 02:44 PM   #14
nine9nine
Member
 
Registered: Jan 2011
Distribution: Ubuntu
Posts: 123

Original Poster
Rep: Reputation: 1
Then what should I do?
 
Old 09-30-2011, 03:22 PM   #15
svu
Member
 
Registered: Apr 2005
Distribution: Slackware 13.37
Posts: 36

Rep: Reputation: 1
Are you sure you're using the right key/password for connecting to your wifi network ?

After a fresh installation your keyboard layout in a desktop environment like KDE might be "wrong" for your actual keyboard. I know if I choose an azerty keyboard when installing Slackware KDE doesn't pick this setting up and I need to fix this in KDE. (otherwise in my case : a = q , w = z , ... and other key's get switched)

Also certain other characters such as ";" or letters you would like to use for your secure password might not be what you think they are when you press them. And because you might not see them due to for example asterisks you might think you're typing it correctly when in fact maybe some characters are off...

This is a long shot as you probably would have noticed a "bad" keyboard layout (I don't know how long you've been using your installation already) but it's better to verify.

Then maybe verify what Knightron says ... check the groups that the user belongs to.
Maybe you didn't add the user to the "netdev" group ? (I believe it's netdev that might be needed for wifi connections).
When adding a new user in Slackware you can put him/her in a set of default groups (it's suggested when creating a new user, I think netdev is part of this suggestion).

I hope one of these things can help you with your connection.

Last edited by svu; 09-30-2011 at 03:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Trouble connecting Slackware 13.37 to the internet adoltswimmer Slackware 14 06-20-2011 02:29 PM
connecting to internet with winXP through slackware 11 PocketSam Linux - Newbie 5 05-19-2007 08:07 AM
WAG511 on Slackware 10.0 not connecting to internet donk Linux - Wireless Networking 5 07-19-2004 08:30 AM
Connecting to the Internet in Slackware 9.1 rfsatxeng Linux - Newbie 2 01-10-2004 10:13 AM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration