LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2006, 12:08 PM   #1
Frank Soranno
Member
 
Registered: Jun 2005
Location: Scranton, Pa. USA
Distribution: Debian
Posts: 230

Rep: Reputation: 30
Red face Connecting to internet?


Just installed Fedora Core 5 and can't find my ethernet connection, When it boots up I see
that eth0 failed to load, Can't find network config on my system, How do I connect to the internet?

OK, Found ethernet connection to be OK, Found NetworkManager, NetworkManagerDispatcher running and still can't get internet to run, Anymore help will be appreciated

Last edited by Frank Soranno; 04-06-2006 at 03:01 PM.
 
Old 04-06-2006, 05:23 PM   #2
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
Find out what network card you've got, find the driver pack for FC / RedHat, install it , modprobe it, hope for the best.

If you can't find the driver pack start getting used to configuring a kernel yourself, look at the kernel's network options and see if you can find a driver that supports your network card.

Compile the kernel, install the kernel, add a line to grub, reboot, pray.

ALTERNATIVELY, your last bit there saying you found your ethernet connection to be OK, does that mean you have the driver running? in which case it would be a good idea to check if your Router (or whatever you're using to connect to the internet) and your Box don't have conflicting network settings. Also you may need to configure your network on the box using netconf (or is it netconfig ...?).

That should pretty much take care of anything if that is the problem.

IF you've done that, ping your router, (same as the default gateway) and provided your router is set up right (password and all that jazz) you probably will be right.

Unless your firewall doesn't let you through (easiest way to make sure of this is to run `services iptables stop` ... or whatever FC uses to start/stop it's firewall these days).

Good luck
 
Old 04-07-2006, 06:47 AM   #3
Frank Soranno
Member
 
Registered: Jun 2005
Location: Scranton, Pa. USA
Distribution: Debian
Posts: 230

Original Poster
Rep: Reputation: 30
Hi chakkerz, Thanks for reply, I have posted all over these forums and had a good many good replies,
However I am not so good at this stuff and perhaps I'm missing the points.I don't think it's a hardware problem, I have the following Kernel 2.6.15-1 Grub V 0.97 eth0 nVidia corp MC51. I did a ping with all packages retuned no errors.

I do have an eth0 that shows up as a devise in my Network Configure in my Admin on the desktop.
When I configure the ethernet device, I have it set to Automaticlly obtain IP address settings with dhcp and Automatically obtain DNS, However when I click Activate button, it return failed?

Here is a little more information;

[root@localhost /]# /sbin/ifconfig
eth0
Link encap:Ethernet HWaddr 00:E0:4C:F1:A3:FE

inet6 addr: fe80::2e0:4cff:fef1:a3fe/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Interrupt:17 Base address:0xe000

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:3553 errors:0 dropped:0 overruns:0 frame:0

TX packets:3553 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0
RX bytes:4405361 (4.2 MiB)
TX bytes:4405361 (4.2 MiB)





root@localhost /]# dmesg | grep eth0
eth0:
forcedeth.c: subsystem: 01565:2501 bound to 0000:00:14.0
eth0:
no IPv6 routers present
[root@localhost /]#

Last edited by Frank Soranno; 04-07-2006 at 03:21 PM.
 
Old 04-08-2006, 02:31 PM   #4
Frank Soranno
Member
 
Registered: Jun 2005
Location: Scranton, Pa. USA
Distribution: Debian
Posts: 230

Original Poster
Rep: Reputation: 30
Hi chakkerz, Finally got it going,I want to Thank you very much for your help. I happened over to linux HOWTO, and got it going by luck, I can't tell you how, but I tried all the codes that were given and wala, I'm on line. Now that I'm up and running I have a lot to learn and a lot of new questions.
Well thank you once more and have a good weekend. Frank
 
Old 04-08-2006, 03:27 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Setting your NIC to get its IP via DHCP will only work if you have a DHCP server on your LAN. If you don't have this what you probably did to get it working was assign yourself a static IP address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
Connecting To Internet dtariman Ubuntu 13 03-25-2006 09:34 AM
connecting to internet sathish80 Linux - Newbie 2 01-23-2006 08:53 AM
connecting to internet reznik Linux - Networking 2 07-19-2003 08:37 PM
Connecting to the Internet ToeShot Linux - General 2 12-13-2001 10:26 AM


All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration