LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2009, 03:42 AM   #16
shogun1234
Member
 
Registered: May 2004
Posts: 176

Rep: Reputation: 15

I try this setting but the result of executing `ifup wlan0' shows
Code:
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
The wirelss configuration in /etc/network/interfaces is

Code:
allow-hotplug wlan0
ifcae wlan- inet dhcp
wirelss_essid TEST
wirelss_key s:password
Is this the correct setting parameters for WEP? I `man wirelss', it seems this is the correct format for setting wirelss.

I am sure the network works well because I can use other pc (windows) to surf the internet.

Also, previously my laptop works well in another wireless which configures using wpa and it worked well without a problem.

What is the correct setting for WEP? Or where can I obtain the working sample for WEP setting?

Thanks for help.


Quote:
Originally Posted by evo2 View Post
Simple example of /etc/network/interaces for wireless device called wlan0 and access point using WEP encryption.

Code:
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
      #wireless_key s:asciikey  # Start with the "s:" if the key is ascii
      wireless_key D05C0B1234   # 
      wireless_essid Foobar
      wireless_mode managed
The line "auto wlan0" will ensure mean that the interace will come up automatically at boot.
You can manually bring it down with

Code:
ifup wlan0
and down with
Code:
ifdown wlan0
NB. This is the way it's done in Debian, and therefore I assume Ubuntu.

HTH,

Evo2.
 
Old 12-04-2009, 04:12 AM   #17
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Quote:
Originally Posted by shogun1234 View Post
I try this setting but the result of executing `ifup wlan0' shows
Code:
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
That is extremly strange. I should output much more than that, even if it does fail.

Quote:
The wirelss configuration in /etc/network/interfaces is

Code:
allow-hotplug wlan0
ifcae wlan- inet dhcp
wirelss_essid TEST
wirelss_key s:password
Is this the correct setting parameters for WEP? I `man wirelss', it seems this is the correct format for setting wirelss.
It depends if the typos above are only in your post and not in your interfaces file. If what is really in your interfaces file is as below, then it should work for wep.
Code:
allow-hotplug wlan0
iface wlan0 inet dhcp
wireless_essid TEST
wireless_key s:password
Quote:
Also, previously my laptop works well in another wireless which configures using wpa and it worked well without a problem.

What is the correct setting for WEP? Or where can I obtain the working sample for WEP setting?
I'm pretty sure that what I posted is correct. There must be some other problem.

From your original post it seems that you are able to use some gui tool to get your wireless working. If so can you please post the output of the following for two cases
Code:
sudo iwconfig
1. When the wireless is working: after bring it up with the gui
2. When it is not working: just after failing to bring it up on the command line.


Cheers,

Evo2.

Last edited by evo2; 12-04-2009 at 04:13 AM. Reason: Typo
 
Old 12-04-2009, 04:13 AM   #18
JML
LQ Newbie
 
Registered: Jan 2005
Location: TN
Distribution: Fedora, Debian, Arch
Posts: 4

Rep: Reputation: 1
I'm not sure if you typed or copy/pasted your network configuration, but in almost every case of "wireless" you're missing an 'e'. Start by correcting that if you did just copy it.

Since this thread has already been resurrected, cnetworkmanager is another option for users who are already using Network Manager on their systems. It's a command line interface to network manager of course, and fairly simple to use. Ex. cnetworkmanager -C my_ssid --wpa-pass=mypass
 
Old 12-04-2009, 09:13 AM   #19
imagine_me2
Member
 
Registered: Nov 2009
Location: Kolkata, India
Distribution: Fedora 11
Posts: 136

Rep: Reputation: 22
To: tredegar

<Quote>nm-applet is rubbish</Quote>

There are people who wrote nm-applet, and with a honest motive of helping the Linux users. I think they deserve a better comment than the above.

We may not like a thing but we can be gentle with our criticism. I said this not because i think you are wrong, but beacause of the way you said it.

Regards.
 
Old 12-04-2009, 11:53 AM   #20
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,542
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Quote:
Originally Posted by imagine_me2 View Post
To: tredegar

<Quote>nm-applet is rubbish</Quote>

There are people who wrote nm-applet, and with a honest motive of helping the Linux users. I think they deserve a better comment than the above.

We may not like a thing but we can be gentle with our criticism. I said this not because i think you are wrong, but beacause of the way you said it.

Regards.
From your perspective!

'PC' is 'BS'!

If something is a piece of crap it deserves noted as such. You can rub or spin any way you want but if the feelings or skin of the software programmer is that thin then I suggest they get out.

When the kettle is Black, it can be hot too. Touching it will make you aware of one but not the other.
 
Old 12-05-2009, 06:52 PM   #21
shogun1234
Member
 
Registered: May 2004
Posts: 176

Rep: Reputation: 15
env: kernel 2.6.31/ gcc 4.3.4/ make 3.81/ debian unstable

I double check the related setting again. It looks correct to me, but I think there should have something missing and I am not aware of it. They are follow:

Firmware located at /lib/firmware contains
Code:
iwlwifi-4965-2.ucode
The result of lsmod | grep iwlagn
Code:
iwlagn 73340 0
iwlcore 95716 1 iwlagn
mac80211 124608 2 iwlagn, iwlcore
cfg80211 76636 3 iwlagn, iwlcore, mac80211
led_class 3868 3 iwlcore, hp_accel, sdhci
I can not find any kernel module with `lsmod | grep 4965`, which is the module detected in the past. I also read on the internet saying that iwl4965 is iwlagn in fact, as follow:
Code:
http://ubuntuforums.org/showthread.php?t=902652&page=2
http://article.gmane.org/gmane.linux.drivers.ipw3945.devel/3398
The syslog shows
Code:
iwlagn: Intel(R) Wireless Wifi Link AGN driver for Linux, 1.3.27ks
iwlagn: Copyright(c) 2003-2009 Intel Corporation
iwlagn: 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn: 0000:10:00.0: setting latency timer to 64
iwlagn: 0000:10:00.0: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
...
iwlagn 0000:10:00.0: firmware: requesting iwlwifi-4965-2.ucode
iwlagn 0000:10:00.0: loaded firmware version 228.57.2.21
Registered led device: iwl-phy0::radio
Registered led device: iwl-phy0::assoc
Registered led device: iwl-phy0::RX
Registered led device: iwl-phy0::TX
ADDRCONF(NETDEV_UP): wlan0: link is not ready
It looks like the firmware is loaded, but I do not know why the link is not ready.

The iwconfig reault
Code:
wlan0 IEEEE 802.11abgn ESSID:"TEST"
      Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
      Tx-Power=15 dBm
      Retry long limit: 7 RTS thr:off Fragment thr:off
      Encryption key:off
      Power Management: off
      Link Quality:0 Signal level: 0 Noise level:0 
      Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
      Tx execessive retries:0 Invalid misc: 0 Missed beacon:0
The interfaces configuration
Code:
allow-hotplug wlan0
iface wlan0 inet dhcp
wireless_essid TEST
wireless_key s:password

auto wlan0
Does these look correct?

Thanks for the help.

I appreciate it.


Quote:
Originally Posted by evo2 View Post
That is extremly strange. I should output much more than that, even if it does fail.


It depends if the typos above are only in your post and not in your interfaces file. If what is really in your interfaces file is as below, then it should work for wep.
Code:
allow-hotplug wlan0
iface wlan0 inet dhcp
wireless_essid TEST
wireless_key s:password

I'm pretty sure that what I posted is correct. There must be some other problem.

From your original post it seems that you are able to use some gui tool to get your wireless working. If so can you please post the output of the following for two cases
Code:
sudo iwconfig
1. When the wireless is working: after bring it up with the gui
2. When it is not working: just after failing to bring it up on the command line.


Cheers,

Evo2.

Last edited by shogun1234; 12-05-2009 at 06:59 PM.
 
Old 12-06-2009, 02:35 AM   #22
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
To help you I need you to follow instructions.
From my last post:

Quote:
From your original post it seems that you are able to use some gui tool to get your wireless working. If so can you please post the output of the following for two cases
Code:

Code:
sudo iwconfig
1. When the wireless is working: after bring it up with the gui
2. When it is not working: just after failing to bring it up on the command line.
It seems you did one of the above, but not both. I need to compare the output in the two situations. It is also important that you run the command as root otherwise I will not be able to see it the key was set properly.

Quote:
The interfaces configuration
Code:
Code:
allow-hotplug wlan0
iface wlan0 inet dhcp
wireless_essid TEST
wireless_key s:password

auto wlan0
Please remove the line with "auto wlan0"

Evo2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting PC to Wireless Network cochetopa Linux - Newbie 3 12-28-2008 11:37 AM
connecting to wireless network gibney Linux - Newbie 1 06-18-2007 05:00 AM
Connecting to Wireless Network Zephryos Linux - Software 3 01-28-2006 06:45 PM
Connecting via the command line jawq Linux - Newbie 2 06-16-2005 10:44 AM
Connecting to a wireless network death_au Linux - Newbie 3 03-06-2005 07:38 AM


All times are GMT -5. The time now is 04:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration