LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-02-2005, 06:21 PM   #1
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Rep: Reputation: 15
Connected to Internet w/wvdial but ppp fails to 'negotiate'


I am making connection to my ISP using wvdial but ppp says: "unable to negotiate" and exits with code (10)

after ppp gets a prompt it says "Dont know what to do, starting ppp and hoping for the best"

I am told that ppp should make a file named: /etc/resolv.conf and that I can edit that file. However, I do not have a file named resolv.conf in the /etc/ directory

Is it that I haven't configured ppp correctly??

If not, what do I do to configure it in order for it to produce the file: /etc/resolv.conf?
 
Old 02-02-2005, 06:27 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,536

Rep: Reputation: 178Reputation: 178
'after ppp gets a prompt it says "Dont know what to do, starting ppp and hoping for the best"'

wvdial has two methods of negotiating with the ISP. You should try both methods. You set the method by specifying Stupid Mode in /etc/wvdial.conf

Stupid Mode = 1
Stupid Mode = 0

"Dont know what to do, starting ppp and hoping for the best"
This is probably the last in a series of error messages. If playing with Stupid Mode has no effect on the problem then please also post the several error messages ahead of this one.

"I am told that ppp should make a file named: /etc/resolv.conf and that I can edit that file. However, I do not have a file named resolv.conf in the /etc/ directory"

You have not got far enough in the signon protocol to have run into problems with /etc/resolv.conf yet.


-------------------------
Steve Stites

Last edited by jailbait; 02-02-2005 at 06:31 PM.
 
Old 02-02-2005, 07:02 PM   #3
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Original Poster
Rep: Reputation: 15
Here's what it reports:

--> Carrier detected. Waiting for prompt
[1c] [1c] [1e][1e] `[1c]~[0e] `

--> Don't know what to do! Starting pppd and hoping for the best.
--> Starting ppd at Wed date/time
--> pid of ppd: number
--> Disconnecting at Wed date/time + 30 seconds
--> The PPP daemon has died. PPP negotiation has failed (exit code = 10)
--> man ppp explains error codes in more detail
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 10)



I assume those are error codes in hex (after the 'Carrier detected' line)

That was all the information I got.
 
Old 02-02-2005, 07:05 PM   #4
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Original Poster
Rep: Reputation: 15
P.S.

There was no line in the wvdial.conf file that had:

Stupid Mode = x

I added one, it didn't seem to make any difference........
 
Old 02-02-2005, 09:54 PM   #5
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,536

Rep: Reputation: 178Reputation: 178
"--> Carrier detected. Waiting for prompt
[1c] [1c] [1e][1e] `[1c]~[0e] `"

I think that wvdial does not understand what it is receiveing and is printing what it received in hex. They are not necessarily error codes. The next thing to lok at are your Hays command strings (Init strings). Could you post your /etc/wvdial.conf with your password xxxx out.


---------------------
Steve Stites
 
Old 02-03-2005, 01:39 AM   #6
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Original Poster
Rep: Reputation: 15
[Dailer Defaults]
Phone = 318-1425
Username = myname
Password = password
New PPPD = yes
Modem = /dev/ttyS0
Baud = 115200
Init1 = ATZ
Init2 = ATQ0 V1 B1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 0 ( I added this line )
Modem Type = Analog Modem

Note: modem is a U.S. Robotics external 56K faxmodem
 
Old 02-03-2005, 10:24 AM   #7
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,536

Rep: Reputation: 178Reputation: 178
Try changing
Init2 = ATQ0 V1 B1 S0=0 &C1 &D2 +FCLASS=0
to
Init2 = ATM0L0

If necessary try ATM0L0 with both Stupid Modes.

-------------------------------
Steve Stites
 
Old 02-03-2005, 10:54 AM   #8
NoobieDoobieDo
Member
 
Registered: Oct 2004
Distribution: Debian 4.0
Posts: 65

Rep: Reputation: 15
Another simple thing :

The modem init command, I noticed linux users ATZ. This is suppose to reset it to factory defaults. However there is also AT&F which supposedly does the same thing. There is some difference between the two but I dont know what it is.

However, on my internal USR Performance Pro if I leave ATZ it will try to negotiate all day long, but if I use AT&F I connect every time.

Just a thought
 
Old 02-03-2005, 03:27 PM   #9
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Original Poster
Rep: Reputation: 15
Setting the line I added:

Stupid Mode = 1

Causes ppp to initate without saying "I don't what to do etc"

However, the ppp daemon still exits 30 seconds later with a code 10

When I call my ISP, there is no record of my connection at the time I make the attempt.

I was told that there is a file: resolv.conf in the /etc/ directory which contained all the DNS info - I do not have this file, the "man resolv" also says I should have this file.

How do I generate the <resolv.conf> file in the /etc/ directory????

BTW - thanks for all the inputs I've received so far
 
Old 02-03-2005, 03:46 PM   #10
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Original Poster
Rep: Reputation: 15
P.S.

I checked my <syslog> and in there it states:

Connect: ppp0 <--> /dev/ttyS0
LCP: timeout sending Config-Requests

So, it looks to me that ppp is communcating with the outside world but nowhere have I been required to give the domain-name of my ISP or the TCP/IP numbers

I suspect this is the stuff that goes in the <resolv.conf> file - of which there ain't
 
Old 02-03-2005, 04:23 PM   #11
Guvvy
Member
 
Registered: Feb 2002
Location: Central Oregon
Distribution: Debian 3.0 - "Woody"
Posts: 39

Original Poster
Rep: Reputation: 15
P.P.S.

What I failed to report from the syslog and which would appear significant is at the identical time that the report :

Connect: ppp0 (etc)

2 or 3 lines previous (identical time) :

modprobe: modprobe: Can't locate module <char-major-108>

I did a search and couldn't find anything closely resembling it.

Went to Debian and searched their packages for anything containing "char-maj" - which turned up nothing.

Plenty of packages containing the word "char" (over 4000) - but which one?????

Possibly, my dial-out program needs this module with which to communicate with the ISP ?????

 
Old 02-09-2005, 10:14 AM   #12
smsanders
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
wvdial connect problems

I am suffering the same exact negotiation failure on a debian system "knoppmyth". The root of the problem for me seems to be that the wvdial negotion never sees the "login:" prompt to complete the negotiation. If I use minicom to dial my ISP I discovered that the ISP does not send the login prompt immediatly after the "CONNECT" message. If I enter a <CR> right after the modem gives the CONNECT message then the ISP sends the login prompt immediatly. If I make no response after the CONNECT message then the ISP waits for about 15 seconds or so and then sends the login prompt.

What appears to be happening in my case is that after wvdial gets the CONNECT message it times out waiting for the login prompt and trys ppp, but of course it then never gets the login prompt and the ppp link can never complete!

Does anyone know how to resolve this? It seems to me either of two things could resolve this:
1) somehow get wvdial to send a <CR> following the connect message so that the login prompt will be sent earlier.

or
2) increase the timeout value used by wvdial to wait for the login prompt before giving up and going to ppp

I don't know how to do either of these. Can anybody out there help?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ppp-go | Wvdial roguefoxx Slackware 1 09-08-2003 02:17 AM
who is connected via ppp to linux server itayemi Linux - Networking 0 09-05-2003 05:38 AM
PPP Stats, Connected time gboutwel Linux - Networking 3 07-22-2002 03:12 AM
wvdial and ppp tge Linux - Networking 3 04-17-2002 09:13 PM
wvdial/ppp settings for cellphone modem cybern8 Linux - General 0 10-02-2001 09:13 PM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration