LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-28-2012, 10:30 AM   #1
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Rep: Reputation: Disabled
Connect to Linux from Windows with Full Rights


Salvete! This is my first post here, and in fact, my first post in any Linux forum! I am a network administrator, and have inherited a Linux server which hosts Asterisk. I have a cli set up so I can do a putty session from my windows xp workstation. However, I need to get full access to the file system on the Linux machine from my windows workstation. I have samba set up and have entered my user account there. Now, when I map the drive on my windows computer, I am prompted for a password, which I give, and so the drive is mapped to the linux machine like I want. However, I cannot browse the root directory - Access Denied. Please help! I have full rights in the root account, but can't seem to give full rights to my own user account! If anyone could assist me, I have the cli open here and can type anything I want there.
 
Old 03-28-2012, 11:01 AM   #2
notihnio
LQ Newbie
 
Registered: Oct 2009
Location: Greece
Distribution: slackware-current
Posts: 23

Rep: Reputation: 5
Hello there!

What do you mean about the "root directory"? Do you mean the "/root" or the "/". I think that not only is there problem with rights, but also with ownership. Both "/root" , "/" are owned by root. So if you mean the "/root" directory you have to type as root "chmod 755 /root" to have read access. If you mean the "/" directory DO NOT TRY AT ALL TO CHANGE ANY RIGHT if you are not exactly what you are doing!!
 
Old 03-28-2012, 11:02 AM   #3
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
When I try to map the network drive, I get prompted for my password, but the login box won't take accept it. Caps lock isn't on, and I use the server's domain: myserver\mylogin but it just won't take. What do I try?
 
Old 03-28-2012, 11:06 AM   #4
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Yes, I do mean the root (/) directory. My user account is a member of the "root" group. Right now, I am using the "root" user through the cli. If I do a ls -l in the root directory, I see that all the directories there are owned by the root user, and also the root group.

Last edited by brother.gabriel; 03-28-2012 at 11:10 AM.
 
Old 03-28-2012, 11:10 AM   #5
notihnio
LQ Newbie
 
Registered: Oct 2009
Location: Greece
Distribution: slackware-current
Posts: 23

Rep: Reputation: 5
On your smb.conf did you try path = /
 
Old 03-28-2012, 11:18 AM   #6
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
In smb.conf, I see an entry for [root] with path=/, but it says valid users = None. Do I change this line? Actually, I am using the joe editor, and it says the file is read-only.

Last edited by brother.gabriel; 03-28-2012 at 11:19 AM.
 
Old 03-28-2012, 11:23 AM   #7
notihnio
LQ Newbie
 
Registered: Oct 2009
Location: Greece
Distribution: slackware-current
Posts: 23

Rep: Reputation: 5
try valid users=@root all root group
 
1 members found this post helpful.
Old 03-28-2012, 11:31 AM   #8
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Okay, but how do I get the file out of read-only? (I am posting in the "newbies" group for a good reason, you know).
 
Old 03-28-2012, 11:42 AM   #9
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Okay, I got it. I used su and joe-edited the file.
 
Old 03-28-2012, 11:46 AM   #10
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hey! It works! That was just the trick I needed! Thank you!
 
Old 03-28-2012, 05:38 PM   #11
notihnio
LQ Newbie
 
Registered: Oct 2009
Location: Greece
Distribution: slackware-current
Posts: 23

Rep: Reputation: 5
You are welcome
 
Old 05-20-2012, 09:19 PM   #12
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Hello! I had to reinstall the OS, and am back to the same problem.

I have added your former suggestions:
Quote:
On your smb.conf did you try path = /
Quote:
try valid users=@root all root group
I can confirm that samba is running, nmb is running, network is running, and the firewall is open.
Everything is yummed and the machine has been restarted.

Now, this may be a clue - if I open the "Network", I get a messagebox saying: "Unable to mount location - Failed to retrieve share list from server"
The computer receives its ipaddress via dhcp, and it *does* recieve its correct ipaddress.

Also, I tried to telnet from my windows computer to ports 139 and 445, but "Could not open connection to the host" on either port.

Likewise, if I try to find the computer from my windows computer, the path is not to be found - although I *am* able to ping the machine.
What can I do?

Last edited by brother.gabriel; 05-20-2012 at 10:33 PM. Reason: added detail about telnet
 
Old 05-21-2012, 11:16 AM   #13
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,028

Rep: Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845Reputation: 845
firewall rules are perhaps blocking that port (in fedora its called system-config-firewall) ?
just for the shiggles, can you post your chkconfig output here.

Last edited by schneidz; 05-21-2012 at 11:30 AM.
 
Old 05-21-2012, 11:21 AM   #14
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Not if I have run this command, no?

Code:
iptables -A INPUT -s 192.168.0.0/255.255.255.0 -j ACCEPT
 
Old 05-21-2012, 11:32 AM   #15
brother.gabriel
LQ Newbie
 
Registered: Mar 2012
Location: Kansas City
Distribution: CentOS 6.2
Posts: 27

Original Poster
Rep: Reputation: Disabled
Oh, well, maybe that *was* the problem. I disabled the firewall completely and it worked...

Quote:
service iptables stop
Now I can browse the folders okay, but I am denied access to edit samba.conf. How can I have access? I have added my useraccount to the root group, and here is my entry in smb.conf:

Quote:
[root]
comment = Root Directory
path = /
valid users = @root all root group
invalid users = None
writeable = yes
browseable = yes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give full admin rights to the new user chethankp Linux - Newbie 3 07-15-2011 05:26 PM
[SOLVED] Program to full remote desktop from windows to linux? golmschenk Linux - Software 2 04-06-2010 05:43 PM
LINUX SAMBA SERVER - Temporary domain admin rights for network windows client user. jcdole Linux - Server 0 01-07-2008 03:44 PM
group have full rights on partition sl4ckw4re Slackware 1 07-20-2006 06:41 PM
Samba: can't connect to my local linux machine but can connect to windows. Royle Linux - Networking 3 01-18-2005 06:32 PM


All times are GMT -5. The time now is 02:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration