LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-31-2009, 08:24 AM   #1
Sapfeer
LQ Newbie
 
Registered: Dec 2009
Posts: 12

Rep: Reputation: 0
conky doesn't start at login


I have ~/.config/autostart/conky.desktop file in my home dir. Here is it:
Code:
[Desktop Entry]
Encoding=UTF-8
Version=1.0
Name=conky
Type=Application
Exec=/usr/bin/conky -d
X-GNOME-Autostart-enabled=true
but conky doesn't start sometimes... Moreover, it just starts sometimes, mostly not... What is the matter?.. I can't find out anything...
 
Old 12-31-2009, 08:26 AM   #2
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Did you add that entry via startup applications?
 
Old 12-31-2009, 08:29 AM   #3
Sapfeer
LQ Newbie
 
Registered: Dec 2009
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ~sHyLoCk~ View Post
Did you add that entry via startup applications?
No, I added that entry manually, in terminal session. It is not the first and not the last entry, I added manually, but others start without any problems...
 
Old 12-31-2009, 08:42 AM   #4
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
See if just adding a conky launcher script at that same location works. Like:

Quote:
#!/bin/bash
conky -d &
chmod +x script

And put it there and see if it works. It's difficult to tell without using gnome.
 
Old 12-31-2009, 10:06 AM   #5
Sapfeer
LQ Newbie
 
Registered: Dec 2009
Posts: 12

Original Poster
Rep: Reputation: 0
~sHyLoCk~
It didn't help. I put such script in ~/.config/autostart, restart gnome several times, but conky started just about two or three times...
 
Old 12-31-2009, 10:12 AM   #6
~sHyLoCk~
Senior Member
 
Registered: Jul 2008
Location: /dev/null
Posts: 1,173
Blog Entries: 12

Rep: Reputation: 129Reputation: 129
Ok try without the "-d", just simply "conky"
 
Old 12-31-2009, 12:05 PM   #7
Sapfeer
LQ Newbie
 
Registered: Dec 2009
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ~sHyLoCk~ View Post
Ok try without the "-d", just simply "conky"
It has no effect... I've rebooted twice, but conky didn't start at all..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conky question: passing conky-variable to shell-script zlin50 Linux - Software 2 12-29-2012 07:47 PM
how to disable "last login log" & disable "last login message" when start login. hocheetiong Linux - Newbie 4 02-08-2011 06:35 AM
[SOLVED] How can I get conky start automatically when I start fvwm? ggyyree Linux - Newbie 10 11-04-2009 10:51 AM
Conky on Suse 10.0 - *** buffer overflow detected *** conky terminated Slidex Linux - Software 1 03-17-2006 12:50 PM
Can't login/start KDE-3.1 satimis Debian 4 01-14-2004 05:12 AM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration