LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-21-2009, 03:06 AM   #1
noiz354
LQ Newbie
 
Registered: Feb 2009
Posts: 18

Rep: Reputation: 0
Smile confusing in installing KDE


hello again
i cant install kde by using this command
Quote:
yum -y groupinstall 'KDE'
it gives error like this
Quote:
.........
kdebase-workspace-4.1.0-8.fc9.i386 from updates-testing has depsolving problems
--> Missing Dependency: libcaptury.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
tkinter-2.5.1-25.fc9.i386 from fedora has depsolving problems
--> Missing Dependency: python = 2.5.1-25.fc9 is needed by package tkinter-2.5.1-25.fc9.i386 (fedora)
kdebase-workspace-4.1.0-8.fc9.i386 from updates-testing has depsolving problems
--> Missing Dependency: libcapseo.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
kdebase-workspace-4.1.0-8.fc9.i386 from updates-testing has depsolving problems
--> Missing Dependency: libcapseo.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
avahi-qt3-0.6.22-10.fc9.i386 from fedora has depsolving problems
--> Missing Dependency: avahi = 0.6.22-10.fc9 is needed by package avahi-qt3-0.6.22-10.fc9.i386 (fedora)
ktorrent-3.1.6-4.fc9.i386 from updates-testing-newkey has depsolving problems
--> Missing Dependency: kdelibs4 >= 4.2.00 is needed by package ktorrent-3.1.6-4.fc9.i386 (updates-testing-newkey)
poppler-qt4-0.8.1-2.fc9.i386 from updates-testing has depsolving problems
--> Missing Dependency: poppler = 0.8.1-2.fc9 is needed by package poppler-qt4-0.8.1-2.fc9.i386 (updates-testing)
xine-lib-pulseaudio-1.1.12-2.fc9.i386 from fedora has depsolving problems
--> Missing Dependency: xine-lib = 1.1.12-2.fc9 is needed by package xine-lib-pulseaudio-1.1.12-2.fc9.i386 (fedora)
kdebase-workspace-4.1.0-8.fc9.i386 from updates-testing has depsolving problems
--> Missing Dependency: libcaptury.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
Error: Missing Dependency: kdelibs4 >= 4.2.00 is needed by package ktorrent-3.1.6-4.fc9.i386 (updates-testing-newkey)
Error: Missing Dependency: python = 2.5.1-25.fc9 is needed by package tkinter-2.5.1-25.fc9.i386 (fedora)
Error: Missing Dependency: libcapseo.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
Error: Missing Dependency: avahi = 0.6.22-10.fc9 is needed by package avahi-qt3-0.6.22-10.fc9.i386 (fedora)
Error: Missing Dependency: libcaptury.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
Error: Missing Dependency: xine-lib = 1.1.12-2.fc9 is needed by package xine-lib-pulseaudio-1.1.12-2.fc9.i386 (fedora)
Error: Missing Dependency: poppler = 0.8.1-2.fc9 is needed by package poppler-qt4-0.8.1-2.fc9.i386 (updates-testing)
 
Old 02-21-2009, 05:38 AM   #2
Udi
Member
 
Registered: Jan 2009
Posts: 165

Rep: Reputation: 44
Try running "yum update" before trying "yum groupinstall KDE" again. It usually resolves dependency problems that result from the yum indexes being out of sync with the repository. Be sure you are running as root.
 
Old 02-21-2009, 06:19 AM   #3
noiz354
LQ Newbie
 
Registered: Feb 2009
Posts: 18

Original Poster
Rep: Reputation: 0
Smile

Quote:
Originally Posted by Udi View Post
Try running "yum update" before trying "yum groupinstall KDE" again. It usually resolves dependency problems that result from the yum indexes being out of sync with the repository. Be sure you are running as root.
i think i have update yum
look at this, thanx before
Quote:
[root@localhost ~]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
No Packages marked for Update
 
Old 02-21-2009, 03:38 PM   #4
anurag_bhd
Member
 
Registered: Nov 2006
Location: Jalandhar, India
Distribution: openSuSE 11.0, Granular 1.0, Mandriva One 2009, Fedora 11
Posts: 60

Rep: Reputation: 18
noiz354,

"yum update" is different from "yum upgrade". Doing a "yum update" updates the list of packages available in the Fedora's repository to the latest one.
 
Old 02-22-2009, 02:18 AM   #5
axelfc
Member
 
Registered: Jan 2006
Distribution: ArchLinux
Posts: 175

Rep: Reputation: 34
Why do you have the testing repository enabled? This is what causes your problem I think.
 
Old 02-22-2009, 04:58 AM   #6
noiz354
LQ Newbie
 
Registered: Feb 2009
Posts: 18

Original Poster
Rep: Reputation: 0
how to remove
them
i don't know how to remove these
Quote:
[norman@localhost ~]$ su -
Password:
[root@localhost ~]# cd /etc/yum.repos.d/
[root@localhost yum.repos.d]# ls
adobe-linux-i386.repo fedora-updates.repo
fedora-rawhide.repo fedora-updates-testing-newkey.repo
fedora.repo fedora-updates-testing.repo
fedora-updates-newkey.repo norman.repo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I am confusing ram_rajavarapu Linux - Enterprise 3 11-12-2008 06:54 PM
Installing KDE Help files in KDE Help Center: 2008.1 Mandriva One smiley_lauf Mandriva 1 05-05-2008 07:02 AM
this is so confusing!! theguitarness Linux - Newbie 5 03-07-2006 10:53 PM
help, installing software in linux is confusing dgaultiere Linux - Software 7 03-01-2006 07:38 PM
so confusing c12ayon Programming 5 10-26-2003 11:52 PM


All times are GMT -5. The time now is 02:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration