LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-22-2012, 05:06 PM   #1
rtz
Member
 
Registered: Mar 2012
Posts: 39

Rep: Reputation: Disabled
configuring ubuntu 10..04 for text based login


how do i configure ubuntu 10.04 for text based login and then logging into graphical mode.i tried configuring the /etc/default/grub file making changes in the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text" but this didn't worked out for me.After updating the grub when i rebooted the system i am getting the same normal graphical screen.
 
Old 10-22-2012, 05:52 PM   #2
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.5, Centos 5.10
Posts: 16,280

Rep: Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032Reputation: 2032
Have a look at /etc/inittab, specifically
Code:
id:3:initdefault:
3 = cli, 5 = GUI on RHEL/Centos. Ubuntu is probably(?) the same, but check the docs.
 
Old 10-22-2012, 06:53 PM   #3
rtz
Member
 
Registered: Mar 2012
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrism01 View Post
Have a look at /etc/inittab, specifically
Code:
id:3:initdefault:
3 = cli, 5 = GUI on RHEL/Centos. Ubuntu is probably(?) the same, but check the docs.
there is no inittab file in the /etc directory
 
Old 10-22-2012, 07:31 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Ubuntu uses runlevel 2 by default and runlevels 2-5 are the same, so this approach won't work anyways.
The correct way to achieve what you want is to either uninstall the display manager (should be GDM on 10.04) or to disable its startup in runlevel 2.
An easy way to disable it is using chkconfig have a look here how to use it: http://superuser.com/questions/26604...n-ubuntu-10-10
 
Old 10-23-2012, 05:50 AM   #5
rtz
Member
 
Registered: Mar 2012
Posts: 39

Original Poster
Rep: Reputation: Disabled
Wink

Quote:
Originally Posted by TobiSGD View Post
Ubuntu uses runlevel 2 by default and runlevels 2-5 are the same, so this approach won't work anyways.
The correct way to achieve what you want is to either uninstall the display manager (should be GDM on 10.04) or to disable its startup in runlevel 2.
An easy way to disable it is using chkconfig have a look here how to use it: http://superuser.com/questions/26604...n-ubuntu-10-10
Thanx for the info.I tried to do it by modifying the grub file moreover even disabling the GDM but things didn't worked for me. Finally, upgrading from grub to grub2 to solved my problem which by default gives you the text based login instead of normal GUI based.for switching from text based login prompt to normal GUI i first had to login with my user account/password and then starting the GDM form the /etc/init.d
 
Old 10-23-2012, 06:21 AM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
It should also work to go directly to your default desktop environment with
Code:
startx
 
Old 10-24-2012, 06:30 AM   #7
rtz
Member
 
Registered: Mar 2012
Posts: 39

Original Poster
Rep: Reputation: Disabled
Smile

thanx!!that was even easier.
 
Old 10-24-2012, 07:08 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
It seems that your issue has been solved. If that's the case, please mark this thread as solved. This will make it easier for other members with the same problem to find this solution. You can do that with the thread tools above your initial post.
 
  


Reply

Tags
login, text


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install Ubuntu via text based method? joao2000 Linux - Newbie 2 11-29-2011 08:51 AM
Run drivers and login automatically in text-based mode! kyawkyaw Linux - Software 3 09-01-2007 03:30 AM
Text based Ubuntu install williamssm Linux - Newbie 3 01-26-2006 04:46 PM
RH Linux 8 pico ; text based login Pillay Linux - Newbie 2 11-02-2003 12:31 PM
Text based login failed but no errors Duukkis Linux - Software 16 08-24-2003 10:29 AM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration