LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-18-2009, 06:32 PM   #1
eeebuntu
LQ Newbie
 
Registered: May 2009
Posts: 3

Rep: Reputation: 0
Configuring LAN connection in Ubuntu (NBR)


I am using the Asus Eee PC (904HA) with Ubuntu 8.10 and Windows XP. I reside in India and have a MTNL broadband connection. I was able to manually set the DNS in XP but have not been able to do so in Ubuntu. I've tried editing the Auto eth0 connection (through Network Connections). Under the IPv4 Settings tab, the Automatic (DHCP) method does not allow me to alter the DNS Servers. I am not aware of my DHCP Client ID. In Windows, the IP is detected automatically. My netmask is 255.255.255.0 and the default gateway and DHCP server is 192.168.1.1.

I have been struggling to make this work since a long time. Any help would be much appreciated.
 
Old 05-18-2009, 11:56 PM   #2
tuxtroll
LQ Newbie
 
Registered: May 2009
Posts: 11
Blog Entries: 1

Rep: Reputation: 0
this problem is strange but you can make this work by *NOT* using DHCP. configure a static ip on ubuntu 192.168.1.xxx and configure DNS and default gateway as provided by ISP
 
Old 05-19-2009, 12:21 AM   #3
mwkemo
Member
 
Registered: May 2009
Location: Croatia
Distribution: Debian
Posts: 31

Rep: Reputation: 16
Hey,

you can try to manually add the lines in the configuration files. For DHCP to work on interface you need to open /etc/network/interfaces file and if your interface is eth0 then it should look like this:

Code:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp
DNS records are in /etc/resolv.conf file. If you know IP of your DNS server you can manualy add it to this file. For example:

Code:
nameserver 192.168.1.1
nameserver 192.168.1.2
I have two DNS servers at my home, that's why there are two IP addresses listed. Just change ip address to your DNS server.

After all changes are done you need to restart the network with:

Code:
sudo /etc/init.d/networking restart
Hope it helps
 
Old 05-19-2009, 12:21 AM   #4
eeebuntu
LQ Newbie
 
Registered: May 2009
Posts: 3

Original Poster
Rep: Reputation: 0
How do I do what you recommend?
I tried using the Manual option and entering the IP, Default Gateway and DNS. This did not work.
 
Old 05-19-2009, 12:33 AM   #5
eeebuntu
LQ Newbie
 
Registered: May 2009
Posts: 3

Original Poster
Rep: Reputation: 0
mwkemo,

Thank you very much for responding. I tried doing what you suggested in the network edit window. I'm not comfortable with the terminal.

Still not working.

Any other ideas?
 
Old 05-19-2009, 12:48 AM   #6
mwkemo
Member
 
Registered: May 2009
Location: Croatia
Distribution: Debian
Posts: 31

Rep: Reputation: 16
Hmmm, dont know if you can edit this files in GUI mode. This files are root protected and as far as I know the Ubuntu GUI dosn't allow you to change this files. You can try to open GUI text editor from terminal with sudo infront.

Dont know the name of GUI text editor. Find out the name of GUI editor and try to open it with terminal like this:

sudo nameoftexteditor

after then its just like working with notepad. Open files mentioned above and edit this files. Save files. After all changes are done all you need to do is this in your terminal window:

sudo /etc/init.d/networking restart

hit Enter. If it ask for password, give him your user password and hit Enter again. You can skip this and just reboot your Asus back to Ubuntu:-)

If it dosn't work you can try to add static IP adreses and gateways as tuxtroll noted above.

Oh yeah, write ifconfig in terminal and c/p the output.

That's it.

Last edited by mwkemo; 05-19-2009 at 12:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No wired networking on my eee 1000 using Eeebuntu 2.0 NBR frznchckn Linux - Laptop and Netbook 4 01-11-2009 04:40 PM
How to configure LAN and Dial up Connection in Ubuntu 8.04 LTS sethawn Linux - Newbie 14 08-22-2008 03:16 AM
configuring Mandrake 9.2 on home LAN with ADSL connection AndyD Linux - Networking 18 01-12-2006 10:37 AM
configuring internet connection thru lan jared78 Linux - Networking 5 05-08-2005 10:51 AM


All times are GMT -5. The time now is 05:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration