LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-12-2004, 03:18 PM   #1
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Rep: Reputation: 0
configuring grub


i installed phlak to one of my hard drives but it doenst show up in grub. how do i edit grub for phlak to showup? im using red hat 9. is there a program or a file i have to edit?
 
Old 05-12-2004, 03:22 PM   #2
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
/boot/grub/grub.conf

You should copy the lines you have and apply changes to them. Before doing this do a backup of the grub.conf file!!!
 
Old 05-12-2004, 06:53 PM   #3
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 0
this is the line i have for phlak, i boot up and it doesnt work.

title PHLAK
root (hda1,0)
kernel /boot/vmlinuz-2.4.21-xfs ro root=LABEL=/

and this is the contents of my boot folder on the phlak drive

config-2.4.21
vmlinuz(shortcut to next item)
vmlinuz-2.4.21-xfs

so what do i need to put in the line in order to boot into phlak.
 
Old 05-12-2004, 07:00 PM   #4
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
What happende to initrd? In RH9 you must have a line saying initrd ..... in your grub.

Just try to make the PHLAK lines identical to REDHAT 9's and make the proper changes. That should do the trick.The one you have now is good. Just add the initrd line. I bet it all stops at Kernel panic: pass init to kernel (or something with init in it )
 
Old 05-12-2004, 07:19 PM   #5
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
I don't think initrd is mandatory. It depends on how the kernel was compiled. If it boots as is, than there is no problem.
 
Old 05-12-2004, 07:29 PM   #6
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 0
im getting the error "error parsing line (hda1,0)" or soemthign similar to that. anyone know?
 
Old 05-12-2004, 07:33 PM   #7
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
(hda1,0) looks wrong. It should probably be (hd1,0).
 
Old 05-12-2004, 07:35 PM   #8
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 0
thats what the red hat line uses. should i try it anyway?
 
Old 05-12-2004, 07:40 PM   #9
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
Maybe it's different, who knows. Doesn't hurt to try, though. In grub hd0,1 means hda1. That's the naming scheme.
 
Old 05-12-2004, 08:01 PM   #10
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 0
this is my line for phlak now

title PHLAK
root (hd0,0)
kernel /boot/vmlinuz-2.4.21-xfs ro root=LABEL=/

it starts to boot and detects devices then gives me this

VFS: Cannot open root device "Label=/" or 00:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 00:00
 
Old 05-12-2004, 08:47 PM   #11
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
You should specify your root partition there. I'm not sure what the 'LABEL' is for.
 
Old 05-12-2004, 08:50 PM   #12
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 0
what is the root partition. i have 2 hard drives, hd0 and hd1, do i put one of them there. hd1 has red hat 9 on it and hd0 is phlack
 
Old 05-12-2004, 08:53 PM   #13
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
According to the rest of your config the root partition for phlak is (hd0,0). However, in the kernel parameters you should use the Linux naming, so (hd0,0) would be hda1. Try:
Code:
kernel /boot/vmlinuz-2.4.21-xfs ro root=/dev/hda1
 
Old 05-12-2004, 09:43 PM   #14
fosh1zzl3
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 0
thanks alot. it works now.
 
Old 05-12-2004, 11:10 PM   #15
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
You're welcome, buddy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
configuring grub???!!! monkey_eater Linux - Newbie 2 09-27-2005 09:17 PM
Configuring Grub blueplanet200 Linux - Newbie 2 04-11-2004 10:44 PM
Configuring Grub arimus25 Linux - Software 2 03-04-2004 04:46 PM
Configuring Grub Leviathan Mandriva 5 10-17-2003 04:57 AM
configuring grub emjay Linux - Newbie 1 10-16-2002 09:21 AM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration