LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2008, 09:01 AM   #1
keith82
LQ Newbie
 
Registered: Jan 2008
Posts: 3
Blog Entries: 1

Rep: Reputation: 0
Configure wireless on fedora 8


Hi all,

I have tryed several times to configure the wireless internet but always encounter the error msg "Error for wireless request set mode 8b06"
Can anyone pls advise me on this error or give a step by step configuration.
 
Old 01-21-2008, 09:38 AM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
It would be helpful if you could provide a more complete description of your problem:

1) A complete description of your hardware (e.g.: Computer manufacture, model, memory, disk rives, etc.)
2) A description of your wireless hardware (Manufacture, type, etc.) If you're using a laptop, and the wireless is "built in," a description of the chipset used by the wireless card. Look in the output of the /sbin/lspci command in a terminal window. You should see something like this:
Code:
$ /sbin/lspci | grep -i ether
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
3) The driver you're using for the wireless card, and how you installed it.
4) The settings you made in the system-config-network command.
5) Anything else you can think of that would help us understand your problem.

Now, specifically, the error message your seeing suggests to me that you've loaded an incorrect driver for your wireless card so the software is attempting to use hardware control codes which are not recognized by your specific hardware.

<edit>
If you're using KDE, most of your system information can be found by clicking on the KInfoCenter application in the System menu. I think there may be a similar application in GNOME, but I can't remember it right now.
</edit>

Last edited by PTrenholme; 01-21-2008 at 10:17 AM.
 
Old 01-22-2008, 06:00 AM   #3
keith82
LQ Newbie
 
Registered: Jan 2008
Posts: 3
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Hi All,

as appreciate your help in troubleshooting my problem.

My current laptop is a asus a8jn laptop processor T5600 the built in is wireless card is intel wireless 3945AGB.
I have not installed any drivers to for the card but have used when i enter the fedora network manager, it detected my wireless card thus i installed the default driver from the os.

I am also unable to activate my wireless card to detect any wireless signal, but fortunately when i use a direct cable connection ethernet i am able to acess the internet.

i believe i have might not installed the correct drivers, and still unfamiliar with the unix commands
could you guide me on this.
 
Old 01-23-2008, 10:43 AM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
keith82, I hadn't replied before this in the hope that someone more knowledgeable than I would respond. I know little about the Intel wireless chisets.

However, a forum search (the clickie at the top of the screen) found this thread which might help. If it doesn't, try starting a new thread in the "Wireless" forum.
 
Old 01-23-2008, 01:15 PM   #5
bbfuller
Member
 
Registered: Dec 2007
Location: UK
Distribution: Fedora, CentOS, Sabayon
Posts: 209

Rep: Reputation: 35
Hello keith82

I'm using an Intel 3945abg on Fedora 8 and it set up without any trouble, in fact all that was needed for Fedora was installed "out of the box", no need for any other drivers or software.

Usually, when you set up the 3945 in the recommended way you don't get the opportunity to see any error messages (and they may well not stop your card working in any case) so it may be that you are falling foul of Fedora having more than one way of controlling Network Cards.

First thing I think is to get your Fedora 8 installation up to date using your wired connection. Wireless control was not a complete success when 8 was released and there have been several updates since. In fact, I installed the most recent today.

Firstly, you would be best advised not to try to control the card through the Network tool on the System - Administration menu.

If you look in it though, highlight your wireless card, click "Edit", make sure that "Activate when Computer starts" is not marked and that "Controlled by NetworkManager is".

If you are running Gnome and installed from the DVD you should have the NetworkManager icon in the notification area on the top toolbar. Do you see a list of potential wireless access points in there?

If you installed from the live cd or are running KDE as your desktop things are slightly different. Let me know and I'll post details.

Left clicking on the access point of choice should bring up a dialogue asking for your wireless key, do you see it?

A word of warning, Fedora doesn't like access points where the name is not broadcast and it is reputed to have trouble with anything higher than plain WPA.

Try the above and post back results and we'll think again.
 
Old 01-25-2008, 09:26 AM   #6
keith82
LQ Newbie
 
Registered: Jan 2008
Posts: 3
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Hi BBfuller

I don understand this part of your sentence

"If you are running Gnome and installed from the DVD you should have the NetworkManager icon in the notification area on the top toolbar. Do you see a list of potential wireless access points in there?"

what is Gnome i installed fedora via DVD and did not find network manager icon on the taskbar. till now i am unable to screen any acess points from any program in fedora.

pls Help me!!
 
Old 01-25-2008, 09:58 AM   #7
bbfuller
Member
 
Registered: Dec 2007
Location: UK
Distribution: Fedora, CentOS, Sabayon
Posts: 209

Rep: Reputation: 35
Hello keith82

In Linux there are two graphical windows systems that provide what in Windows you call the desktop.

In Windows you have one taskbar at the bottom of the screen.

In Linux different distributions go with one or the other of the main desktops as their first choice.

For Fedora, the first choice is Gnome and then you have two bars on the screen, one at the top and one at the bottom.

You can though specify the other Desktop which is KDE and that looks a bit more like Windows with just the one bar at the bottom.

Let me know which you have got as it saves having to describe things in two different ways to cover all the eventualities.
 
Old 01-28-2008, 06:13 AM   #8
infinity99
LQ Newbie
 
Registered: Dec 2007
Distribution: Fedora Core 8
Posts: 7

Rep: Reputation: 0
3945ABG works for me now.

I had been trying to get my wireless working for quite some time. Glad, it works now.

Check out the intel driver page:
Here

Try the following:
[taken from INSTALL]

Code:
% ifconfig wlan0 up
% iwconfig wlan0
You should see something like:

Code:
wlan0      unassociated  ESSID:off/any
          Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
          Bit Rate=0 kb/s   Tx-Power=20 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
And now you are ready to go.

First, find your AP:

Code:
% iwlist scan
Configure to use AP using iwconfig:

Code:
% iwconfig wlan0 channel <channel>
	% iwconfig wlan0 key <key>
	% iwconfig wlan0 essid <name>
	% iwconfig wlan0 ap <mac>
 
Old 02-01-2008, 01:14 PM   #9
spiderweed
LQ Newbie
 
Registered: Jan 2008
Posts: 16

Rep: Reputation: 0
Unhappy

hi
i have read so many threads regarding my issue (same as Keith82's)...i have the same problem...

error for wireless request set mode 8b06

i am not able to get network manager to auto detect my ssid...
i have a pc right next to my laptop (with fedora 8) and its online fine...but even if i manually enter my info into network manager, i still do not connect...

i did make one change that was suggested above...uncheck load at startup and have network manager control the connection...still no luck though...

i am a moderate newbie when it comes to linux...i can get my way around and do things but for some reason i'm always having problems getting online....

here is a bit about my setup...might help right?

sony vaio laptop
built in wireless card
fedora 8
dual boot with xp

what else do you need?

and is there any help for me? LOL...

should network manager automatically scan and show me the ssid? and even if i go into the Network setting thing, i can never activate the device....

thanks all...
 
Old 02-01-2008, 01:37 PM   #10
spiderweed
LQ Newbie
 
Registered: Jan 2008
Posts: 16

Rep: Reputation: 0
man
i typed out a huge reply and lost it


i'll start again.

i'm having the exact same problems that keith82 is/was...

i am running fedora 8 dual booted with xp...xp, wireless works flawlessly...

i had network set to load on start up, which, thanks to this post, have fixed and now soley configured through network manager...

no matter what i do it does not detect my ssid, nor does the device activate...

i would be considered a linux newbie, although i've had linux installed over the years on various computers, but never got into the command line type stuff...i stick to what i can do with the gui...and install things via rpms cause i can double click them as opposed to making installs and stuff...

so, i would love some help.

please tell me what you need and how i can get it to you and i'll be more than happy!! thanks....
 
Old 02-01-2008, 02:23 PM   #11
spiderweed
LQ Newbie
 
Registered: Jan 2008
Posts: 16

Rep: Reputation: 0
maybe this info will help.....i found a thread that told me how to do a few things.. lol..



lo no wireless extensions.
wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.



and...


Ethernet controller: Atheros Communications, Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)
 
Old 02-01-2008, 02:38 PM   #12
ak_k80
LQ Newbie
 
Registered: Feb 2008
Location: Bhopal,M.P,India
Distribution: fedora 8
Posts: 16

Rep: Reputation: 0
Wireless configuration

hello,
I am another 2days old baby to Fedora 8/linux, i hv V6000 serie Presario Laptop with Intel Corporation PRO/Wireless 3945ABG Network Connection .... problem being the same that i m unable to connect my wireless n/w.
in N/w manager,wen i goto "CONNECT TO OTHER WIRELESS N/w" and type in the SSID along wid the key....it tries to connect but it again and again returns a window in which it asks the details abt the key...i hv been redoing a number of times with all possibilities but no success...i even tried to install wireless driver of intel for linux as mentioned in the above post,but i am toooo new to understand kernel and all....is there any other way to configure it??
How do i check whether its a driver installation problem or smthing else?

one more thing,wen i enter iwlist scan in terminal window then in wlan0,o/p is RESOURCE TEMPRORILY UNAVAILABLE
 
Old 02-01-2008, 03:25 PM   #13
bbfuller
Member
 
Registered: Dec 2007
Location: UK
Distribution: Fedora, CentOS, Sabayon
Posts: 209

Rep: Reputation: 35
Hello infinity99

That's one way of configuring a wireless card but if that is your wireless access point then you should really consider if it is wise to run it unsecured. If you run it secured then you will find it much more awkward to control from the command line which is where NetworkManager and other utilities come in.

Hello spiderweed

In the main here we are talking about an intel card. Most of the diagnostics work the same, but I haven't got an Atheros card and wouldn't want to advise you.

Hello ak_k80

You don't say which distribution you are running and some of the things I would ask you to check can be Fedora specific. Could you tell me what you are running.

You might also consider posting back the results of the following commands:

Code:
/sbin/iwconfig
should tell you if wireless extensions are being detected and an interface identity for your card.

If you move to a root command prompt by typing:

Code:
su
and giving your root password and then using:

Code:
/sbin/iwlist wlan0 scan
should tell you if the software has control of your card enough to detect wireless access points. Note in that last command, where I have written wlan0 you should substitute it if necessary with the interface identity returned by the first command.

Last edited by bbfuller; 02-01-2008 at 03:28 PM.
 
Old 02-01-2008, 03:52 PM   #14
spiderweed
LQ Newbie
 
Registered: Jan 2008
Posts: 16

Rep: Reputation: 0
would this work for me?



/sbin/iwlist wlan0 scan
 
Old 02-01-2008, 05:32 PM   #15
bbfuller
Member
 
Registered: Dec 2007
Location: UK
Distribution: Fedora, CentOS, Sabayon
Posts: 209

Rep: Reputation: 35
Hello spiderweed

Yes, that is a command line tool and will work in just about and linux that has the wireless parts installed - and I don't know any that don't.

I see from your post #10 that you have already run the command iwconfig and determined that your wireless card is wlan0 so the command will runs as it stands.

Do be aware though that it needs some of roots privileges to run on Fedora, hence the su command should be run first as above. You also haven't specified which distribution you are running and as I said to 'ak_k80' it does make a difference. In Ubuntu for instance I believe you would need to run:

Code:
sudo /sbin/iwlist wlan0 scan
If you want to discuss the output of the command please tell what you are running.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to configure a ZD1211B wireless stick to monitor mode on Wireshark using Fedora 7 Lopes_sma Linux - Software 8 07-03-2007 10:59 AM
help to configure a wireless card in fedora core3 uxan Fedora 1 08-03-2006 06:07 AM
Configure broadcom wireless on fedora core 5 dragoncoder Linux - Software 7 07-14-2006 12:05 AM
source for rpms to configure wireless in fedora core 3 pranith Linux - Wireless Networking 0 11-16-2004 07:34 AM


All times are GMT -5. The time now is 02:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration