LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-05-2010, 11:34 AM   #1
voicu_gabriel
LQ Newbie
 
Registered: May 2010
Posts: 3

Rep: Reputation: 0
configure script problem


Hello,

I'm developing an interface for an already existing project. I would like to add QT libs into the configure script, but I don't know how.
I tried to add this into the configure.ac:

Code:
AC_CHECK_HEADERS(/usr/include/qt4/QtGui/qlabel.h)
 
if test x"$ac_cv_header_usr_include_qt4_QtGui_qlabel_h" != x"yes" ; then
  AC_MSG_ERROR([Missing headers. Please install Qt4-devel.])
fi
then ran "autoconf" and "./configure" and this is the output that I got:
Code:
checking /usr/include/qt4/QtGui/qlabel.h usability... no
checking /usr/include/qt4/QtGui/qlabel.h presence... no
checking for /usr/include/qt4/QtGui/qlabel.h... no
configure: error: Missing headers. Please install Qt4-devel.
The file actually exists.Any help would be really appreciated.

Thank you,

Gabriel
 
Old 05-05-2010, 02:49 PM   #2
rweaver
Senior Member
 
Registered: Dec 2008
Location: Louisville, OH
Distribution: Debian, CentOS, Slackware, RHEL, Gentoo
Posts: 1,833

Rep: Reputation: 164Reputation: 164
Linux is case sensitive, is the case on your directories correct?
 
Old 05-05-2010, 05:41 PM   #3
voicu_gabriel
LQ Newbie
 
Registered: May 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Hello rweaver,

Yes, it's the correct path. I tried all the possible path combinations but I still received the same error.
 
Old 05-06-2010, 03:25 AM   #4
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Is "AC_CHECK_HEADERS" really correct? From a quick look at some autoconf docs it seems, that in *this* case the macro you would want to use is "AC_CHECK_HEADER" (ie no trailing S).

Evo2.

PS. Also, you should not include the full path to the header... the whole point is that the autotools should try to find the header.

Last edited by evo2; 05-06-2010 at 03:28 AM.
 
Old 05-07-2010, 02:18 PM   #5
voicu_gabriel
LQ Newbie
 
Registered: May 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Hello evo2,

Unfortunately, it seems that these are not the problems, because I still receive the same error. But, thank you for your ideas.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
configure script sends bad switches to daughter configure scripts Wells Linux - Software 7 10-10-2008 03:38 PM
Problem in installing CLIsh: Configure script unable to find pthread_create function avinash_ag1985 Linux - Kernel 3 07-22-2008 02:47 PM
problem with "configure" script. sety Linux - Newbie 1 12-20-2006 06:04 PM
Qt and configure script Peterius Linux - Software 0 10-18-2004 12:32 PM
Configure Script?? Phonics3k Linux - Software 12 06-20-2002 10:06 AM


All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration