LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   configure: Requested 'glib-2.0 >= 2.32.0' but version of GLib Uninstalled is 2.29.2 (http://www.linuxquestions.org/questions/linux-newbie-8/configure-requested-glib-2-0-%3D-2-32-0-but-version-of-glib-uninstalled-is-2-29-2-a-4175442396/)

rohanp141@gmail.com 12-21-2012 12:40 AM

configure: Requested 'glib-2.0 >= 2.32.0' but version of GLib Uninstalled is 2.29.2
 
Hi,
I am trying to knock my head from two days to solve this problem .
I have installed Glib 2.32 , which is needed for gstreamer compiling but when I compile Gstreamer getting error :
configure: Requested 'glib-2.0 >= 2.32.0' but version of GLib Uninstalled is 2.29.2
configure: error: This package requires GLib >= 2.32.0 to compile.
configure failed

Note :pkg-config --modversion glib-2.0 shows: 2.34.2

but dont know why I am getting error : glib-2.0 >= 2.32.0' while compilation

Is it not getting new Glib path . I am missing any thing on it?
Please help

gdejonge 12-21-2012 01:03 AM

In most cases, if you want to compile from source, you'll need the development versions of the depended libraries. They normally come with the same name but with -dev or -devel attached to the name.

knudfl 12-21-2012 03:16 AM

Welcome to LQ.

Please try to set the new glib first in the LD_LIBRARY_PATH, like :

export LD_LIBRARY_PATH=/usr/local/lib:/usr/lib:/lib
( Or wherever you installed the "2.32.0".)

But : It may be difficult on some OS to handle two versions.

.

rohanp141@gmail.com 12-21-2012 04:29 AM

In most cases, if you want to compile from source, you'll need the development versions of the depended libraries. They normally come with the same name but with -dev or -devel attached to the name.

I have installed all the depended libraries for Glib .
In fact Glib is build and configured successfully but I think older version of glib is still running hence getting the error : glib-2.0 >= 2.32.0' while compilation
how to update the Glib version so that when i am compiling it should take glib 2.32 and not 2.0

gdejonge 12-21-2012 04:50 AM

To make things clear. Did you install the new glib from a package or did you also build it from source?

rohanp141@gmail.com 12-21-2012 06:12 AM

Quote:

Originally Posted by gdejonge (Post 4854237)
To make things clear. Did you install the new glib from a package or did you also build it from source?

I did install new Glib package
site : http://www.linuxfromscratch.org/blfs...ral/glib2.html

I configured and build glib 2.32.0
Now I am building gstreamer and for that I need Glib version 2.32.0
Already my system had glib 2.0

I am not able to compile Gstreamer even if I have installed Glib 2.32
getting error as mentioned above


All times are GMT -5. The time now is 07:11 AM.